Raspi 3b will nicht ins WLAN, war aber vorher schon da

  • Ich habe meinen Raspi 3b mit neuer SD Karte und PiCore 9.1 versehen, und wollte den dann nun weiter nutzen. Bisher war PiCore 8.2 drauf, und das lief per WLAN schon einige Zeit ohne ein Problem. Nun bekomme ich den Pi absolut nicht ins WLAN eingebunden.

    Daten dafür sind richtig eingetragen, beim Test findet er auch das WLAN problemlos, bekommt aber irgendwie keine IP von der FRITZ!Box . Das ist, was ich nicht verstehe. Der Raspi war ja schon lange vorhanden. Müßte der nicht trotzdem die gleich MAC Adresse haben, wie vorher mit Picore 8.2? Nur per Kabel geht er ins Netzwerk.
    Hat wer eine Idee, warum, oder wodurch das passieren könnte?

    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • Du hast doch auf der gui die info gehabt er bekommt keine ip.

    Stell ihm testweise ne feste eine oder mach das mit der lease time auf der fritze wie angesprochen.

    btw.: Läuft der DHCP auf der Fritze oder auf dem Adguard?

    das Einzige was am Ende zählt ist
    dass ihr lebt was ihr liebt und liebt wofür ihr lebt


    Kodi HTPC - W11 | AMD Athlon 3000G | Pioneer A 504R Bj. 96
    OMV NAS - NAS | Emby Server | LogitechMediaServer
    3x Logitech SqueezeBox & 3x RasPi PiCorePlayer
    Loxone SmartHome

  • Der Raspi war ja schon lange vorhanden. Müßte der nicht trotzdem die gleich MAC Adresse haben, wie vorher mit Picore 8.2? Nur per Kabel geht er ins Netzwerk.

    Nein. Müsste er nicht. Wie oben schon erwähnt, ändere mal die Lease-Time. Mir ist sowas auch schon passiert als ich die Range der IP Adressen die per DHCP vergeben werden dürfen, eingeschränkt habe. Die eingestellte Lease-Time hat die IP für das "alte" Gerät mit dem alten Betriebssystem reserviert und es war keine andere mehr frei.

    Das Löschen der Leases wird das wieder "gangbar" machen. Oder, wie oben gesagt, nimmst du eine feste IP. Nur drauf achten, dass die IP noch nirgends vergeben ist.

  • Die Mac ändert sich eben nicht da Hardwaregebunden.

    Siehe: https://de.wikipedia.org/wiki/MAC-Adresse

    Die MAC-Adresse ist die Hardware-Adresse jedes einzelnen Netzadapters, die als eindeutiger Identifikator des Geräts in einem Rechnernetz dient. Man spricht auch von physischer Adresse oder Geräteadresse.

    Wenn Dein Betriebssystem PiCore aber in den Systemeinstellungen eine Möglichkeit bietet eine zufällige MAC zu generieren wie zum Beispiel bei IOS würden ich die Funktion als erstes deaktivieren.

    Ansonsten kann sich eine Hardwareadresse nur mit dem tausch der Hardware, also des Netzwerkadapters ändern.

    Am besten rufst Du erst einmal die Terminal Eingabe auf und fragst per Befehl ab welche Daten Deine Hardware liefert.

    In Linux ginge das per ifconfig.

    Siehe: https://www.howtoforge.de/anleitung/linux-ifconfig-befehl/

    Da könnte man die eingetragen MAC in dem Router mit der MAC des WLan Adapters Deines Raspi vergleichen um den Fehler einzugrenzen.

    Edited once, last by Joerg1909: Satz hinzugefügt: Da könnte man die eingetragen MAC in dem Router mit der MAC des WLan Adapters Deines Raspi vergleichen um den Fehler einzugrenzen. (June 11, 2024 at 12:03 AM).

  • Du hast doch auf der gui die info gehabt er bekommt keine ip.

    Stell ihm testweise ne feste eine oder mach das mit der lease time auf der fritze wie angesprochen.

    btw.: Läuft der DHCP auf der Fritze oder auf dem Adguard?

    Lease in der Fritze habe ich auf 1 Tag gestellt.

    DHCP läuft auf der Fritze.

    Wie vergebe ich dem Raspi nachträglich eine fest IP? Auch in der WLAN Config Datei?

    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • Immernoch keine Änderung dadurch? mist

    Wifi auf der Fritzbox - hast du für 2,4 und 5ghz eine SSID? Komisch das esjetzt auf einmal nicht geht... wäre ein Versuch für 2,4ghz mal eine andere SSID zu setzen, nur zum Test, und gezielt diese zu Nutzen.

    Auf der Main Seite gibts Beta Features - da kannst du die IP Setzen. Was ich jetzt schon ab und zu hatte - unter wifi settings ganz unten die network wait time mal höher setzen.


    ansonsten ggf das Wifi kaputt? :( Nochmal mit nem älteren Image prrobieren?

    das Einzige was am Ende zählt ist
    dass ihr lebt was ihr liebt und liebt wofür ihr lebt


    Kodi HTPC - W11 | AMD Athlon 3000G | Pioneer A 504R Bj. 96
    OMV NAS - NAS | Emby Server | LogitechMediaServer
    3x Logitech SqueezeBox & 3x RasPi PiCorePlayer
    Loxone SmartHome

  • Hab jetzt mal WiFi wieder nur eins gemacht, Router und alles andere neu gestartet. Wird der Raspi noch immer nicht gefunden. Habe jetzt mal Kabel dran, damit ich die Oberfläche sehen kann. Schaue mir mal den WiFi - Breich an, ob ich da eine IP vergeben kann. Was ich nicht verstehe: Auf der Seite WiFi kann man ja mal einen testscan machen. Da wird alles gefunden. Also kann WiFi am Raspi ja nicht defekt sein, oder?

    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • Sehe gerade, nach dem Neustart des Raspi mit Kabel, da steht auf der WiFi Seite des PiCore aufeinmal eine IP für WLAN:


    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • Nochmal neu gestartet, jetzt ist er wieder per WLAN zu erreichen und läuft. Kommt evtl. PiCore 9.1 nicht mit den unterschiedlichen WLAN Bezeichnungen plus MESH von der Fritte nicht zurecht? Egal, läuft wieder, Kabel einpacken :) Danke Jungs.

    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • So ein "Vorteil" hat das Ganze: Jetzt kommt mein Squeezebox Radio nicht mehr ins WLAN [ai] Musste es neu verbinden, Schlüssel eingegeben, und es kommt: Kann nicht verbunden werden. Super...[am]

    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • Boogie2005

    Nutzt du pCP 9.1 32 oder 64 Bit ?

    Ich hätte das WLAN nicht geändert , sondern 8.2 nochmal versucht.

  • Boogie2005

    Nutzt du pCP 9.1 32 oder 64 Bit ?

    Ich hätte das WLAN nicht geändert , sondern 8.2 nochmal versucht.

    Nutze 9.1, vorher 8.2. Hatte aber die SD Card schon neu geflasht mangels Menge an Karten ;)

    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • 32 oder 64 Bit?

    Ich hatte mit der 64er bei Jivelite so meine Probleme ....die 32er lief dann.

    Evtl gibt es so etwas auch bei WLAN...?

    Wobei...ich lese gerade du nutzt einen Raspberry 3....da nutzt du wahrscheinlich ohnehin die 32 Bit Version?

  • Ehh sorry, 32 BIT ist drauf jetzt.

    Display Spoiler

    Client: Nvidia Shield 2019 Pro Kodi 20.1, AVR Sony STR-DN 1080, Nubert NuBox Series 5.1, LG TV 55SM8600 Nanocell
    Musik über Pi4 mit Picore 8 und LMS am AVR.
    Gästezimmer:Shield TV 2017 Kodi 20.1
    Server: unRaid; Fractal Des. Define 7;Asrock B365M PROF-4, Intel i3-8100, 16GB RAM und 20TB Platten,
    Arbeitstier: DeepSilence 4, AX370M, AMD Ryzen 5 2600X; 8GB RAM, Samsung M2 970EVO 500GB, RX560 Grafik

  • Sehe gerade, nach dem Neustart des Raspi mit Kabel, da steht auf der WiFi Seite des PiCore aufeinmal eine IP für WLAN:


    ist diese MAC auch in der Fritzbox eingetragen ?

    ist evt. MAC-Filterung aktiv ? (Siehe attached screenshot)

    wenn ja, mache die mal auf, verbinde deine Geräte mit der Fritzbox, danach Mac-Filter wieder zu.

    Oder via Button "Wlan-Gerät hinzufügen"

    P.S. Spielen am Mac-Filter startet das WLAn neu, also dauert einen Moment (sichtbar mit klicken auf "Funkkanal" [siehe screenshot])

    ===

    hatte, hauptsächlich bei der Fritzbox 7490 (?), Probleme mit Wlan-Connects, wenn ein Gerät im Gast-WLan war und dann ins Non-Gast-Wlan wollte und vice versa. Dann war ein Löschen des Wlan-Gerätes aus der FB und ein reboot der Fritzbox angesagt.

  • Ist denn vieleicht der dhcp bereich für beide WLANs zu klein?

    wenn ein Gerät im Gast-WLan war und dann ins Non-Gast-Wlan wollte und vice versa. Dann war ein Löschen des Wlan-Gerätes aus der FB und ein reboot der Fritzbox angesagt.

    --------------
    Guides nicht mehr verfügbar wegen Youtube unvermögen guten von schlechten Kodi Videos zu unterscheiden.

  • Ist eigentlich komisch weil "theoretisch" aufgrund des voreingestellten MAC Wechsels beim neu einloggen in ein WLAN es keinen Unterschied machen sollte.

    --------------
    Guides nicht mehr verfügbar wegen Youtube unvermögen guten von schlechten Kodi Videos zu unterscheiden.

  • Ist eigentlich komisch weil "theoretisch" aufgrund des voreingestellten MAC Wechsels beim neu einloggen in ein WLAN es keinen Unterschied machen sollte.

    "voreingestellten MAC Wechsels beim neu einloggen" verstehe ich nicht !

    ja, "sollte" ...

    scheinbar verbandelt die FB im laufendem Betrieb, die jeweilige SSID, MAC, MAC-Filter, IP oder ein Kombi davon miteinander, sodass ein SSID-Wechsel so nicht möglich war.

    gesehen bei 2x 7490 mit älteren FW's

    Keine Ahnung, ob gefixed in Neueren

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!