Kodi 20.2, Fire TV Stick, keine externe Datenbank mehr

  • Hallo Zusammen,

    ich habe das Update Kodi 20.2 auf meinem Fire TV Stick installiert. Nach dem Neustart, war meine komplette externe Datenbank nicht mehr erreichbar. Habe alles neu aufgesetzt, inkl. der [definition='2','1']advancedsettings[/definition].xml. Leider wird keine neue Datenbak in phyMyAdmin installiert. Ich sitze da jetzt schon drei Tage vor und komme keinen Schritt weiter. Ich verwende einen NAS - WD My Cloud EX2 Ultra.

    Ich habe mal meine [definition='2','1']advancedsettings[/definition].xml angehängt. Vielleicht ja einer von euch die Lösung.

    Ich weiß einfach nicht, was ich falsch mache? Ich habe Kodi genau wie immer neu installiert und eingerichtet, dann die [definition='2','1']advancedsettings[/definition].xml hinzugefügt, Kodi neu gestartet und alles ist wie immer schön. Nur jetzt nicht mehr und ich weiß nicht, warum die Datenbank nicht erstellt werden kann. Die entsprechende [definition='1','2']kodi.log[/definition] liegt ebenfalls im Anhang.

    Vielen Dank schon mal.

  • @darkside-40

    Angehängt Bilder von phpMyAdmin. Sieht für mich alles richtig aus. Oder? Die Rechte für "media" sind doch richtig vergeben.

    #Ich würde noch mal IP und Port überprüfen und schauen ob die DB auch auf anderen Interfaces als dem Loopback Interface des NAS horcht.

    Wie mache ich das? Ich bin jetzt nicht so der Computermensch.

  • In der [definition='2','1']advancedsettings[/definition].xml steht:

    2023-10-25 18:07:30.849 T:9528 info <general>: ES: Starting UDP Event server on port 9777 - Ich habe in der [definition='2','1']advancedsettings[/definition].xml den Port 3306 stehen.

    2023-10-25 18:07:30.850 T:9528 info <general>: UDP: Listening on port 9777 (ipv6 : false) - Ich habe auf meinem NAS gesehen, dass der IPv6 Netzwerkmodus deaktiviert ist. Wie aktiviere ich diesen?

    Kann es daran liegen? Wenn ja, was muss ich machen? Den Port kann ich ja leicht umschreiben, in der *.xml. Aber wie aktiviere ich den IPv6 Netzwerkmodus und wo?

    Muss eventuell in der Fritz!Box unter Internet/Freigaben/Portfreigaben mein NAS hinzugefügt werden? War allerdings bis vor ein paar Tagen auch nicht der Fall und es hat alles super und einwandfrei funktioniert.

  • Ich habe die Zugangsdaten wieder und wieder geprüft, ich finde keinen Fehler.

    Ich habe den Port geprüft, der ist 3306.

    Ich finde keine Fehler in der [definition='2','1']advancedsettings[/definition].xml. Schreibfehler werden ja gerne mal übersehen.

    Ich habe IPv6 auf meinem NAS aktiviert. Leider ebenfalls ohne Erfolgsergebnis.

    Ich habe meinen NAS neu gestartet, 2 mal. Auch das hat nicht zum Ziel geführt.

    Ich weiß nicht, was ich noch machen kann/soll? Ich brauche wirklich eure Hilfe.

  • Was mich auch irgendwie irritiert, ist, dass ich 127.0.0.1 (lokalhost) im Log-File sehe. Darf das überhaupt sein?

    Ich habe doch eine konkrete IP-Adresse eingetragen.

    Ich komme vom Bau und kann da mireden. Aber gerade jetzt? Man, das nervt. Vor ein paar Tagen war noch alles in Ordnung und jetzt funktioniert gar nichts mehr.

    Hat irgendwer eine Idee?

  • 1. Geduld. Jeder hier hat ein privatleben und macht das in seiner Freizeit als Hobby hier ;)

    2. Statt immer wieder neue Beiträge zu erstellen nutze doch bitte den Bearbeiten knopf wenn du informationen hinzufügen willst ...


    Wie aus deinen Screenshots ersichtlich passt das Thema IP schon einmal. Zu dem Rest kann ich dir aktuell aber leider nicht helfen da ich keine MySQL für kodi einsetze. Wenn sich aber morgen auch keiner meldet schaue ich mal was ich machen kann.

    das Einzige was am Ende zählt ist
    dass ihr lebt was ihr liebt und liebt wofür ihr lebt


    Kodi HTPC - W11 | AMD Athlon 3000G | Pioneer A 504R Bj. 96
    OMV NAS - NAS | Emby Server | LogitechMediaServer
    3x Logitech SqueezeBox & 3x RasPi PiCorePlayer
    Loxone SmartHome

    Edited 2 times, last by noob_at_pc (October 25, 2023 at 7:59 PM).

  • 2023-10-25 18:07:30.849 T:9528 info <general>: ES: Starting UDP Event server on port 9777 - Ich habe in der [definition='2','1']advancedsettings[/definition].xml den Port 3306 stehen.

    Der UDP Eventserver hat nichts mit deiner Datenbank zu tun

    2023-10-25 18:07:30.850 T:9528 info <general>: UDP: Listening on port 9777 (ipv6 : false) - Ich habe auf meinem NAS gesehen, dass der IPv6 Netzwerkmodus deaktiviert ist. Wie aktiviere ich diesen?

    Isst irrelevant und hat wieder nichts mit deiner Datenbank zu tun

    Hast du mal versucht die Windows-Firewall abzuschalten?

    Kannst du dich per SSH auf das NAS verbinden und dort dann das Kommando: netstat -tulpen absetzen und uns die Ausgabe zeigen?

    Wenn du auf deinem Windows-Rechner curl installieren könntest, dann könntest du mal folgendes von der Kommandozeile versuchen: curl -v -k 192.168.178.53:3306.

    Das Kommando macht einen Request an die IP mit dem Port. Ich habe mir gerade mal eine MySQL auf meinem Rechner in einem Docker hoch gefahren und die Ausgabe von dem "curl"-Befehl sollte dann ungefähr so aussehen:

    Wenn auf Port "3306" nichts lauschen würde, dann würde es so aussehen (hier habe ich dann einfach mal einen anderen Port angegeben):

    Code
    curl -v -k 127.0.0.1:3307
    *   Trying 127.0.0.1:3307...
    * connect to 127.0.0.1 port 3307 failed: Verbindungsaufbau abgelehnt
    * Failed to connect to 127.0.0.1 port 3307 after 0 ms: Verbindungsaufbau abgelehnt
    * Closing connection 0
    curl: (7) Failed to connect to 127.0.0.1 port 3307 after 0 ms: Verbindungsaufbau abgelehnt

    Du könntest auch einen MySQL Client auf deinem Windows-Rechner installieren. Wenn du es über die Kommandozeile machen. Das wäre dann sowas wie: mysql -h 192.168.178.53 -u media -p. Dann sollte eine Abfrage nach dem Passwort kommen und du könntest dich so über die Kommandozeile zu deiner MySQL verbinden.

    #für Login und Zugriff - geprüft und ist richtig, würde ja sonst nicht auf die Anwendung phpMyAdmin gelangen

    Das stimmt nur bedingt. Grundlegend hast du damit schon mal geprüft, dass Username und Passwort passen. Nicht aber der Zugriff bzw ob der Port stimmt. Denn PHPMyAdmin läuft auf dem gleichen NAS wie die MySQL und nutzt daher auch die 127.0.0.1. Wir müssen feststellen, warum der Zugriff "von außen" (also von deinem Windows-Rechner) nicht geht. Da würden uns die oben genannten Kommandos auf jeden Fall etwas mehr Licht ins Dunkel bringen.


    ich habe das Update Kodi 20.2 auf meinem Fire TV Stick installiert.

    und wir sollten uns auch einig werden von welchem Gerät wir sprechen. Hier sagst du, dass es dein FireTV Stick ist. Das Kodi-Logfile zeigt aber eine Windows-Installation:

    Running on Windows 10 22H2

    Um dem Problem auf die Spur zu kommen müssen wir sehr penibel mit dem sein, was wir sagen und was wir tun. Du sagst, dass du das entsprechende Log angehangen hast. Das stimmt in dem Fall nicht. Du hast nicht das "entsprechende" Log vom FireTV angehangen. Der könnte potentiell einen anderen Fehler aufweisen...das wissen wir aktuell nicht, da du uns ein anderes Log präsentiert hast.

    Wenn alle Stricke reißen, dann schick mir deine Telefonnummer per PN, wir telefonieren und verabreden potentiell einen Zoom-Call oder ein Google-Meet und dann leite ich dich da durch. Wird keine Raketenwissenschaft sein ;) Ist meistens nur von der Konfig her irgendwas falsch.

    Wisse auch, dass Kodi 19 eine andere Datenbank als Kodi 20 verwendet. Diese Datenbanken sind nicht kompatibel. Es kann also sein, dass du potentiell deine Datenbank neu aufsetzen musst. Der Zugriff sollte aber erstmal klappen.

  • Oh, ja, dass stimmt. Ich habe Kodi auf meinem Rechner installiert, weil die Eingaben einfacher sind. Anbei nun aber das richtige kodi.log-File, von meinem Fire TV Stick. Sorry, habe nicht nachgedacht.

    Es wurde auch gefragt, ob ich phpMyAdmin auf meinem NAS ausführe: ja. Wüsste gar nicht, wie ich es anders machen sollte.

    Was die erwähnten Kommandos angeht, würde ich ja gerne machen. Aber ich weiß nicht wie. Ich starte noch mal den NAS neu. Hat leider wieder nix gebracht. Siehe Anhang.

  • Es wurde auch gefragt, ob ich phpMyAdmin auf meinem NAS ausführe: ja. Wüsste gar nicht, wie ich es anders machen sollte.

    Was die erwähnten Kommandos angeht, würde ich ja gerne machen. Aber ich weiß nicht wie. Ich starte noch mal den NAS neu. Hat leider wieder nix gebracht. Siehe Anhang.

    Wenn Dein DB-Server "nur Zugriff von lokalhost/127.0.0.1" zu lässt (bind-address = 127.0.0.1), dann kann sich der DB-User media "nicht von außerhalb einloggen".

    Du kommst also mit PHPMyAdmin von "lokalhost/127.0.0.1" von Deinem NAS, und öffnest eine DB auf dem selben lokalhost/127.0.0.1, insofern klappt der aktuelle Login. Deine Clients/FTVs u.s.w. befinden sich hoffentlich in der IP-Range (192.168.178.0-255) vom NAS, und das NAS hat ein statische IP.

    Es gilt also zu prüfen, in der my.cnf der Parameter "bind-adress" gesetzt ist. Ist das der Fall, kann dieser durch auskommentieren "# bind-address = 127.0.0.1" deaktiviert werden. Auf meiner Synology ist dieser Parameter per Standard nicht aktiviert. Und noch ein mal der Hinweis ->nach dem DB-Server Setup "NAS neustarten"!

    Ob generll der Zugriff auf den DB-Server funktioniert, kann sehr einfach mit dem portablen Windows-Tool "HeidiSQL" getestet werden. Tool starten, NAS-IP, DB-UserName und Passwort eintragen und auf "öffnen" gehen. Öffnet nichts, und man bekommt eine Fehlermeldung, dann stimmen entweder die Zugangsdaten nicht, oder der DB-Server lässt den Login nur von lokalhost/127.0.0.1 zu, s.o..

    Bei meiner MariaDB Installation auf dem Synology NAS, kann/muss die TCP/IP-Verbindung mit dem gewünschten Port (3306) aktiviert werden.

    Im Anhang die [definition='2','1']advancedsettings[/definition].xml sortiert mit Deinen DB-Datenbank Zugangsdaten, kannst Du ggf. testen.

  • Noch etwas zum SMB-Protokoll.

    "<to>smb://media:cNM5nNUpqzc83nx@192.168.178.53/Public/200_Thumbnails/</to>"

    Ich gehe davon aus, das Dein NAS mindestens SMBv2 kann, bzw. Du das entsprechend aktiviert hast.

    Insofern solltest Du in den Kodi-Einstellungen "Dienste" entsprechend min/max SMBv2/SMBv3 einstellen.

  • Ok, habe ich ausprobiert und ich habe die Meldung "Can't connect to server on '192.168.178.53' (10061)" erhalten. Mist!

    Wo finde ich die my.cnf-Datei, um das entsprechende Parameter auszukommentieren? In Kodi? Wenn in phpMyAdmin, habe ich keine AHnung, wie ich da rankommen soll.

    Und ja, meine IP-Range ist im Bereich von 192.168.178.1 bis (derzeit) 192.168.178.60.

    Die Zugangsdaten habe ich nun mehrfach geprüft, ich finde keinen Fehler. Alle Anmeldungen funktionieren, ob am NAS oder phpMyAdmin. Die Eingabe Localhost habe ich bei der [definition='2','1']advancedsettings[/definition].xml auch ausprobiert, bin mir nicht sicher, ob ich es richtig eingetragen habe, aber ich bekomme auch damit keinen Zugang zur Datenbank. Was müsste ich den bei "host" eintragen? Wäre ja dann nur dort oder?

  • Die Eingabe Localhost habe ich bei der [definition='2','1']advancedsettings[/definition].xml auch ausprobiert, bin mir nicht sicher, ob ich es richtig eingetragen habe, aber ich bekomme auch damit keinen Zugang zur Datenbank. Was müsste ich den bei "host" eintragen? Wäre ja dann nur dort oder?

    Kodi ist Dein Client, und die "bind-adress" Einstellung/Parameter findest Du auf dem DB-Server in der my.cnf Datei.

    Vielleicht arbeitest Du einfach mal das komplett ab, was ich Dir geschrieben bzw. vorgeschlagen habe, Stichwort "HeidiSQL" Tool + Screenshot bez. TCP/IP + Kodi-SMB, damit verschaffst Du dir Klarheit, ob ein Login auf den DB-Server mit Deiner derzeitigen Konfiguration von außerhalb von localhost überhaupt möglich ist. [dq]

    Danach kommt dann die Sache mit der "my.cnf"

    Noch einmal zu "Alle Anmeldungen funktionieren, ob am NAS oder phpMyAdmin.", -> Dein phpMyAdmin-Login kommt vom "localhost", Dein Windows/FTV-Client Login "NICHT" [bc]

    Edited 4 times, last by catshome (October 26, 2023 at 2:24 AM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!