LibreELEC 11 am TV - HDMI in Kodi (Nexus) kein audio-Device

  • Ich habe bisher auf einem Raspi4 LibreELEC 9.x(?) mit Kodi 18.9 am TV genutzt (ohne Probleme). Aber 1 von mir genutztes Addon benötigt inzwischen zwingend mindestens die Nexus-Version.

    Doch bei allen Versuchen mit LibreELEC 11 (mehrfache Tests, auch 1x mit der 12er), OSMC (nur 1 Test) wird HDMI nicht als Audio-Device gefunden.

    Ich quäle mich nun schon seit 2 Wochen damit rum und habe keine Idee mehr. [bw]

    Setze ich die alte SD, mit der alten Installation ein, geht es wieder - da kann ich unter Audio aber auch RPI:HDMI auswählen, d.h. Raspi,TV, Kabel, HDMI-Anschluss sind ok. Bei der neuen gibt es nur "Default Bluetooth Audio (Pulseaudio)".

    Änderungen in der config.txt :

    Code
    # keine Verbesserung hdmi_force_hotplug=1
    #zwingend notw. f. TV/Monitor u. Sound = Einstellungen wie bei alter, funktionierender Version
    hdmi_group=2
    hdmi_mode=82
    hdmi_drive=2
    # keine Verbesserung config_hdmi_boost=5
    # keine Verbesserung hdmi_force_edid_audio=1
    # keine Verbesserung hdmi_force_mode=1

    Ansonsten musste ich in der distroconfig.txt noch den Eintrag disable_fw_kms_setup=1 auskommentieren, weil sich sonst der Bootvorgang immer aufgehängt hat.

    Hat jemand hier noch eine Idee, wie ich Nexus HDMI als audio-Device wieder "unterjubeln kann"?

    Andernfalls würde ich jetzt doch langsam aufgeben... [dg]

  • Ohne die Einträge bleibt der Monitor schwarz [ad]

    Habe mir jetzt noch ein neues Kabel bestellt - obwohl das vorhandene mit der alten Version ja funktioniert...

    Wenn auch das nicht hilft, wird es wohl eine andere Hard- u. Software werden müssen... [bn]

  • Danke für die Hinweise. Ich habe mich aber erst nach intensivem Testen durchgerungen hier zu posten - SD-Tausch, verschiedene Image-Writer (am Ende bin ich bei Raspi-Imager geblieben) sowie Test an TV und Monitor (beide mit internem Lautsprecher) waren da schon inklusive.

    Wenn don recht hat, kann es ja fast nur noch am Kabel liegen... "schau 'mer mal" *P

    Sobald ich das neue Kabel testen konnte, gebe ich hier nochmal Feedback.

  • So. Neues Kabel getestet und es ist genau wie von don beschrieben - ich musste tatsächlich gar nichts (in der config.txt) ändern; es hat alles auf Anhieb geklappt.

    Die Erkennung/Unterstützung der TV-Fernbedienung (CEC) scheint mir mit der neuen Version noch smarter zu funktionieren (beachten der Start-Reihenfolge erst Raspi, dann TV für Erst-Erkennung, wie bei der alten Version, war mit der 11er und dem neuen Kabel auch nicht mehr nötig). [bo]

    (Thread kann als erledigt geschlossen werden - habe keine Option gefunden, das hier selbst auszulösen.)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!