[erfolglos erledigt] frage zu wlan-prob beim raspi4 (libreelec, argonone gehäuse)

  • hiho,

    wieder nur mal was für leute, denen langweilig ist. ist also absolut kein notfall!

    ich verwende sowieso lan, aber das fehlerbild würd mich interessieren, ob da wer ideen zu hat.

    hab heute aus langeweile einen alten raspi4 mit libreelec versorgt - soll als notfallgerät dienen, wenn mal eine der shields den geist aufgibt.

    einzige besonderheit: ein altes (nicht mehr supportetes) argonone gehäuse, bei dem ich mit viel sucherei im netz dann doch noch den lüfter steuern konnte.

    das war die erfolgreiche der 1000 anleitungen: https://forum.libreelec.tv/thread/21302-a…5436#post165436

    jetzt der schmäh:

    lan ... rennt problemlos

    wlan 2.4 ghz ... rennt auch problemlos

    wlan 5 ghz ... rennt nicht, ging aber anfangs ... würde sagen, hat rund 3 reboots überlebt.

    einziger fehler, den ich sehe: er hatte auf einmal probleme beim aushandeln von irgendwas, oder wollte das wlan-pwd neu haben. die fritte meint einfach, er ist nicht online. ich kann jederzeit auf 2.4ghz und lan umstellen im betrieb. er sieht auch die 5ghz version meiner fritte immer als idle. nur anmelden kann er mich wohl nicht.

    wer mir sagt, wo ich genau was nachlesen kann ... bitte. eh schon wissen: ich und linux sind todfeinde *g*

    wer den fehler kennt --> bin für jeden info empfänglich.

  • Hast du mal versucht den Pi aus der Liste der "bekannten Geräte" aus der Fritte raus zu werfen und schauen obs dann wieder geht?

    Hast du für 2,4 und 5 unterschiedliche SSIDs?

    Wertschätzung kostet nichts, aber sie ist von unschätzbarem Wert.

  • Hallo,

    ist auf der Fritzbox im Bereich "Sicherheit", "Verschlüsselung", "Weitere Sicherheitseinstellungen" die Option "Unterstützung für geschützte Anmeldungen von WLAN-Geräten (PMF) aktivieren" eingeschaltet?

    Deaktiviere diese mal und versuch dann noch mal.

  • Hast du mal versucht den Pi aus der Liste der "bekannten Geräte" aus der Fritte raus zu werfen und schauen obs dann wieder geht?

    Hast du für 2,4 und 5 unterschiedliche SSIDs?

    ja, 3 mal

    ja, 2 verschiedene ssid's, sehr ähnliche namen und gleiches pwd (sonst schaffts mein saugbot nicht, das netz zu wechseln)

    Hallo,

    ist auf der Fritzbox im Bereich "Sicherheit", "Verschlüsselung", "Weitere Sicherheitseinstellungen" die Option "Unterstützung für geschützte Anmeldungen von WLAN-Geräten (PMF) aktivieren" eingeschaltet?

    Deaktiviere diese mal und versuch dann noch mal.

    die ist ein ... muss ich heute nachmittag probieren dann mal

    scheint aber auch WLAN-Probleme mit der ein- oder anderen Gehäuseversion zu geben: https://www.martinrowan.co.uk/2021/06/argon-…ssues-resolved/

    Vielleicht auch noch mal in die Richtung testen, je nach dem was vorliegt.

    wie g'sagt: es ging ja, ich war problemlos im wlan auf 5 ghz, bis ich mal fertig war mit allem "wichtigen" unter kodi. testweise hab ich schon meine nas nach filmen abgegriffen (erfolgreich und sehr flott). aja, das gehäuse ist das ganz alte ... also nix mt zusatzspielchen, wie im link *g*.

    also mal libreelec selber alles einstellen,

    im kodi die ganzen unterstützenden module von libreelec für den pi, netzwerk, ... installieren,

    daraufhin oben erwähnte steuerung für den venti aufsetzen,

    freuen, dass er funzt und feststellen, dass 5ghz wlan probleme beim aushandeln hat.

    btw.:

    gabs da ned übrigens mal vor langer zeit ein kodi-modul fürs einstellen des argonone? finds nicht mehr, war aber auf jeden fall das letzte mal gesehen vor der großen seuche, deren name nicht erwähnt werden darf *g*

  • Hallo,

    ist auf der Fritzbox im Bereich "Sicherheit", "Verschlüsselung", "Weitere Sicherheitseinstellungen" die Option "Unterstützung für geschützte Anmeldungen von WLAN-Geräten (PMF) aktivieren" eingeschaltet?

    Deaktiviere diese mal und versuch dann noch mal.

    du scheinst wohl recht zu haben (hab mal "händisch" in der fritte das protokoll durchsucht, die scrollerei gestern war wohl der fehlerfindung nicht zuträglich *g*):

    von unten nach oben zu lesen ... ab da ging dann nur mehr 2.4ghz

    das dumme: wenn ich das nu abschalte und es geht, hab ich nix gewonnen, weil ich würd's ned dauerhaft abstellen ... frag mich grade, wie ich den pi wieder aus der sperre raus krieg?

  • jo, hab einfach das neueste le für den pi4 gestern gesaugt und d'rauf geworfen.

    aber danke für den link - immerhin kann ich mal von ausgehen, dass der pi wohl nix hat. is mir mal das wichtigste.

    ein echter "5ghz test" ohne pmf kommt noch - bin heute nur so extrem unmotiviert *g* vor allem, weils ja so 100% zum problem passt, was die so schreiben.

    zum glück is es mir eh nicht wichtig. lan ist standard und 2.4ghz würden für z.b. updates auch reichen.

    wlan is bei mir eh nur notfall, oder zwang vom hersteller *g*

    ich frag’ mich aber immer noch, woran genau es liegt - ich glaub’, ich werd’ mal die ganze helferlein-mods für netzwerk und hw aus dem kodi werfen - die pi-tools sind halt wieder wegen des lüfters zwingend notwendig.

  • ohne da jetzt ganz tief in die Materie einzusteigen, scheint das auch generell ein größeres Problem mit WPA3 beim RPi zu sein und in WPA3 ist PMF ja verpflichtend.

    Wi-Fi Protected Access 3 (WPA3) support · Issue #4718 · raspberrypi/linux
    I bought a Raspberry Pi Zero 2 W and apparently it does not support my home wifi which uses WPA3. I excepted that to be the case, since on Debian usually works…
    github.com

    Die Sache mit PMF war mir jetzt persönlich nie aufgefallen, da ich meinen RPi 4 auch nur per LAN betreibe und WLAN dort noch nie benutzt habe.

    Auf was steht denn dein WPA-Modus? "WPA2 (CCMP)" oder "WPA2+WPA3"?

    Bei WPA2 ist PMF wohl optional, das könntest du auch noch mal testen, wenn du nur "WPA2 (CCMP)" einstellst statt dem WPA3-Transition-Mode "WPA2 + WPA3" und PMF aktiviert lässt, ob es dann nicht genutzt wird beim RPi.

    Edited once, last by joschi77 (January 29, 2024 at 6:01 PM).

  • is mir doch auch nur aufgefallen, weil ich aus purer faulheit kein lan verlegen wollt zum aufsetzen.

    mein problem wäre eh nur gewesen, wenn der pi hw-probs gehabt hätte. wäre blöd, wenn ein notfall-tool im notfall ned geht *lach*

    ich hatte übrigens noch wpa2(ccmp) eingestellt gehabt, jetzt dann mal wpa2+wpa3 umgestellt. mal schauen, was der raspi dazu sagt ... morgen, oder so.

    müsste lt. dir und div. seiten ja heißen: wpa2 kriegt er auch ohne pmf hin. ich bin also voller hoffnung.

    ich glaub’, man sollte irgendwann mal die ganzen hilfe-dateien lesen. eventuell wäre man dann g'scheiter.

    könnte auch helfen, weil mein motorola neo ewigkeiten brauchte zum einloggen, wenns auch immer 5ghz hatte. mit wpa2+wpa3 wars grad sofort angemeldet nach der umstellung ...

    das wär den sermon hier alleine schon wert gewesen *g*

    btw - wir hatten hier immer samsung-handys - die hatten solche probleme generell nicht.

  • so, ich geb's auf ...

    hab jetzt jede kombination auf der fritte/pi4 durch. inkl. alles mit geräte löschen, dazwischen rebooten, usw.

    es bleibt immer dabei, dass ich mich im 5ghz nicht anmelden kann, 2.4 aber immer geht. lan sowieso und bt auch.

    mehr aufwand is mir das echt nimma wert ...

    vielen thx auf jeden fall, für eure ideen dazu. vielleicht hat ja noch wer die ultimative lösung, aber ich glaub's ned wirklich *g*

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!