Ton aussetzer in Kodi 19

  • Habe auf Ubuntu-Server 22.04 yavdr-ansible installiert.
    Darin enthalten ist Kodi 19.
    Beim abspielen von Videos von ext. Festplatte habe ich Ton Aussetzer.
    Egal welche Datei ich verwende.
    Bei Live-TV über Kodie ebenfalls.
    Habe sämtliche Einstellungen durchprobiert,aber immer das gleiche,es treten Aussetzer auf
    Habe in Kodi [definition=12,1][definition=12,3][definition=12,5][definition=12,6]debug-Log[/definition][/definition][/definition][/definition] speziell für Audio aktiviert und hänge die Datei an.

    Aufgefallen ist mir folgende Zeile

    2022-12-05 15:59:34.212 T:4610 [definition=12,0][definition=12,4][definition='1','3']Debug[/definition][/definition][/definition] <general>: CDVDAudio::Pause - pausing audio stream

  • Habe auf Ubuntu-Server 22.04 yavdr-ansible installiert.
    Darin enthalten ist Kodi 19.

    Bei allen Problemen diesbezüglich darfst du dich vertrauensvoll an die Maintainer von "yandr-ansible" wenden. Keiner weiß, was die geändert haben.

    Ich würde dir raten Kodi aus den offiziellem Kodi PPA für Ubuntu zu installieren. Ein VDR Binary Add-on gibt es für Ubuntu 22.04 ebenfalls schon aus dem PPA.

    Du hast leider bei yaVDR-Ansible schon falsch angefangen, wie es aussieht: https://github.com/yavdr/yavdr-ansible

    Dort steht schon im zweiten Satz der Read-Me:

    "yavdr-ansible uses Ansible to set up a yaVDR System on top of an Ubuntu 20.04 Server installation "

    Etwas weiter unten:

    "Set up a Ubuntu Server 20.04.x Installation and install openssh-server."

    Man scheint also ein 20.04 anstelle eines 22.04 zu empfehlen. Warum es mit 22.04 nicht so läuft, wie du es dir vorstellst, wissen aber nur die Maintainer dort.

    Viel Glück

    Wertschätzung kostet nichts, aber sie ist von unschätzbarem Wert.

  • Habe mal folgendes ppa probiert

    Code
    ppa:team-xbmc/xbmc-nightly


    und siehe da es funktioniert und der Ton ist absolut stabil.
    Mit dem stable ppa von euch treten wieder Aussetzer auf,ist ja komisch ,oder?

    Code
    ppa:team-xbmc/ppa

    Wieder Aussetzer ohne Ende.

  • Nö. Das ist nicht komisch. Das ist vielleicht einfach ein Bug, der in Kodi 19 noch nicht gefixt wurde aber vielleicht in Kodi 20 schon. Weiter wird wahrscheinlich Kodi 20 auch ein anderes ffmpeg verwenden als Kodi 19

    Du fängst aber jetzt an Themen zu vermischen.

    Zuerst war dein Thema, dass du mit yaVDR und dem darin enthaltenen Kodi Aussetzer hast. Da sage ich dir, dass du dich an die Maintainer wenden sollst.

    Jetzt reden wir von Tonaussetzern mit dem Kodi vom Kodi PPA. Da haben wir noch gar kein [definition=12,7][definition='1','1']debuglog[/definition][/definition] gesehen. Wenn du das aber direkt reproduzieren kannst, dann mach doch bitte einfach hier:

    https://github.com/xbmc/xbmc/issues

    ein Bug-Ticket auf. Beschreibe dein Problem so gut wie möglich mit so wenigen Worten wie möglich. Häng debuglogs von Kodi 19 und Kodi 20 an, die das unterschedliche Verhalten belegen. Wenn du es noch ganz genau machen möchtest, dann fügst du noch einen Video-Schnippsel an, mit dem du das Problem darstellen kannst.

    Oder du bleibst einfach beim Nightly PPA. Da hast du halt nur die Gefahr, dass das auch mal kaputt sein kann, wenn du updatest.

    Wenn du aber auch hier schon Hilfe suchst (wobei ich dir wirklich den Kodi Bug-Tracker ans Herz legen würde in dem Fall), dann brauchen wir auch hier genau die gleichen Logs, wie auf Github.

    Wertschätzung kostet nichts, aber sie ist von unschätzbarem Wert.

  • Danke für den Link,werde die [definition=9,2][definition=9,3]Kodi.[definition='1','0']log[/definition][/definition][/definition] vom stable dort posten.
    Werde dann aber wieder zum Nightly PPA zurück gehen.

    Code
    Wenn du aber auch hier schon Hilfe suchst (wobei ich dir wirklich den Kodi Bug-Tracker ans Herz legen würde in dem Fall), dann brauchen wir auch hier genau die gleichen Logs, wie auf Github

    Ok,werde die Tage das nochmals testen und die [definition=9,2][definition=9,3]Kodi.[definition='1','0']log[/definition][/definition][/definition] zur Verfügung stellen.
    Danke erstmal und schöne Feiertage.Vielleicht schaffe ich es auch früher.

  • Habe nun nach langem testen festgestellt das die Tonaussetzer bei *.mp4 auftreten,wenn ich den gleichen aufgenommenen Stream in *.mkv wandele sind die Tonaussetzer verschwunden.

    Vielleicht ist ja an meiner ffmpeg Befehlzeile was falsch.

    ffmpeg -y -hwaccel cuda -hwaccel_output_format yadif_cuda -i test.ts -map 0 -map -0:s -c:a ac3 -c:v hevc_nvenc -vf eq=gamma=1.1 -preset p7 -cq:v 26 -rc:v vbr -tune hq test.mp4

  • Und die test.ts - spielt die ohne Tonaussetzer?

    Und wenn du ohne Recodierung in mkv wandelst - spielt die ohne Tonaussetzer? ffmpeg -i test.ts -map 0 -c copy -copy_unknown test.mp4

    Kodi 20.5, 17.6, 20.5, 16, 20.5 on Windows 11 Pro, Android 6, Android 12, FireTV Box 2nd Gen, FireTV 4k Max 2nd Gen
    Media on NAS, OpenMediaVault 6 (Debian Linux).

  • Da fällt mir noch auf - bei deinem Recodieren in mp4 hast du ac3 Ton Format generiert. Ich meine mich zu erinnern (ohne Prüfung) dass mp4 normalerweise aac will. Wenn man kein Tonformat forciert, wählt ffmpeg nach meinem Verständnis was zum Ausgabe-Format passendes. (Auch das ohne Prüfung)

    Wie genau hast du das mp4 in mkv gewandelt? Insbesondere - wurde da nochmals recodiert?

    Wenn du ffmpeg hast, hast du vermutlich auch ffprobe. Kannst mal vergleichen, welche Codecs/Formate wirklich in den verschiedenen Dateien drin sind - vielleicht siehst du was Auffälliges. Z.B.: ffprobe test.mp4 und halt auch die .ts und .mkv. Geht auch über mediainfo - ich finde es über ffprobe übersichtlicher. Vielleicht kommt Kodi in deiner Umgebung mit dem Audio-Codec in deiner mp4 gerade nicht zurecht und mit ggf. anderen Codecs in .ts und .mkv schon.

    Kodi 20.5, 17.6, 20.5, 16, 20.5 on Windows 11 Pro, Android 6, Android 12, FireTV Box 2nd Gen, FireTV 4k Max 2nd Gen
    Media on NAS, OpenMediaVault 6 (Debian Linux).

  • Ich wandele nicht mp4 in mkv sondern ts in mkv,der ts stream ist H264.

    Wenn ich an Stelle von ac3 aac verwende erhalte ich einen gruseligen Sound,da hört sich Regen nicht wie regen an sondern quitscht ganz seltsam.

  • Ich sags mal so....typisches Problem mit MP4-Dateien. Mach ne MKV mit Handbrake draus und du solltest glücklich werden. Mit MP4 gibt es schon immer irgendwie Probleme, soweit ich weiß.

    Wertschätzung kostet nichts, aber sie ist von unschätzbarem Wert.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!