TVHeadend Powermanagement für XBMC-Live/XBMCbuntu (11.04-12.04)

  • Als Umsteiger von MythTV wollte ich ein lieb gewonnenes Feature von MythTV auch gerne mit XBMC nutzen.

    Das Timer gesteuerte Aufwachen und Ausschalten des Rechners zu Aufnahmen und EPG Aktualisierungen.

    Ich möchte meine Erfahrungen mit einem Addon, daß diese Aufgabe erledigt mit Euch teilen.

    Man könnte das Ganze auch überschreiben:

    Gefährliches Halbwissen (ich) trifft auf fantastische Software (XBMC)

    Auf meinem System:
    Zotac Mag HD ND 01 per HDMI an einen Philipps TV angeschlossen
    läuft ein Mythbuntu 12.04

    dem ich über diese Anleitung:
    http://www.mythtv.org/wiki/ACPI_Wakeup
    das Aufwachen beigebracht habe

    dann über

    Code
    sudo add-apt-repository ppa:pulse-eight/pulse
    sudo apt-get update
    sudo apt-get install xbmc tvheadend xbmc-bin


    XBMC mit PVR Unterstüzung installiert.

    Auf die Einrichtung von TVHeadend gehe ich jetzt nicht ein.

    Dann habe ich mir hier
    http://www.vdr-portal.de/board60-linux/board62-software/board95-xbmc/108411-announce-tvheadend-powermanagement-für-xbmc-live-xbmcbuntu-11-04-12-04/
    das Addon herrunter geladen und aus der zip Datei installiert.

    Wie dort schon geschrieben steht sollte man die Readme lesen und verstehen, was mir nicht so ganz leicht gefallen ist.
    Der ein oder andere geübte Leser wird wohl über mich schmunzeln oder schlimmeres denken.

    Man muss Besitzer / Gruppenzuordnung und Ausführbarkeit des shutdown Skripes ändern
    Ich benutze hier eigener XBMCNutzer als Platzhalter, das muß natürlich angepaßt werden.

    Code
    cd /home/eigener XBMCNutzer/.xbmc/addons/script.program.pvrmanager/resources/lib/
    sudo chown eigener XBMCNutzer shutdown.sh
    sudo chgrp eigener XBMCNutzer shutdown.sh
    sudo chmod 755 shutdown.sh

    an die sudoers einfach hinten (entgegen der readme – anfügen):

    Code
    Cmnd_Alias PVR_CMDS = /home/eigener XBMCNutzer/.xbmc/addons/script.program.pvrmanager/resources/lib/shutdown.sh
    eigener XBMCNutzer ALL=NOPASSWD: PVR_CMDS

    Das Skript wird per Powertaste der Fernbedienung aktiviert.
    Wenn man das Programm nicht über die definierte Taste beendet macht das Skript natürlich auch nichts.
    Deshalb musste ich, weil ich eine Funktastatur verwende, erst einmal eine Powertaste definieren:
    Ich habe F1 genommen, dafür in
    ~/.xbmc/userdata/keymaps/remote.xml (!):

    unter <global> (vor <remote>)folgendes einfügen:

    Code
    <keyboard>
        <f1>XBMC.RunScript(script.program.pvrmanager)</f1>
    </keyboard>

    Das hat den Vorteil, dass nach einem XBMC-Update die definierten Tasten nicht gelöscht werden, da die remote.xml im "Userspace" nicht überschrieben wird.

    Wenn jetzt ausserdem noch sichergestellt ist, das XBMC auch bei ausgeschaltetem Monitor läuft, was bei mir nicht der Fall war
    dazu habe ich hier :
    http://www.beisammen.de/board/index.ph…726#post1246726
    Hilfe gefunden

    sollte das AddOn nach dem man die entsprechenden selbst erklärenden Einstellungen im XBMC vorgenommen hat funktionieren.

    Ich hoffe, ich habe nichts wichtiges vergessen und langweile die geübten User nicht.

  • Hallo Nerds,

    Ich bin der Programmierer dieses Plugins ;), komme ursprünglich vom VDR-Portal, lese hier schon geraume Zeit mit und habe mich gestern hier aktiv angemeldet. Das Plugin zum Timer-/Powermanagement wurde seit dem letzten Beitrag hier kontinuierlich weiter entwickelt und ist natürlich auch unter Gotham funktionsfähig. Wenn Helix aus dem Alpha-/Betastadium raus ist, werden auch hier - falls nötig - entsprechende Anpassungen vorgenommen. 'Meine' XBMCs (insgesamt 7 Geräte auch im Bekannten-/Verwandtenkreis) laufen übrigens alle mit der Kombi XBMCBuntu + TVHeadend + Plugin absolut zuverlässig.

    Die Diskussion zum Timer-/Powermanagement ist nach wie vor im VDR-Portal zu finden (siehe Post #1), das aktuelle Plugin findet Ihr - neben anderen interessanten Sachen - auf meinem Webserver: http://vdr4bj1.no-ip.org

    Viele Grüße
    BJ1

    AZi (DEV): Nexus auf LibreElec | Asrock J4205 | 4 GB RAM | 128 GB Sandisk| Rii mini
    DEV: PC Ubuntu 20.04 | Matrix
    AZi: Tanix TX3 | Android/CoreElec Dualboot (EMMC), Nexus
    WoZi: Nexus auf LibreElec | Asrock J4205 | 4GB RAM | 128 GB Sandisk SSD | Atric IR | URC7960

    NAS: unRaid, 3x6TB, 2x12TB | TV-Server: Futro S550 mit Hauppauge QuadHD DVB-C
    PayPal: paypal.me/pvdbj1

  • Nur die Ports, mit Komma oder Leerzeichen getrennt.

    AZi (DEV): Nexus auf LibreElec | Asrock J4205 | 4 GB RAM | 128 GB Sandisk| Rii mini
    DEV: PC Ubuntu 20.04 | Matrix
    AZi: Tanix TX3 | Android/CoreElec Dualboot (EMMC), Nexus
    WoZi: Nexus auf LibreElec | Asrock J4205 | 4GB RAM | 128 GB Sandisk SSD | Atric IR | URC7960

    NAS: unRaid, 3x6TB, 2x12TB | TV-Server: Futro S550 mit Hauppauge QuadHD DVB-C
    PayPal: paypal.me/pvdbj1

  • Nein. Das Skript ist auf Bibliotheken angewiesen, die nur XBMC/Kodi bereitstellt. Für headless-Server findest Du bei tvheadend.org einige Skripte. Auch hier hat jemand mal was gepostet, finde ich nur gerade nicht....

    AZi (DEV): Nexus auf LibreElec | Asrock J4205 | 4 GB RAM | 128 GB Sandisk| Rii mini
    DEV: PC Ubuntu 20.04 | Matrix
    AZi: Tanix TX3 | Android/CoreElec Dualboot (EMMC), Nexus
    WoZi: Nexus auf LibreElec | Asrock J4205 | 4GB RAM | 128 GB Sandisk SSD | Atric IR | URC7960

    NAS: unRaid, 3x6TB, 2x12TB | TV-Server: Futro S550 mit Hauppauge QuadHD DVB-C
    PayPal: paypal.me/pvdbj1

  • Würde das Skript auch auf einem Headless TVHeadend Only Server funktionieren?

    Ja ich weiß, dass es ein Kodi Plugin ist, aber dahinter stecken ja Skripte.

    Was genau möchtest du denn erreichen?

    Meine Hardware

    [contentbox]TV-Server/NAS:
    Gigabyte GA-B85M-D2V | Intel G1840 | 4GB RAM | 1x SSD 120GB System | 1x SSD 30GB Kodi Thumbs & mySQL | 3x HDD (9TB) |
    DD Cine S2 6.5 4Tuner | OMV 2.x[/contentbox][contentbox]Backup-Server: AMD Athlon 64 X2 | 1GB RAM | 5,5 TB | OMV 2.x[/contentbox]

    [contentbox] HTPC | Asrock Q1900-ITX | 4GB RAM | 120Gb Samsung SSD | OpenELEC 5.0.8
    2x RasPi 1 | OpenELEC 5.0.8
    RasPi 2 | OpenELEC 5.0.8
    MacBook Pro | Kodi 14.2[/contentbox]

  • Ich würde gerne einen TVHeadend Headless Server so betreiben, dass er automatisch aufwacht und einschläft. Dabei sollen anstehende Timer und auch Aktive Clients berücksichtigt werden. Zudem möchte ich nicht selbst skripten sondern hätte gerne was "fertiges", was diese Bedingungenerfüllt.

  • Dieses Skript weckt meinen Server wenn eine Aufnahme ansteht, der Server aber schläft.
    Unter einem Debian-System gehört das Skript in den Ordner "/etc/pm/sleep.d/"
    Bei mir heißt diese Datei "95_wakeuptimer.sh", das Skript mit ausführbar sein. (chmod +x)

    Der Server darf allerdings nicht ausgeschaltet sein, es sei denn RTC-Wakeup wird aus S5 unterstützt. Das können aber wohl nur wenige Boards. (3 Stück getestet, keines konnte es).

    Zum schlafen legen nutze ich das OMV-Plugin Autoshutdown.

    Meine Hardware

    [contentbox]TV-Server/NAS:
    Gigabyte GA-B85M-D2V | Intel G1840 | 4GB RAM | 1x SSD 120GB System | 1x SSD 30GB Kodi Thumbs & mySQL | 3x HDD (9TB) |
    DD Cine S2 6.5 4Tuner | OMV 2.x[/contentbox][contentbox]Backup-Server: AMD Athlon 64 X2 | 1GB RAM | 5,5 TB | OMV 2.x[/contentbox]

    [contentbox] HTPC | Asrock Q1900-ITX | 4GB RAM | 120Gb Samsung SSD | OpenELEC 5.0.8
    2x RasPi 1 | OpenELEC 5.0.8
    RasPi 2 | OpenELEC 5.0.8
    MacBook Pro | Kodi 14.2[/contentbox]

  • Der Server darf allerdings nicht ausgeschaltet sein, es sei denn RTC-Wakeup wird aus S5 unterstützt. Das können aber wohl nur wenige Boards. (3 Stück getestet, keines konnte es).

    Seltsam. Bis jetzt ist hier jedes Board aus dem S5 aufgewacht. Selbst Exoten, die per Poweroff-Kernel schlafen gelegt werden mussten - allerdings wachen die dann nur per NVRAM auf, ACPI überlebt die Poweroff-Prozedur nicht...

    AZi (DEV): Nexus auf LibreElec | Asrock J4205 | 4 GB RAM | 128 GB Sandisk| Rii mini
    DEV: PC Ubuntu 20.04 | Matrix
    AZi: Tanix TX3 | Android/CoreElec Dualboot (EMMC), Nexus
    WoZi: Nexus auf LibreElec | Asrock J4205 | 4GB RAM | 128 GB Sandisk SSD | Atric IR | URC7960

    NAS: unRaid, 3x6TB, 2x12TB | TV-Server: Futro S550 mit Hauppauge QuadHD DVB-C
    PayPal: paypal.me/pvdbj1

  • Also WOL aus dem S5 konnte jedes Board, aber RTC-Wakeup eben nur aus dem S4.
    Nicht das wir uns missverstehen...

    habs mit 2 AsRocks und einem Gigabyte getestet, keines kann RTC-Wake aus S5.

    Meine Hardware

    [contentbox]TV-Server/NAS:
    Gigabyte GA-B85M-D2V | Intel G1840 | 4GB RAM | 1x SSD 120GB System | 1x SSD 30GB Kodi Thumbs & mySQL | 3x HDD (9TB) |
    DD Cine S2 6.5 4Tuner | OMV 2.x[/contentbox][contentbox]Backup-Server: AMD Athlon 64 X2 | 1GB RAM | 5,5 TB | OMV 2.x[/contentbox]

    [contentbox] HTPC | Asrock Q1900-ITX | 4GB RAM | 120Gb Samsung SSD | OpenELEC 5.0.8
    2x RasPi 1 | OpenELEC 5.0.8
    RasPi 2 | OpenELEC 5.0.8
    MacBook Pro | Kodi 14.2[/contentbox]

  • Wie gesagt, RTC-Wakeup aus S5 heraus war nie ein Thema. Hat immer funktioniert. Für mich (und andere) die zuverlässigste Methode, um einen HTPC pünktlich zur Aufnahme aufwachen zu lassen...

    AZi (DEV): Nexus auf LibreElec | Asrock J4205 | 4 GB RAM | 128 GB Sandisk| Rii mini
    DEV: PC Ubuntu 20.04 | Matrix
    AZi: Tanix TX3 | Android/CoreElec Dualboot (EMMC), Nexus
    WoZi: Nexus auf LibreElec | Asrock J4205 | 4GB RAM | 128 GB Sandisk SSD | Atric IR | URC7960

    NAS: unRaid, 3x6TB, 2x12TB | TV-Server: Futro S550 mit Hauppauge QuadHD DVB-C
    PayPal: paypal.me/pvdbj1

  • Echt komisch...
    Werde es demnächst nochmal testen, auch wenn ich es schon einige male getestet habe.
    Wobei es bei mir mit schlafen gehen in den S4 und aufwachen per RTC-Timer wunderbar klappt!
    Aber interessieren tuts mich ;)

    Meine Hardware

    [contentbox]TV-Server/NAS:
    Gigabyte GA-B85M-D2V | Intel G1840 | 4GB RAM | 1x SSD 120GB System | 1x SSD 30GB Kodi Thumbs & mySQL | 3x HDD (9TB) |
    DD Cine S2 6.5 4Tuner | OMV 2.x[/contentbox][contentbox]Backup-Server: AMD Athlon 64 X2 | 1GB RAM | 5,5 TB | OMV 2.x[/contentbox]

    [contentbox] HTPC | Asrock Q1900-ITX | 4GB RAM | 120Gb Samsung SSD | OpenELEC 5.0.8
    2x RasPi 1 | OpenELEC 5.0.8
    RasPi 2 | OpenELEC 5.0.8
    MacBook Pro | Kodi 14.2[/contentbox]

  • Also mein Asrock N3150M kann laut dmesg auch nur S4 wacht aber Problemlos auf S5 auf.

    Weiterhin gibt es im TVHeadenforum einen Post, der genau das tut was ich mir gewünscht habe. Vielen Dank an BJ1 für den Hinweis.
    Zudem soll das OVM Plugin auf Debian/Ubuntu Systemen lauffähig sein. Und soweit wie ich das Skript überflogen habe sah das aucherstmal gut aus. Das wäre noch eine andere Möglichkeit, da es wesentlich mehr Möglichkeiten und Funktionen bietet, ohne Explizit auf TVH einzugehen. Dass muss man dann eben noch anders lösen.


    Vielen Dank

  • hallo @BJ1
    ich hab eine frage zum TVHeadend Timer/Powermanagement.
    du hast ja vor kurzem ein update rausgebracht welches einiges verändert hat (events startup|login|poweroff|restart)
    bisher hatte ich in meinem tvheadend als post process nach aufnahmen das shutdownscript /resources/lib/shutdown.sh ausführen lassen um den htpc nach aufnahmen runterfahren zu lassen.
    das geht nach dem letzten update nicht mehr.
    man könnte natürlich per kommando normal runterfahren lassen aber dann wird ja kein timer mehr gesetzt, richtig?
    wie hast du das gelöst...vlt hab ich ja nur nen denkfehler?
    es wäre nett wenn du mir da mal auf die sprünge helfen könntest.

  • Am Shutdown-Skript selbst habe ich nichts verändert. Warum lässt Du das Shutdown-Skript durch TVHeadend starten? Normalerweise macht das doch das Addon? Evtl. stimmen die Rechte für die shutdown.sh nicht (sollte ausführbar sein, aber auch das managed das Addon). Ansonsten ist für das Herunterfahren der 'poweroff'-Parameter dazugekommen, der auch in der remote.xml bei RunScript(...) mit eingetragen werden muss. Evtl. hängt's auch daran. Erzähl' mal ein bisschen mehr zu Deiner Konfiguration, wie sieht z.B. der Eintrag für's Postprocessing in TVH aus...

    AZi (DEV): Nexus auf LibreElec | Asrock J4205 | 4 GB RAM | 128 GB Sandisk| Rii mini
    DEV: PC Ubuntu 20.04 | Matrix
    AZi: Tanix TX3 | Android/CoreElec Dualboot (EMMC), Nexus
    WoZi: Nexus auf LibreElec | Asrock J4205 | 4GB RAM | 128 GB Sandisk SSD | Atric IR | URC7960

    NAS: unRaid, 3x6TB, 2x12TB | TV-Server: Futro S550 mit Hauppauge QuadHD DVB-C
    PayPal: paypal.me/pvdbj1

  • Warum lässt Du das Shutdown-Skript durch TVHeadend starten? Normalerweise macht das doch das Addon?


    hmmm....wusste gar nicht dass das addon nach der aufnahme auch ein shutdownbefehl sendet :whistling:

    Evtl. stimmen die Rechte für die shutdown.sh nicht (sollte ausführbar sein, aber auch das managed das Addon).


    rechte passen, gerade nochmal geschaut

    Ansonsten ist für das Herunterfahren der 'poweroff'-Parameter dazugekommen, der auch in der remote.xml bei RunScript(...) mit eingetragen werden muss. Evtl. hängt's auch daran.


    in der remote ist alles auf die neue version angepasst, per fernbedienung (poweroff) meldet sich das addon auch und setzt brav den timer

    Erzähl' mal ein bisschen mehr zu Deiner Konfiguration, wie sieht z.B. der Eintrag für's Postprocessing in TVH aus...


    der postprocessingeintrag war einfach ein ausführen des shutdown.sh scriptes.
    was ich genau da reingebastelt hatte weiss ich nicht mehr und kann es auch nicht kontrollieren da ich htpc komplett umgerüstet (kodi neu gemacht) und das nas gegen nen server ausgetauscht hab.
    ich setz mal ne aufnahme, schalte den htpc aus und schaue nach der arbeit wann und wie er runtergefahren ist....ob durch das timer/power addon oder durch den sleepywatchdog.
    rückmeldung kommt dann heute abend von mir.
    vielen dank schonmal für den support :thumbup:

  • Ich habe mir dieses Plugin installiert. Soweit funktioniert das es sagt halt bald Aufnahmestart nicht ausschalten. Und es wird auch angezeigt das das ein Timer gesetzt wird wenn ich ihn ausschalte. Allerdings mache ich danach ein

    Quote

    cat /proc/driver/rtc

    Sagt er Starte um 12:41 ... wobei die Aufnahme nach 20 uhr ist.
    Logdatei wird nicht erstellt, egal ob Kodi im [definition='1','3']Debug[/definition] modus ist oder nicht.

    Wie kann ich noch feststellen woran es liegt.

    Damit startet er neu wenn ich dieses Script starte aber über das Plugin nicht.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!