Angepinnt Ember Media Manager 1.4.8.0 Alpha - Diskussionsthread

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • mal so eine dringende Bug Warnung:


    Wenn man Ember auf eine hinreichend große Anzahl von Filmen loslässt (Scrapen/Renamen) kommt dann irgendwann (keine Ahnung wann, waren so 4000 oder 5000 Filme, bevor das Chaos losbricht) "Out of Memory Error".

    Das wäre vielleicht nicht so schlimm, wenn Ember dann wenigstens abbrechen würde und den Dienst quittiert.

    Stattdessen läuft die Schleife im Hintergrund weiter und PRODUZIERT NUR NOCH SCHROTT !!!


    Also VORSICHT, wenn ihr nicht wie ich mal eben 1000 und mehr Filme am Stück verlieren wollt!



  • Ja, es war die aktuelle Version von Ember (Alpha5)
    Strg+M, Bulk Renamer händisch gestartet -> Episoden werden umbenannt und in einen neu angelegten Ordner Season01 verschoben.
    Manuell klappt das also, nur nicht automatisch.

    Edit:
    Wähle ich die erste Serie (nachdem sie umbenannt wurde) wieder ab (Strg+M), wähle eine zweite Serie aus, markiere sie (Strg+M), starte den Bulk Renamer -> dann wird mir im Bulk Renamer nicht die zweite Serie angezeigt, sonden die umbenannten Dateinamen der ersten Serie. Das sollte aber do wohl nicht so sein ;)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von TLaufer ()

  • mam schrieb:

    Also VORSICHT, wenn ihr nicht wie ich mal eben 1000 und mehr Filme am Stück verlieren wollt!
    @mam es gehen doch nicht die Filmdateien, nfo und zugehörigen Arts verloren. Wird nur Müll in die Kodi-db geschrieben?
    @DanCooper scheint auf dem Weg der Besserung zu sein, dann hoffen wir mal, dass er nächste Woche dazu kommt, sich das anzuschauen.

    TLaufer schrieb:

    Ja, es war die aktuelle Version von Ember (Alpha5)
    Strg+M, Bulk Renamer händisch gestartet -> Episoden werden umbenannt und in einen neu angelegten Ordner Season01 verschoben.
    Manuell klappt das also, nur nicht automatisch.

    Edit:
    Wähle ich die erste Serie (nachdem sie umbenannt wurde) wieder ab (Strg+M), wähle eine zweite Serie aus, markiere sie (Strg+M), starte den Bulk Renamer -> dann wird mir im Bulk Renamer nicht die zweite Serie angezeigt, sonden die umbenannten Dateinamen der ersten Serie. Das sollte aber do wohl nicht so sein ;)
    Mit Strg+M wählst du nur etwas aus und genau das bearbeitet auch der BulkRenamer. Das Gleiche wäre, wenn du oben im Suchfeld einen Suchstring eingibtst und dann unten nur wenige Filme/Serien angezeigt werden - auch dann prüft der BulkRenamer bei Diesen die Ordner/Dateinamen.

    Dein Edit kann nicht sein, steht im Suchfeld eventl. noch der Name der ersten Serie.
    Teste es nochmals genau und melde dich nochmals.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • @mam es gehen doch nicht die Filmdateien, nfo und zugehörigen Arts verloren. Wird nur Müll in die Kodi-db geschrieben?

    Schön wärs, die Kodi-DB hab ich mir gar nicht mehr angeguckt, die kann man ja jederzeit wieder neu aufbauen.
    Die Filme sind weg! gelöscht! überschrieben!

    Offensichtlich läuft der Rename irgendwann mal Amok (wenn der Speicher voll ist) und produziert keine neuen Namen mehr, sondern behält immer den letzten bei. Dann werden alle folgenden Filme nacheinander so umbenannt, wobei sie bei jedem Vorgang die letzte so benannte Datei überschreiben.

    WEG! PUFF! SNIEF!
  • @Nepomuk
    Mit Strg+M wählst du nur etwas aus und genau das bearbeitet auch der
    BulkRenamer. Das Gleiche wäre, wenn du oben im Suchfeld einen Suchstring
    eingibtst und dann unten nur wenige Filme/Serien angezeigt werden -
    auch dann prüft der BulkRenamer bei Diesen die Ordner/Dateinamen.
    Dein Edit kann nicht sein, steht im Suchfeld eventl. noch der Name der ersten Serie.

    Vorgehensweise:
    Ember gestartet.
    Über Menuepukt bearbeiten usw. neue Serie hinzugefügt.
    Datenbank aktualisiert.
    neue Serie gescrapt, dann:
    Nur diese Serie ausgewählt [Strg+M], als einzige rot markiert; Suchfeld am oberen Rand der Seite ist leer.
    Dann über Menuepunkt Tools den Renamer gestartet.
    Der liest alle vorhandenen Serien und ihre Folgen ein, zeigt sie auch alle nach dem Einlesen im Umbenenn-Fenster.
    Hier muss dann rechts unten ein Häckchen bei : <nur die umzubennenden Serien anzeigen> gesetzt werden,
    dann werden alle anderen Serien mit ihren Episoden ausgeblendet und nur die umzubenennende bleibt übrig.
    Mit der gehts dann. Insofern passts jetzt.

    Gruß.
  • TLaufer schrieb:


    Vorgehensweise:
    Ember gestartet.
    Über Menuepukt bearbeiten usw. neue Serie hinzugefügt.
    Datenbank aktualisiert.
    neue Serie gescrapt, dann:
    Nur diese Serie ausgewählt [Strg+M], als einzige rot markiert; Suchfeld am oberen Rand der Seite ist leer.
    Dann über Menuepunkt Tools den Renamer gestartet.
    Der liest alle vorhandenen Serien und ihre Folgen ein, zeigt sie auch alle nach dem Einlesen im Umbenenn-Fenster.
    Hier muss dann rechts unten ein Häckchen bei : <nur die umzubennenden Serien anzeigen> gesetzt werden,
    dann werden alle anderen Serien mit ihren Episoden ausgeblendet und nur die umzubenennende bleibt übrig.
    Mit der gehts dann. Insofern passts jetzt.
    Asche auf mein Haupt,
    ich hab vergessen es zu beschreiben, dass du nach einem markieren von einer oder auch mehrere Filme/Sets/Serien mit STRG+M dann auch noch unten bei Filter das Kästchen Markiert den Filter aktivieren musst. Jetzt nimmt der BulkRenamer auch NUR die Markierten.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • mam schrieb:

    @mam es gehen doch nicht die Filmdateien, nfo und zugehörigen Arts verloren. Wird nur Müll in die Kodi-db geschrieben?

    Schön wärs, die Kodi-DB hab ich mir gar nicht mehr angeguckt, die kann man ja jederzeit wieder neu aufbauen.
    Die Filme sind weg! gelöscht! überschrieben!

    Offensichtlich läuft der Rename irgendwann mal Amok (wenn der Speicher voll ist) und produziert keine neuen Namen mehr, sondern behält immer den letzten bei. Dann werden alle folgenden Filme nacheinander so umbenannt, wobei sie bei jedem Vorgang die letzte so benannte Datei überschreiben.

    WEG! PUFF! SNIEF!
    Ich hab meine Filme immer nur mit dem BulkRenamer in mein Wunschnamesformat gebracht und auch nie alle an einem Stück.
    Da hab ich keine Fehler bemerkt.
    Und ich hab das Tagelang betrieben, bis ich die Variablen vom Renamer so gesetzt hatte, dass ich mit dem Ergebnis zufrieden war.
    Mit dem automatischen Renamer hab ich jetzt keinerlei Erfahrung. Hoffe, dass @DanCooper sich Dies als allererstes anschaut und fixt, wenn er wieder fit ist - und dann natürlich gleich eine neue alpha zur Verfügung stellt.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • Leider speichert Ember beim scrapen keines der von mir ausgewählten Bilder (Banner, Poster, Fanart, Clearlogo), sondern übernimmt nur die Vorschläge, die in der obersten Reihe schon vorhanden sind. Ich hoffe ja, dass das nur ein Einstellungsproblem von mir ist, und mir da jemand von euch auf die Sprünge helfen kann.
    Weiters habe ich bemerkt, dass der Tag-Manager leer ist, also keine Filme eingetragen hat, die man taggen könnte. Und ob das Absicht ist, dass es den Tag-Manager nur für Filme, nicht aber für Serien gibt?
    Danke und liebe Grüße, Schiffschaukel
  • Hey,

    übernehme hier direkt aus dem Diskussionsthread zum Tutorial.




    rezmer schrieb:

    Hey,

    kleines Problem mit dem Kodi-Interface.
    Habe jetzt alles eingestellt und klappt soweit ganz gut.
    Wenn ich jetzt aber über das Kontextmenu Episoden von Serien synchronisieren will, zeigt er mir bei Episoden von Serien kein Poster mehr an und das Staffelposter ist auch weg.
    Kann mir da vielleicht jemand helfen?


    Gruß
  • Schiffschaukel schrieb:

    Leider speichert Ember beim scrapen keines der von mir ausgewählten Bilder (Banner, Poster, Fanart, Clearlogo), sondern übernimmt nur die Vorschläge, die in der obersten Reihe schon vorhanden sind. Ich hoffe ja, dass das nur ein Einstellungsproblem von mir ist, und mir da jemand von euch auf die Sprünge helfen kann.
    Weiters habe ich bemerkt, dass der Tag-Manager leer ist, also keine Filme eingetragen hat, die man taggen könnte. Und ob das Absicht ist, dass es den Tag-Manager nur für Filme, nicht aber für Serien gibt?
    Danke und liebe Grüße, Schiffschaukel
    Ein einfacher Klick auf das von dir gewünschte Bild reicht nicht aus. Du musst jetzt mit nem Rechtsklick auf das Bild und dann mit "Select Image" das Bild bestätigen.
    Den Tag Manager gibt es bisher nur für Filme. Ist aber bei mir aber derzeit auch ohne Funktion, da ich zwar meine vorher angelegten Tags sehen kann, aber auf der rechten Seite nur Auswahlkästchen sind, keine Filmtitel.
  • Nepomuk schrieb:

    Ich hab meine Filme immer nur mit dem BulkRenamer in mein Wunschnamesformat gebracht und auch nie alle an einem Stück.
    Da hab ich keine Fehler bemerkt.
    Ja, in kleinen Häppchen geht das alles gut, hatte ich ja auch lange getestet, bevor ich die große Runde angeworfen habe.
    Das Problem liegt offensichtlich in einer fehlerhaften Reaktion auf "Speicher voll". Dazu braucht es schon eine ganze Menge von Filmen. Offensichtlich unterschätzt hier jemand die Größe der Objekte, die angelegt werden und der "schöne" Programmierstil begünstigt leider das Speicherchaos. So ordentlich und cool Zeilen wie:

    Quellcode

    1. tmpname = tmpname.Replace(".", " ").Trim.Replace("(", " ").Replace(")", "").Trim

    sind, sie erzeugen viele temporäre Objekte und wenn das alles in einer engen Schleife passiert, kommt die Garbage Collection auch nie zum Aufräumen (abgesehen davon, dass der ungeübte Leser über solchen Zeilen erst einmal eine Stunde lang meditieren muss, um sie verstehen zu können und auch danach noch nicht wirklich sicher ist, in welcher Reihenfolge die einzelnen Aktionen denn nun wirklich stattfinden).

    Und selbst mit 64 Bit (wenn sie den laufen würden) wären es nur ein paar Objekte mehr, bis das Programm wieder anfängt zu spucken. Hier sollte man vielleicht überlegen, ob nicht die großen Schleifen automatisch aufgeteilt werden in kleinere Abschnitte zwischen denen dann mal aufgeräumt wird.
  • Zum Thema "Speicherchaos" kann ich auch etwas vermelden. Habe gestern bei ca. 70 Filmen das Cover manuell geändert. Mal über das Editieren und nur Poster scrapen, mal einfach das Poster selbst heruntergeladen, in den Filmordner kopiert und den Film "neu geladen". Nach jedem Film einmal manuell über "Rechtsklick" "Kodi Interface" und "synchronisieren" Kodi mitgeteilt, dass es was neues gibt. Irgendwann hat Ember sich dann selbst beendet mit der Meldung "Nicht genügend Arbeitsspeicher". Da der Fehler zweimal und nach deutlich weniger als 70 Filmen aufgetreten ist, habe ich gerade mal ins Log geschaut. Nach dem ersten Absturz kann ich insgesamt 33 unterschiedliche Filmtitel zählen und dann kommt der zweite Absturz.

    Ich habe als System Windows 8.1 mit 4 GB Ram

    Dann habe ich gestern Abend noch ein benutzerdefiniertes Scrapen angestoßen für insgesamt 1354 Filme. Dabei sollten nur die Titel des Films gescraped werden. Dabei sind keine Fehler aufgetreten. Meiner laienhaften Meinung nach, liegt es dann am Öffnen des Editierfensters.

    Ich hab mal einen Auszug aus der Log-Datei angehängt. Beinhaltet alles nach dem ersten Absturz bis zum zweiten Absturz.
    Dateien
    • 2016-02-14.txt

      (76,14 kB, 3 mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von nadkp () aus folgendem Grund: Edit: "Dabei sind keine Filme aufgetreten" in "Fehler" geändert

  • Ich hab mir mal erlaubt, im ersten Post auf die neuste alpha-Version hinzuweisen und zu verlinken.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • @Nepomuk Ich hab jetzt endlich mal den Button für die DaemonTools / VirtualCloneDrive Einstellungen gefixt, ausserdem wird nun auch bei VCD das Image nach dem Auslesen wieder ausgeworfen. Bitte bei Gelegenheit (und vorhandenem Release) mal testen.

    Das neu-laden der Info im Main Screen ist noch nicht gefixt, das werde ich in den nächsten Stunden dann auch noch machen.
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • Super. Ja, mach ich.
    Dann warte ich bis du eine neue alpha zum Download zur Verfügung stellst. Eventl. ist auch @waffi schneller.

    Hast du sonst auch noch ein paar andere Bugs gefixt, welche getestet werden müssen. Denke gerade an den Bug von @mam. Weil der brennt ja - der Bug.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • Schade, dass @Cocotus trakt.tv noch nicht gefixt hat.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • So, ich habe nun auch nach längerem testen und einstellen, etc. das Vergnügen euch ein paar Bugs und Verbesserungsvorschläge hier in den Thread zu posten.

    bei den meisten Bildern sind Kommentare mit der Beschreibung, wenn was unklar ist bitte fragen.


    So, nun fang ich mal mit meinen Erkenntnissen ;)


    Client1: ML03B|GA-A75M-UD2H|MSI R5450|A4-3400 2x2.70GHz|8GB DDR3-1600|LE 7.0.2
    Client2:RPI2|LE 7.0.2
    NAS 1: DS211J
    NAS 2: Define Nano S|ASRock H110M|G4560 2x 3.50GHz|8GB|OMV 3.x|Emby Server 3.x
    SKIN: Estuary.Refresh
    Display: Samsung 55 Zoll
    PVR: VU Duo 2|3TB
    FB: Harmony 600
    Amp: OnkyoTX626
    Center VOKAL
    Front: ZENZOR5
    Surround: ZENZOR1