VNSI Stream Wiedergabe Problem

  • Hallo
    Ich nutze immer noch das VNSI "PVR Addon" im Zusammenhang mit dem ctVDR. Ich habe verschiedene KODI Installationen auf unterschiedlicher HW. Das VNSI Addon funktioniert eigentlich überall problemlos. NUR nicht auf der einen HW (Core i5 3gen, HD2500, WinX(aktuell), KODI Version (alle seit x-Jahren)) auf der es mir wichtig wäre.
    Problem: Der TV Livestream wird nicht abgespielt (unendlich Sanduhr).
    Meldung in [definition=9,2][definition=9,3]Kodi.[definition='1','0']log[/definition][/definition][/definition] CVideoPlayer::ReadPacket - Error demux packet doesnt't belong to a valid stream

    Ansonsten funktioniert aber der Rest. EPG wird geladen. Aufnahmen werden abgespielt!!
    Und der Rest aller KODI-Addons und Funktionen auch. Alles wurde natürlich schon mehrfach neu installiert (ausser WinX). Auf diesem Rechner bleibt's wie es ist.

  • Ich will ja nix sagen, aber die Hardware ist 13 Jahre alt. Meinst du nicht, dass es Zeit für was neues wäre?

    Kannst du uns mal nen vollständiges Log zukommen lassen? Nur eine Zeile ist ein wenig vage um eine Aussage machen zu können

    Wertschätzung kostet nichts, aber sie ist von unschätzbarem Wert.

  • Ich gebe Ihnen recht - mit der Anschaffung einer neuen HW wäre das Problem höchstwahrscheinlich beseitigt.
    Wenn ich jetzt nur noch an der Stelle 4k-Filme schauen wollte, hätte ich das wohl getan.


    aber die Hardware ist 13 Jahre alt. Meinst du nicht, dass es Zeit für was neues wäre

    Etwas korrigieren muss ich. Es ist nicht ctVDR sondern yaVDR letzter Ausprägung.
    Klar - die eingesetzte Technik ist nicht mehr "upToDate". Aber für meine Bedürfnisse max.720p völlig ausreichend.
    Bei Live-Video über yaVDR reden wir ja über SD-Auflösung. Dafür reicht ein Pentium IV System aus.

  • Dein Log ist leider kein [definition=12,7][definition='1','1']debuglog[/definition][/definition]. Dafür musst du in den Einstellungen [definition=12,2]debugging[/definition] aktivieren.

    Kannst du das bitte nochmal machen?

    Bei Live-Video über yaVDR reden wir ja über SD-Auflösung. Dafür reicht ein Pentium IV System aus

    Also....erstmal spielt Hardware keine Videos ab. Das macht immer noch die Software mit einem zugrunde liegenden Betriebssystem welches dann die Hardware anspricht.

    Warum ich aber die Hardware in Frage stelle ist, weil sich die Software weiter entwickelt und man so eine Mindestanforderung an die verwendete Hardware hat. Es mag also sein, dass ein Pentium IV System ausreichend wäre um SD-Videos abzuspielen. Wenn die Software das aber nicht ist bzw. dahingehend entwickelt wurde so alte Hardware nicht mehr zu supporten, dann hilft dir die Aussage recht wenig.

    Die Hardware, die du verwendest war zu Kodi 17 schon das absolute Minimum was erforderlich war um HW-Beschleunigung der GPU nutzen zu können. Das mag sich mittlerweile auch verschoben haben. In deinem Log sehe ich zwar nichts von DXVA, aber das mag auch daran liegen, dass du [definition=12,2]debugging[/definition] nicht eingeschaltet hast.

    Wertschätzung kostet nichts, aber sie ist von unschätzbarem Wert.

  • Die Hardware, die du verwendest war zu Kodi 17 schon das absolute Minimum was erforderlich war um HW-Beschleunigung der GPU nutzen zu können

    Kodi 17.0 mit DXVA lief (auch) noch unter MS-Vista.
    (BTW: Ich habe hier tatsächlich noch so ein System (zu Testzwecken) - damals noch mit Chipsatzgrafik - damit funktioniert's)
    Ein Core i5 3gen 3GHz ist jetzt nicht unbedingt das "absolute Minimum" für Kodi17.
    Die HW sehe ich hier grundsätzlich nicht als Problem. Netflix, Prime und... mit Widevine funktionieren auf dem System mit 720p Auflösung unter WinX 22H2 aktuell Mit KODI 20.0)
    Als wenn - da "Irgendetwas" fehlen würde. Aber eine KODI Installation bringt doch alle benötigten APIs mit - oder nicht?
    Die Wiedergabe der yaVDR-Netzwerkstreams (http://yaVDRhost:3000/TS/.. via VLC funktioniert ebenso.

  • Ein Core i5 3gen 3GHz ist jetzt nicht unbedingt das "absolute Minimum" für Kodi17.

    Doch. Dieses System hat eine Ivy Bridge CPU und eine HD2500 Grafik. Das ist nun mal das absolute Minimum mit Hardware-Decoding. Und das schon zu Zeiten von Kodi 17:

    Folgendes Wiki ist seit der Version 17 von Kodi nicht mehr in Bezug auf die Hardwareanforderungen aktualisiert worden und diese sind mit Sicherheit nicht geringer geworden.
    https://kodi.wiki/view/Supported_hardware#Windows


    Diese Nachricht:

    2023-01-24 23:05:52.574 T:11584 error <general>: CVideoPlayer::ReadPacket - Error demux packet doesn't belong to a valid stream

    Wird 1000ende Male in deinem Log wiederholt:

    2023-01-24 23:05:22.592 T:11584 error <general>: CVideoPlayer::ReadPacket - Error demux packet doesn't belong to a valid stream
    2023-01-24 23:05:28.454 T:808 info <general>: Skipped 1369 duplicate messages..

    Wie man das aber löst oder an was es liegt, mag ich gerade nicht zu beurteilen.

    Wertschätzung kostet nichts, aber sie ist von unschätzbarem Wert.

  • Vielleicht mal etwas info erzaehlen, damit man hier vielleicht mehr helfen koennte ?

    z.b. Was hat sich geaendert zwischen dem letzten Mal wo es funktioniert hat und dem ersten mal wo es nicht funktioniert hat ? Wann hat es denn zum letzten Mal bekanntermassen funktioniert ?

    Oder wie der Systemaufbau insgesamt ist. yaVDR, aber womit werden da SDD Fernsehkanaele empfangen ? Und gibt es jetzt noch einen anderen client mit Kodi/VNSI der von demselben Server via VNSI die live-kanaele korrekt empfangen kann ?

  • xIch habe auch mal etwas experimentiert um die Ursache zu finden. Den Hinweis zu der veralteten HW kann ich nicht ganz zurückweisen. Kann sein dass die neuen KODI-Versionen generell nur auf neuere HW-Decodierung setzen.

    Code
    warning <general>: DXVA::CContext::CreateContext: using app d3d11 device for decoding due extended NV12 shared textures it's not supported.
    
    
    info <general>: DXVA::CDecoder::Open: Total video memory available is 1792 MB (dedicated = 32 MB, shared = 1760 MB)


    Folgend mal ein Auszug aus der Log-Datei auf einem gaannz alten System völlig ohne Beschleunigung. Für die SD Qualität reicht SW-Rendering des Pentium Dual Core hier völlig aus.

    Auf ALLEN von mir getesteten KODI-Versionen/Systemen werden Aufnahmen problemlos abgespielt. Nur mit den LIVE-Streams gibt's Probleme. Auf LIBRELEC(Raspi) und ANDROID Installationen gibt's keine Probleme mit der LIVE-Stream Wiedergabe.

    Vielleicht werden auf den neueren WINDOWS-Versionen andere Stream-IDs für HW-Decodierung erwartet die dann nicht gefunden werden.

  • andere Stream-IDs für HW-Decodierung

    Guter Hinweis - aber daran liegt's nicht. Auch in Einstellung "Software Renderer" tut's nicht.
    Langsam gehen mir auch die Ideen aus woran es liegen könnte. DXVA-d3d11 sehe ich hier nicht
    Da wo es funktioniert sieht der LOG so aus


    Sieht für mich so aus, dass nach verschiedenen IDs gesucht wird. Wird der gefunden kommt DXVA ins Spiel und die Wiedergabe beginnt.
    Auf dem besagten Rechner bleibt die Wiedergabe mit...
    "CVideoPlayer::ReadPacket - Error demux packet doesn't belong to a valid stream" endlos hängen.

    Im Quellcode finde ich an entsprechender Stelle:

    Von FFMPEG habe ich auch schon aktuelle Versionen installiert.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!