MediaPortal PVR Probleme mit Live TV

  • Hallo Zusammen,

    ich nutze seit vielen Jahren MP mit Clients, und wollte jetzt aus Platzgründen einen Client durch einen Raspi 4 mit Kodi ersetzen. Hat auch soweit geklappt bis auf folgendes:
    Aufbau: Server mit MP 1.22 (TV-Karte Satellit) und passendes Kodi Plugin (korrekt konfiguriert -Pfade grün, Timeshiftordner freigegeben für jeden), LibreELEC-RPi4.arm-9.2.0, Im MP PVR Client IP, Port 9596, Benutzer: servername/benutzername,
    Wiedergabe: TSReader, schneller Kanalwechsel: aus.

    Verbindung kommt zustande, Kanäle werden übertragen, Aufnahmen angezeigt. Wenn ich jedoch einen Sender aufrufen will, blinkt es nur kurz es erfolgt aber keine Widergabe (ebenso wenn ich Aufzeichnungen wiedergeben will).
    Wiedergabe von Filmen aus freigegebenen Ordnern auf dem Server funktioniert einwandfrei.

    Wenn ich jedoch im PVR Client "RTSP Stream verwenden" ankreuzte funktioniert alles, aber beim Umschalten von HD auf SD Sender kommt nichts mehr und Kodi hängt sich auf. Wenn ich zuerst auf Stopp drücke, eine Sekunde warte und ein neues Programm wähle geht es (Ist aber keine wirklich elegante Lösung).

    Mit einem Kodi-Client auf einem Windows Rechner funktioniert alles einwandfrei wenn der Timeshift Ordner freigegeben ist - wenn ich die Freigabe zurücknehme hab ich das selbe Verhalten wie beim Raspi.

    So jetzt bin ich mit meinem Latein am Ende ?( ?( ?(

    Ich hoffe jemand hat eine Idee dazu - irgendwie muss das ja ein Rechte Problem sein oder?

  • @Amehl
    Ich habe dein Thema verschoben.

    Könntest du uns zu den Versuchen eine [definition=9,2]kodi.[definition='1','0']log[/definition][/definition] zukommen lassen?
    So ist es etwas Raterei. Hinzu kommt, dass nur noch sehr wenige MediaPortal als Server nutzen.

    (Wenn du noch ein paar Euro Weihnachtsgeld über hast, empfehle ich unter Windows einen Blick zum DVB-Viewer.)

  • Weiter oben ist der Part mit dem TS Zugriff.

    Code
    2019-12-01 09:53:49.068 T:2521822064  NOTICE: AddOnLog: MediaPortal PVR Client: Translate path V:\Archif2\live3-0.ts.tsbuffer -> smb://mediacenter/XXXX:XXXXXXXXXX@MEDIACENTER/Archif2/live3-0.ts.tsbuffer
    2019-12-01 09:53:50.674 T:2521822064   ERROR: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile(), open file smb://mediacenter/XXXX:XXXXXXXXXX@MEDIACENTER/Archif2/live3-0.ts.tsbuffer failed.
    2019-12-01 09:53:50.674 T:2521822064   ERROR: AddOnLog: MediaPortal PVR Client: Failed to open file 'V:\Archif2\live3-0.ts.tsbuffer' as 'smb://mediacenter/XXXX:XXXXXXXXXX@MEDIACENTER/Archif2/live3-0.ts.tsbuffer'

    Berechtigungsproblem. Hab mal deine Login-Daten "geschwärzt". Wenn du das Kennwort woanders nutzt lösche mal dein Log. ;)

  • Jau. Beim MePo wird immer "eine" Timeshift-TS-Datei geschrieben und von der wird im TS Modus direkt gelesen.

    Kenne jetzt das Betriebssystem des Servers nicht, aber neben einer noch nicht korrekten Freigabe - davon würde ich gern mal nen Screenshot sehen - könnte
    es ja auch noch eine SMB Protokollsversions-Problematik sein.

  • Danke für die Infos KW benutze ich nur hier zum Testen - also keine Gefahr.

    Wenn ich einen Film aufrufe funktioniert es ja, da der tsbuffer im freigegebenen VZ läuft. Nur beim Live TV erkennet er nicht, dass der Timeshiftordner freigegeben ist. Wie gesagt nur der Raspi Client, der Win Client macht das einwandfrei. Der Timeshiftordner ist im Besitz des Users und für diesen sowie für jeden mit Vollzugriff freigegeben. Mir scheint, das pvr Plugin mach hier einen Fehler, bzw hat keine Rechte.

  • Was meinst du mit Film funktioniert? In KODI einen Film von einem Share aufrufen? Das ist was anderes, nutzt auch eigene Logins.

    Also ich habe eine RAM Disk, Laufwerk Z. Diese habe ich im Netzwerk freigegeben. Jetzt mal analog zu deinem Beispiel "für jeden", ich nutze einen eigenen Nutzer für sowas.


    Danach unter KODI das AddOn installieren, IP des TV Servers einstellen und Benutzername und Kennwort eines auf dem Server bekannten Nutzers hinterlegen.
    Fertig. Beim Benutzername keine Domäne\Arbeitsgruppe\PC Namen davor.

    (Dein LOG sah eh bzgl. der Shares irgendwie komisch aus, müsste ich mit meinem mal vergleichen. )


    Wenn es läuft evtl. "für jeden" ändern, sowas macht man doch nicht. ;)
    Schnellen Kanalwechsel kannst ruhig anlassen.


    EDIT: Hab auch RPI Clients. Daran liegts nicht. Was für Betriebssysteme laufen den auf Server und funktionierendem Client?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!