Aus ZattooBoxExtBeta wird ZattooHiQ

  • rolapp , ich habe das zattooHiQ Addon noch einmal komplett Deinstalliert. Im Anschluss deine Testversion neu installiert und die Anmeldedaten eingegeben. Den Stream konnte ich zwar starten, es gibt aber keine Möglichkeit diesen wieder zu beenden. Nur ein Beenden von Kodi hat Abhilfe gebracht. Danach habe ich Kodi neugestartet. Dabei hatte ich dasselbe Verhalten wie weiter oben bereits beschrieben, also keine Möglichkeit mehr Kodi sinnvoll zu nutzen, da jede Eingabe zum Fehler führt. Anbei das [definition='1','3']Debug[/definition].[definition='1','0']log[/definition] nach dem Neustart.

    Gruß Weri

  • Danke erstmal poste mal ein Bild von deiner Fernbedienung

    Da muss ich dich enttäuschen rolapp ! Ich nutze das Addon weitestgehend nur auf mobilen Geräten mit Touchscreen. Im konkreten Fall ein Samsung Tablet. Dabei ist mir aufgefallen, dass es auch bei der Darstellung des Haupt-Menu noch Probleme gibt: Die Bezeichnung der einzelnen Einträge werden bis auf die "Vorschau" nicht angezeigt. Anbei ein Screenshot zur Verdeutlichung.

    rolapp , ich habe das zattooHiQ Addon noch einmal komplett Deinstalliert. Im Anschluss deine Testversion neu installiert und die Anmeldedaten eingegeben. Den Stream konnte ich zwar starten, es gibt aber keine Möglichkeit diesen wieder zu beenden. Nur ein Beenden von Kodi hat Abhilfe gebracht. Danach habe ich Kodi neugestartet. Dabei hatte ich dasselbe Verhalten wie weiter oben bereits beschrieben, also keine Möglichkeit mehr Kodi sinnvoll zu nutzen, da jede Eingabe zum Fehler führt. Anbei das [definition='1','3']Debug[/definition].[definition='1','0']log[/definition] nach dem Neustart.

    Gruß Weri

    Ergänzend zu dem oben beschriebenen, wollte ich noch den Hinweis geben, das es mit dieser Version des Addons auch keine Möglichkeit mehr gibt eventuell vorhandene Untertitel zu aktivieren. Du hattest diese Funktion in einer früheren Version (siehe Beitrag: RE: Aus ZattooBoxExtBeta wird ZattooHiQ) eingebaut. Außerdem ist mir aufgefallen, dass solange kein Stream gestartet wird das Addon als auch Kodi insgesamt normal benutzt werden kann. Erst nachdem ein Stream gestartet wurde kommt es zu dem ob dargestellten Problem und Kodi ist nicht mehr verwendbar.

    Gruß Weri

  • Das habe ich mir fast gedacht. Wie beendest du bei anderen Addons die Streams.

    Ganz normal über das Standard OSD (Viereck am unteren Bildschirmrand) rolapp. Wie bereits vor längerer Zeit erwähnt habe ich auch bei Zattoo immer lieber das Standard OSD (tab mit zwei Fingern) verwendet. Dies funktioniert in deiner Testversion wie geschrieben aktuell leider nicht mehr.

    Gruß Weri

  • Warum eigentlich überhaupt ein "eigener Skin" für das Addon?

    Warum nicht so, wie alle anderen Video Addons auch? Ok, für die EPG Übersicht vielleicht nötig, aber ist das nicht letztendlich auch nen enormer Wartungsaufwand, wenn sich in zukünftigen Kodi Versionen irgendwelche Skin Attribute ändern sollten?

    Bitte nicht falsch auffassen, die Frage ist jetzt nicht böse gemeint und auch keine Kritik. Einfach nur Neugier.

  • Bitte nicht falsch auffassen, die Frage ist jetzt nicht böse gemeint und auch keine Kritik. Einfach nur Neugier.

    Gut das du die Frage stellst.

    Du kennst dich ja auch mit der Kodi Addon Programmierung etwas aus.

    Meine Frage an Dich, wenn ich etwas über die kodi Directory sieht das so aus.

    Code
      xbmcplugin.endOfDirectory(handle[, succeeded, updateListing, cacheToDisc]) 

    Der handle ist int(sys.argv[1])

    Für was ist das gut, kann das mal jemand erklären.

    Jetzt ist es im ZattooHiq teilweise so gewesen das der handle -1 zeigt.

    Kodi Menü aufruf über die Router Funktin im Addon(

    Was zur Folge hat das kodi ewig rum bimmelt.

    Code
     content = [
    
        {'title': '[COLOR ff00ff00]'+localString(31099)+'[/COLOR]', 'image': POPULAR_IMG, 'thumbnail': POPULAR_IMG, 'isFolder': False, 'url': __addonuri__+ '?' + urllib.parse.urlencode({'mode': 'popular'})},
        {'title': localString(31103), 'image': PREVIEW_IMG, 'thumbnail': PREVIEW_IMG, 'isFolder': False, 'url': __addonuri__+ '?' + urllib.parse.urlencode({'mode': 'preview'})},
        {'title': localString(31104), 'image': EPG_IMG, 'thumbnail': EPG_IMG, 'isFolder': False, 'url': __addonuri__+ '?' + urllib.parse.urlencode({'mode': 'epg'})},
        {'title': localString(31102), 'image': LIST_IMG, 'thumbnail': LIST_IMG, 'isFolder': True, 'url': __addonuri__+ '?' + urllib.parse.urlencode({'mode': 'channellist'})},
        {'title': localString(31105), 'image': SEARCH_IMG, 'thumbnail': SEARCH_IMG, 'isFolder': True, 'url': __addonuri__+ '?' + urllib.parse.urlencode({'mode': 'searchlist', })},
      ]

    Das sieht im Code so in etwa aus.

    Diesen ganzen Quatsch schenke ich mir mit dem eigenen Skin.

    Der Button ruft direkt ohne irgend welche URLs die Funktion auf die ich haben möchte.

    Das ergibt einen unheimlichen Geschwindigkeits-Vorteil.

    Beim ersten Test bin fast vom Stuhl gefallen wie schnell das Menü mit der Sender Liste kam.

    Publish3r warum nicht auch mal was anderes probieren.

    Ok, für die EPG Übersicht vielleicht nötig, aber ist das nicht letztendlich auch nen enormer Wartungsaufwand, wenn sich in zukünftigen Kodi Versionen irgendwelche Skin Attribute ändern sollten?

    Die Diskussion gab es schon mal vor Jahren wegen der hidden GUI, da hatte ich das mit der eigenen Keyboard.xml eingebaut.

    hidden GUI ist ein Fenster 1x1 Pixel liegt beim Live-Tv über dem Vollscreen und wertet die Eingaben aus, geht viel schneller als über die keyboard.xml.

    Da sind wir auch schon beim Problem von Weri

    In der Keyboard.xml sieht das so aus.

    Code
    <touch>
      <tap>RunPlugin("plugin://plugin.video.zattoo_hiq/?mode=showInfo")</tap>
      <tap pointers="2">OSD</tap>
      <swipe direction="left">RunPlugin("plugin://plugin.video.zattoo_hiq/?mode=toggle_channel")</swipe>
      <swipe direction="up">RunPlugin("plugin://plugin.video.zattoo_hiq/?mode=skip_channel&amp;skipDir=1")</swipe>
      <swipe direction="down">RunPlugin("plugin://plugin.video.zattoo_hiq/?mode=skip_channel&amp;skipDir=-1")</swipe>
    </touch>

    wie man hier sieht wird da auch erst das Plugin auf gerufen, dauert und dauert.

    Und ich habe es nicht auf dem Schirm gehabt und nicht eingebaut.

    Will jetzt mal zum Schluss kommen.

    Danke an Weri fürs testen und auch an Publish3r für das nachfragen.

    Weri gut ich weis jetzt wo ran es liegt.

  • Weri versuche am WE wieder was zu machen.

    Danke für deine Hilfe, was brauchst du alles für den Touch-Screen Bedienung

    Hatte an folgendes gedacht

    • Swip-up -skip Sender vor
    • Swip-down -skip Sender zurück
    • Tap - Zattoo-OSD
    • zwei Finger Tap - Kodi OSD

    Danke rols1 , die beschriebenen Touch-Funktionen sind für mich völlig ausreichend. Wie bereits erwähnt, bin ich eher ein "Fan" vom originalen Kodi OSD [ag]

    Gruß Weri

  • Hi rolapp , habe mir soeben deine neue Version angeschaut. Auf jeden Fall funktioniert diese schon besser und blockiert nicht mehr das gesamte Kode-System. Allerdings funktioniert die Touch-Bedienung noch nicht wie gewünscht:

    swipe_left -> zurück --> keine Reaktion (Stream läuft weiter??)

    swipe_up -> Skip-up --> keine Reaktion (Stream läuft weiter??)

    swipe_down -> Skip-down --> keine Reaktion (Stream läuft weiter??)

    Tap -> Zattoo-OSD --> keine Reaktion (Zattoo OSD wird nicht ausgegeben??)

    Tap-two -> Kodi-OSD --> führt zum Zurückspringen ins Hauptmenü

    Im Hintergrund läuft allerdings immer noch der gestarte Kanal weiter. Nach mehrmaligen zurückspringen im Tattoo-Hauptmenü kann dann dieser mittels Kodi-OSD gestoppt werden.

    Gruß Weri

  • Raspberry PI, Libreelec 11.0.6 und Zattoohiq 3.0.62+Matrix-Plugin
    Ich hatte ein Problem mit Zattoohiq, unabhängig von der Libreelec-Version, bei dem ich gelegentlich einen "403 Forbidden"-Fehler erhielt, wenn ich versuchte, Zattoohiq zu starten. Ich habe dieses Problem zunächst gelöst, indem ich eine saubere Deinstallation durchgeführt habe, libreelec heruntergefahren habe, libreelec gestartet habe und Zattoohiq installiert habe. Schließlich fand ich heraus, dass ich dieses Problem lösen konnte, indem ich mich per SSH anmeldete und den Befehl "rm /storage/.kodi/userdata/addon_data/plugin.video.zattoo_hiq/*.cache" ausführte. Ich hoffe nun, dass das Problem nicht wieder auftritt, da ich "rm /storage/.kodi/userdata/addon_data/plugin.video.zattoo_hiq/*.cache" in das libreelec autostart.sh Skript eingebaut habe.
    Können Sie dies dauerhaft beheben, so dass ich keinen Workaround implementieren muss?

  • Hallo zusammen

    Ich bin langjähriger Fan von Zattoo HIQ und natürlich auch von rolapp ;)

    Leider funktioniert bei mir aber seit längerem nichts mehr so, wie es sollte.
    Nicht nur das Zattoo-Addon, sondern auch Kodi selber. Habe es auf einem Raspberry Pi 4 installiert.

    Da ich eh alles neu aufsetzen muss, wäre meine Frage, ob es eine aktuelle Zattoo HIQ-Version gibt, die funktionieren würde?
    Spätestens bis zur Fussball EM wäre ich mega dankbar für eine gute Möglichkeit, um die Spiele (zeitversetzt) zu schauen mit allem Komfort, den man mit dem Addon hat.

    Welche Kodi-Version müsste ich mit welchem Addon installieren, damit ich es zum Laufen bringe?

    Danke vielmals für gute Tipps!

  • Pumpido Ich habe wieder eine Festanstellung und das Gewerbe als Kleingewerbe nebenbei. Um die Mutter muss ich mich dann abends noch kümmern. da bleibt einiges liegen.

    Welche Version von ZattooHiq geht nicht.
    Ich habe da einiges noch vor. Die Version aus dem repo bekomme ich auf die schnelle wieder hin.
    Was geht genau nicht.

    Bitte mit Log und danke für die Blumen.

  • Pumpido Ich habe wieder eine Festanstellung und das Gewerbe als Kleingewerbe nebenbei. Um die Mutter muss ich mich dann abends noch kümmern. da bleibt einiges liegen.

    Welche Version von ZattooHiq geht nicht.
    Ich habe da einiges noch vor. Die Version aus dem repo bekomme ich auf die schnelle wieder hin.
    Was geht genau nicht.

    Bitte mit Log und danke für die Blumen.

    Hallo.

    Kein Stress. War überhaupt nicht "fordernd" gemeint ;)

    Wenn du mir sagen kannst, welche Version laufen müsste (mit welcher Kodi-Version) und wo ich ein zip-File davon finde, probiere ich es aus und bin dann höchstwahrscheinlich glücklich.
    Ich dachte schon, es gäbe keine Version mehr, die überhaupt läuft ;)

    Danke!

  • Raspberry PI, Libreelec 11.0.6 und Zattoohiq 3.0.62+Matrix-Plugin
    Ich hatte ein Problem mit Zattoohiq, unabhängig von der Libreelec-Version, bei dem ich gelegentlich einen "403 Forbidden"-Fehler erhielt, wenn ich versuchte, Zattoohiq zu starten. Ich habe dieses Problem zunächst gelöst, indem ich eine saubere Deinstallation durchgeführt habe, libreelec heruntergefahren habe, libreelec gestartet habe und Zattoohiq installiert habe. Schließlich fand ich heraus, dass ich dieses Problem lösen konnte, indem ich mich per SSH anmeldete und den Befehl "rm /storage/.kodi/userdata/addon_data/plugin.video.zattoo_hiq/*.cache" ausführte. Ich hoffe nun, dass das Problem nicht wieder auftritt, da ich "rm /storage/.kodi/userdata/addon_data/plugin.video.zattoo_hiq/*.cache" in das libreelec autostart.sh Skript eingebaut habe.
    Können Sie dies dauerhaft beheben, so dass ich keinen Workaround implementieren muss?

    Vielen Dank! Hatte das Problem auch. Den Cache zu löschen hat den "403 Forbidden" Fehler gefixt. Da es auch eine Funktion zum erneuren des Caches in den Einstellungen des Plugins selbst gibt (die nicht funktioniert hat), bin ich da natürlich nicht drauf gekommen. Dachte Zattoo hätte mich aus irgendeinem Grund zumindest im Kodi-Plugin gebant.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!