Anleitung! Emby Media Server - Der Kodi-Scraper und Datenbank-Ersatz

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • hmm.... Also der Zugriff scheint immernoch ein Problem zu sein...

    starte Kodi....nach eingien Sekunden erscheint oben links nen Popup von Emby:

    "Vergleiche Filme von: Flime..." läuft durch bis 100% danach die Fehlermeldung:

    "Kann Datei nicht finden von "Netzwerkpfadsowieso, alphabetisch der erste" Bitte überprüfen Sie die Netzwerkanmeldeinformationen im Emby addon oder die Pfadersetzung im Emby Server" (Wortlaut aus Gedächtnisprotokoll)

    Also scheint das mit den Quellen immernoch nicht korrekt zu sein.

    Was gebe ich denn als Netzwerkanmeldeinformation ein? Klar, die IP-Adresse vom Server, also die von meinem NAS (braucht man dabei den Port? :8096) und was gibt man als Servernamen ein? Dann will er noch nen Passwort. Ist das das Passwort meines NAS? oder das von Emby-Connect?.....
  • Keine Ahnung also ich stelle den Server bei mir manuelle ein!

    mit auswählen des Benutzers und angeben des Passworts.
    Danach muss dann noch der Benutzername und das Passwort für deinen Benutzer auf dem NAS eingegeben werden und dann sollte es an sich laufen


    Könnte Emby connect evtl nicht funktionieren weil keine Portfreigabe auf dem Router!? (Ich weiß nicht ob Emby connect auch lokal funktioniert)
    Client1: Nvidia Shield Box 1

    Client2: HTPC
    Case: Antec Fusion
    OS: Windows 10
    Board: FM2A75 Pro4-M
    Chip: A8


    Server: HP Proliant N54l 6Bay
    OS: DSM6
  • Jetzt meinst du aber das Emby-Addon in Kodi!?!

    Genau das verirrt mich in dem moment. Wann gebe ich denn an welcher Stelle welchen Benutzer an? (NAS-Name+PW oder Emby-User+PW)

    Mein Problem fängt ja schon viel früher an, dass ich bei der angabe der Quellen in der Bibliothek im Emby-Server bereits nicht weiter komme. Wenn ich den Netzwerkpfad angebe, wird es verweigert und kommt nicht zustande. Gebe ich den Absoluten Pfad ein (weil der Server ja auf dem gleichen Gerät läuft wie die Daten), dann hab ich ja das Zugriffsproblem via netzwerk ja nur verschoben. Selbst wenn ich die path-sub einstelle, ist es ja dann wieder eine Netzwerkadresse, auf die Emby keinen Zugriff hat.

    Ich hab ja den SQL-Server noch parallel laufen. Der hat mir ja damals den benutzer "kodi" angelegt, wie es ja in den meisten TUTs angepriesen wird. Dieser hat auch ohne Probleme Zugriff drauf und den finde ich auch in der Liste der Berechtigungen wieder. Aber eben niemand anderen. Dachte nur, wenn ich jedem Zugriff erteile, sogar "Gast", dann sollte es klappen, aber anscheinend ist meinem NAS der Benutzer Emby nicht bekannt und verweigert den Zugriff übers Netzwerk. Ich könnte höchstens mal den Emby-Server aufm Laptop installieren und versuchen ob es aus der externen Richtung des Servers klappen würde. Ist natürlich n mord bohai für Schuss ins Ungewisse
  • In den Emby einstellungen:
    Login Method: Manual
    Benutzername: Name deines angelegten Benutzers in Emby
    Servername: Der Name deines Emby Servers
    Primäre Serveradresse: sollte klar sein http(s)://IP des Servers:Port


    Oben steht der Servername und bei mir heisst er Synology
    Bilder
    • Bildschirmfoto 2017-01-11 um 23.34.35.png

      81,83 kB, 1.836×518, 18 mal angesehen
    Client1: Nvidia Shield Box 1

    Client2: HTPC
    Case: Antec Fusion
    OS: Windows 10
    Board: FM2A75 Pro4-M
    Chip: A8


    Server: HP Proliant N54l 6Bay
    OS: DSM6
  • Man muß im Emby-Addon noch seine Network Credentials eintragen, damit sind User und PW für den Zugriff auf die Quellen gemeint ... Bei Windows dann halt der berechtigte User mit seinem PW, bei den NAS Devices der dortige Account mit PW ...
  • OMG, es geht endlich....

    fragt mich nicht, was die finalen Züge waren. Also das letzte was ich geändert habe, war tatsächlich der Hinweis von Snickers, danke dafür nochmal.

    Habe in den Emby-Addon-Einstellungen und nicht in den Netzwerkanmeldeinformationen das auf manuell gestellt, was vorher bei mir noch auf embyconnect stand. Die von dir genannten Informationen waren schon vorausgefüllt oder evtl mal irgendwann von mir da eingesetzt gewesen.

    Jetzt kann ich das Ergebnis direkt sehen. Vorher (also mit dem Embyconnect als Serveranmeldung) war es so, dass er die Datenbank (Eine testdatenbank mit 3 filmen) zwar synchronisiert hatte, die Filme aber nciht wiedergeben onnte, weil die Path-Sub nciht funktionierte. Er wollte immer den Eintrag wieder entfernen. Ist man mit der Taste "i" auf den Film gegangen, konnte man sich den eingestellten Pfad anschauen und der war eben sowas wie: "/share/Multimedia/Kodi/Download". Also hat da die Path-Sub nicht funktioniert. Was allerdings die Anmeldeinformation mit der Path-Sub zu tun haben soll ist mir schleierhaft. Insofern wars wohl Zufall, dass ich an der richtigen Schraube gedreht habe. Teste noch kurz aus ob das zurückstellen auf embyconnect nun ebenfalls zum gleichen ergebnis führt, da ich ja den User umbenannt habe und anschließend mit dem Account verbunden habe....

    Es bleibt weiterhin spannend

    Danke nochmal und schönen Abend noch

    Ps: Was immernoch bleibt: Ich kann als quelle für die Bibliothek keine Netzwerkadresse eingeben. Wird immer verweigert. Kann also nur den lokalen Pfad angeben und dann das mit der Path-Sub für die Clienten einstellen. Wie soll man sich das denn vorstellen wenn mein NAS als purer Daten-Speicher genutzt wäre und der Server wo anders liegen würde? Dann is man ja auf den Netzwerk-Zugriff angewiesen!?!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von gmh007 ()

  • Nabend,

    bin kurz davor ein richtiger Emby-Jünger zu werden. Jetzt noch ein paar Fragen, da ich grad dabei bin meine Quellen hinzu zu fügen:

    1. Ich habe meine Filme jetzt folgendermaßen Sortiert: Filme/"Unterordner". Und die Unterordner heißen jetzt:
    -Kinderfilme
    -FSK0-12
    -FSK16
    -FSK18
    Wenn ich jetzt in Kodi einen Benutzer neben dem admin anlege (Mein Kind) und im Emby-Server ebenfalls einen User angelegt habe, reicht es dann dem Kinder-User lediglich die Freigabe auf die Bibliothek "Kinderfilme" zu geben damit er seine eigenen whatched-states hat? Ich würde in meinem Account, oder in dem meiner Frau ja dann die gleiche Bibliothek freigeben. Hat durch die unterschiedlichen Emby-User jeder seinen eigenen Status oder muss ich wirklich auch unterschiedliche Bibliotheken/Quellen anlegen, damit ich die getrennt bekomme? Würde ja dann so aussehen:
    User: Ich-->Bibliothek: Papa-->Quellen: Kinderfilme+FSK0-12+FSK16+FSK18
    User: Kind1-->Bibliothek: Kind1-->Quellen: Kinderfilme
    ...
    Oder kann ich das so wie oben beschrieben Konfigurieren:
    User: Ich-->Bibliothek: Kinderfilme-->Quelle: Kinderfilme, + Bibliothek: FSK0-12-->Quelle: FSK0-12, + ....
    User: Kind1-->Bibliothek: Kinderiflme--Quelle: Kinderfilme.

    Die Frage zielt darauf hin: Entweder habe ich 4 Bibliotheken für meine Filme mit jeweils einer Quelle oder ich habe pro User eine Bibliothek mit unterschiedlich vielen Quellen.
    zweiteres würde ja bedeuten, dass dementsprechend oft gescrappt werden müsste. Was man hinnehmen müsste, wenn dafür der gesehenstatus erhalten bleibt.

    2. Nun zu meiner zweiten Frage, ich habe es immmernoch nicht hinbekommen die Netzwerkadressen meiner Quellen hinzu zu fügen. Es sind immernoch direkte Pfade mit der Path-Sub. Habe auch flgendes probiert: Anstatt direkt die IP-Adresse einzugeben (192.168...), das als Netzwerkfreigabe mit User+Passwort zu übergeben "smb://kodi:kodi@192.168....)
    Die Kombination kodi:kodi hab ich gewählt, weil diese in kombination mit das as.xml und der SQL-Datenbank bislang funktionierte...