Angepinnt Datenbank für Dokus, Heimvideos und weitere...

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo,
    ich bekomme seit den letzten Updates leider meine Menüpunkte nicht mehr wie ursprünglich angepasst.

    Habe folgende Playlists angelegt:

    Quellcode

    1. OpenELEC:~/.kodi/addons/skin.transparency/720p # cat /storage/.kodi/userdata/playlists/video/Filme.xsp
    2. <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    3. <smartplaylist type="movies">
    4. <name></name>
    5. <match>all</match>
    6. <rule field="path" operator="contains">
    7. <value>Filme</value>
    8. </rule>
    9. </smartplaylist>

    Quellcode

    1. OpenELEC:~/.kodi/addons/skin.transparency/720p # cat /storage/.kodi/userdata/playlists/video/Sonstiges.xsp
    2. <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    3. <smartplaylist type="movies">
    4. <name>Sonstiges</name>
    5. <match>all</match>
    6. <rule field="path" operator="contains">
    7. <value>Sonstiges</value>
    8. </rule>
    9. </smartplaylist>


    Wenn ich diese Playlists anwähle funktionieren Sie auch wie gewollt.


    Der Film-Knopf ist in der ~/.kodi/addons/skin.transparency/720p/Includes_Home.xml ursprünglich wie folgt Konfiguriert:

    Quellcode

    1. <include name="HomeMoviesButton">
    2. <item id="2">
    3. <label>342</label>
    4. <onclick condition="!Skin.HasSetting(CinemaScript_HomeMenu)">ActivateWindow(Videos,movietitles,return)</onclick>
    5. <onclick condition="Skin.HasSetting(CinemaScript_HomeMenu)">RunScript(script.cinema.experience,movietitles)</onclick>
    6. <include condition="!Skin.HasSetting(Home_Movies_Fanart_Background)">home-movies-background</include>
    7. <include condition="Skin.HasSetting(Home_Movies_Fanart_Background)">home-movies-background-fanart</include>
    8. </item>
    9. </include>


    Meine angepasste Konfig für die Menüpunkte Filme und Sonstiges sieht nun wie folgt aus:

    Quellcode

    1. <include name="HomeMoviesButton">
    2. <item id="2">
    3. <label>342</label>
    4. <onclick>ActivateWindow(VideoLibrary,special://playlists/video/Filme.xsp,return)</onclick>
    5. <icon>special://skin/backgrounds/movies.jpg</icon>
    6. <thumb>$INFO[Skin.String(Home_Custom_Back_Movies_Folder)]</thumb>
    7. </item>
    8. </include>
    9. <include name="HomeTVShowsButton">
    10. <item id="3">
    11. <label>20343</label>
    12. <onclick>ActivateWindow(Videos,tvshowtitles,return)</onclick>
    13. <include condition="!Skin.HasSetting(Home_TVShows_Fanart_Background)">home-tvshows-background</include>
    14. <include condition="Skin.HasSetting(Home_TVShows_Fanart_Background)">home-tvshows-background-fanart</include>
    15. </item>
    16. </include>
    17. <item id="666">
    18. <label>Sonstiges</label>
    19. <onclick>ActivateWindow(VideoLibrary,special://playlists/video/Sonstiges.xsp,return)</onclick>
    20. <icon>special://skin/backgrounds/videos.jpg</icon>
    21. </item>
    Alles anzeigen


    Leider wird mir der Menüpunkt Sonstiges gar nicht angezeigt und und wenn ich den Filme auswähle scheint er die playlist nicht zu laden da ich in dem Menü mit der Auswahl Filme, Serien, Begonnene Serien, Neu hinzugefügte Filme, Neu hinzugefügte Episoden, Dateien Wiedergabelisten... lande.

    Weiß jemand wo der Fehler liegt? Danke im Vorraus!
  • Ich habe die letzten Tage weiterhin verucht es hinzubekommen, leider erfolgleos. :(

    Der Menüpunkt für Filme scheint weiterhin die Playlist nicht zu finden bzw zu laden. Habe es unter anderem mit dem absoluten Pfad versucht <onclick>ActivateWindow(VideoLibrary,special://storage/.kodi/userdata/playlists/video/Filme.xsp,return)</onclick> und
    <onclick>ActivateWindow(VideoLibrary,special:///storage/.kodi/userdata/playlists/video/Filme.xsp,return)</onclick>.
    Hilft alles nichts :(

    Auch den zusätzlichen Menüpunkt "Sonstiges" bekomme ich leider nicht hinzugefügt. Benötigt der Absatz in der Konfig include-Tags? Bisher waren Sie ja nicht nötig..

    Ist das Hinzufügen eines zusätzlichen Menüpunktes sowie das Anpassen eines vorhandenen evtl gar nicht mehr möglich?! Wäre um Hilfe sehr dankbar! :thumbsup: