Serien einrichten unter Kodi 18

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ich habe mich nun mal (bisher erfolglos) an den Aufbau eigener nfo Files gemacht.
    Dabei habe ich mich am nfo maker versucht. Ich wollte, um überhaupt erst einmal einen Erfolg zu haben, eine ganf einfache nfo Datei bauen. Dabei habe ich mich am folgenden Beispiel gehalten.:

    Serienname: Arne Dahl
    Staffel: 1
    Episode: Misterioso
    Titel: Misterioso Kurzversion

    Zur Erklärung: Ich habe sowohl die Episode als Doppelfolge (2 Filme) und als Kurzversion.
    In TVDb ist nur die Version mit zwei Filmen, nicht aber die Kurzversion aufgeführt.
    Ich habe also ein File mit notepad++ geschrieben mit dem Namen "Misterioso.nfo"
    Die Kurzversion des Filmes heißt "Misterioso.mp4"
    In der Datenbank soll der Film als "Misterioso Kurzversion" aufgeführt werden. Cover und Fanart habe ich noch nicht angelegt. Es soll erst mal überhaupt funktionieren. Den Inhalt des nfo Files habe ich aufs Nötigste begrenzt:


    XML-Quellcode: Misterioso.nfo

    1. <?xml version="1.0" encoding="utf-8"?>
    2. <episodedetails>
    3. <title>Misterioso Kurzfilm</title>
    4. </episodedetails>
    Das File liegt im selben Ordner wie die Filmdatei. Dann gehe ich bei Kodi im Bereich Serie auf Datenbank aktualisieren. Leider ändert sich auf dem Bildschirm danach nichts. Ich hätte jetzt erwartet, dass neben "Misterioso Teil 1", "Misterioso Teil 2" auch der Eintrag "Misterioso Kurzfilm" auftauchen würde.

    Wie im Anhang zu sehen, werden nur die beiden Folgen der Langversion aufgeführt, die so auch in der TVDb enthalten sind. Kann es damit zusammen hängen, dass ich beim Exportieren der Bibliothek nicht ein nfo File auf dem NAS finde?
  • Moin zusammen,

    ich habe mich ein paar Tage rar gemacht. Nicht weil meine Fragen beantwortet wurden und ich sang und klanglos in der Versenkung verscgwunden bin (ist nicht mein Stil. Bin in einem anderen Forum der Fachmann und ärgere mich immer maßlos über solche User)
    Vielmehr habe ich selber versucht, weiter zu kommen und bin es auch ein ganzes Stück.
    Ich wunderte mich, dass nach dem Auslesen der Bibliothek unter Seperate kein einziges nfo File vorhanden war. Nun ist ja das Auslesen der Datenbank für Audio und Video unterschiedlich. Für Audio kann ich einen Pfad für den Download festlegen, für Video wird alles in die entsprechenden Video Ordner abgelegt. Ich habe für jeden Film einen eigenen Ordner und bei den Serien für jede Staffel einen eigenen Ordner. Musik habe ich nach Interpret;Album und dann die Titel einer CD in einen eigenen Unterordner. Wenn es nun eine Doppel CD ist, dann natürlich zwei Ordner. Das zum Vorgeplänkel.
    Der Ordner für die Video und Audio Files war nicht frei gegeben. Ihn erreichte ich nur via ftp. Das war mir vorher nie aufgefallen, weil ich auf die Files mit CIFS Protokoll zugegriffen habe. Den Ordner habe ich nun frei gegeben, habe die Bibliotheken erneut extrahiert. Dabei stellte ich dann fest, dass für die Audio Daten nfo Files in jeden Album Ordner geschrieben wurde. Bei Video allerdings wurden weiterhin nur die jpg Files ausgelesen, allerdings finde ich hein einziges nfo File auf dem NAS:

    Meine Frage ist nun, woe ist denn der Pfad, wohin die nfo Files extrahiert werden? Liegen die evtl in einem Ordner auf dem Raspberry selber?

    Danke für das Interesse und schöne Pfingsten.
  • Das hatten wir so auch noch nicht.
    Bilder werden geschrieben aber keine nfo?!
    Das kann irgendwie nicht sein. Lösch doch noch mal ein paar Bilder, damit du dir da sicher bist.
    Ich vermute auch ein Schreibrechteproblem, da deine Datenbank ein wenig problematisch geworden ist.
    Du hast halt das Protokoll irgendwann gewechselt. Das kann schwierig werden.
    Keine unlösbaren Probleme :)
    [ (C8H10N4O2) ]


  • So, ich habe nun Im Film und Serien Ordner alle jpg Files gelöscht. Dann habe ich Bibliothek mit Kodi neu ausgelesen. Dabei auf seperate, Bilder ertellen, alte Daten löschen geklickt. Ergebnis:

    Nicht ein nfo File in irgend einem Ordner. In jedem Ordner die entsprechenden Cover, wenn vorhanden, weiterhin alle fanarts, poster usw. Die werden also eindeutig durch die Kodi Datenbank erstellt. Deshalb hatte ich auch für mich ausgeschlossen, dass Schreibrechte fehlen. Da ich aber blutiger Laie bin, habe ich den Fehler natürlich zuerst bei mir gesucht. :)


    Edit:

    Ehrlich gesagt, weiß ich mir momentan keinen Reim mehr. Ich werde eine frisch aufgesetzte Karte mal mit Kodi 17 versehen und dann die Datenbank nochmal versuchen zu exportieren. Ist nicht auszuschließen, dass ich mir das durch das ganze Rumprobiere zerschossen habe. Ich werde berichten.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Friedel540 ()

  • Nun bin ich langsam etwas ratlos. Es werden beim exportieren der Database weiterhin nur die jpg Files exportiert. Ich habe eine neue SD Karte mit Libreelec 8.2.5 aufgesetzt und vorher die jpg Files alle gelöscht. Nach Exportieren mit Modus Seperate sind wieder nur alle jpgs in den entsprechenden Ordnern. Ich nutze als Client einen Raspberry pi 3B+ mit Libreelec und neuestem Milhouse 9 Testbuild. Als Server fungiert ein QNAP TS-419 II. Ich vermute, dass der Fehler nun eher in der Konfiguration des NAS liegt.
    Ich habe für Admin und Everyone Lese und Schreibrechte vergeben. Wenn da etwas falsch wäre, würden nach meinem Verständnis auch die jpg Files nicht geschrieben. Vielleicht verhindert ein Dienst auf dem NAS das extrahieren der nfo Files. Gibt es hier User, die einen QNAP NAS nutzen und eventuell weiter helfen können?
  • kurz noch einen hinterher.

    Ich hänge mal Beispielbilder von Musik, Film, Serien am. Die Musik Datebank habe ich in einem Ordner exportiert, der im Film Ordner liegt. Damit wollte ich jede Möglichkeit ausschließen, dass es vielleicht doch ein Rechte Problem ist. Wie zu sehen ist, werden die nfo Files für Musik geschrieben, für Film und Serien nicht. Ich bin jetzt erst mal raus. Ich habe die letzten Tage sehr viel Zeit für die Datenbank Pflege eingebracht und muss mich wirklich um liegen gebliebene Arbeiten kümmern. Ist also kein Desinteresse, wenn ich mir hier erst mal keinen Wolf mehr schreibe.



  • Moin zusammen,

    ich habe mich die letzten Tage noch einmal mit dem Einrichten der Datenbank beschäftigt.

    Die Hauptarbeit war wirklich das Umbenennen der Film, Musikvideos und Episoden der Serien auf dem NAS.

    Ich habe dann eine SD Karte komplett neu aufgesetzt und mit Libreelec 8.2.5 versehen. Dabei ist mir aufgefallen, dass für die Musikvideos in dieser Version die TMDb nicht angeboten wird. In Libreelec 9 habe ich die Möglichkeit, die Musikvideos mit TMDb zu sortieren. In libreelec 8,2.5 kann ich die TMDb nicht anwählen. Sei´s drum. wenn ich alles am Rennen habe, setze ich die Karte eh noch einmal mit Libreelec 9 komplett neu auf.

    Die Erzeugung von nfo Files habe ich weiterhin nicht in den Griff bekommen.

    Stand der Dinge ist, dass ich ALLE meine Filme mit TMDb gefunden habe und bis auf 2-3 Exoten, auch alle mit Cover.
    Musikvideos habe ich nur die auf den NAS gelegt, die auch gefunden werden. Die größten Probleme habe ich weiterhin bei den Serien. Dort gibt es, wie schon erwähnt bei manchen Serien Kurzversionen einer Episode, manchmal Langversionen bestehend aus 2 Episoden. Wenn das nun in der TVDb nicht berücksichtigt wird, habe ich ein Problem. Ich habe also konsequent diese Serien ausgelagert und kümmere mich mit dem Einpflegen, wenn ich hinter den Fehler der Nichterstellung der nfo Files gekommen bin.

    Vielleicht stelle ich an anderer Stelle eine extreme Dummy Frage, um die Konfiguration des QNAP NAS zu erfragen.

    Musik habe ich komplett ausgelagert und wird auch mit dem Video Raspberry nicht bedient. Ich habe hier noch ein original Raspberry 7" Display mit Gehäuse, Raspberry 3B und digiberry. Damit betreibe ich einen reinen Musik Client, der über das Touchsreen Display und der Soft Volumio gesteuert wird.

    Also auf den Punkt gebracht: abgesehen von den nfo Files, die ich auch für meine Exoten Videos brauche, die es nicht in den Datenbanken gibt:

    Filme rennen zu 100%
    Musikvideos rennen bis auf meine Exoten zu 100%
    Serien rennt bis auf meine Exoten zu 100%
    Musik rennt mit Touchscreen und Volumio zu 100%

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von root2 () aus folgendem Grund: Habe mal ein paar Leerzeilen eingefügt, damit der Text leserlicher wird.