...hab da gerade ne geile Idee! ;) - ist das realisierbar?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • alles klar, das habe ich gemacht:

    Der interne Tuner des ersten Pi nimmt gerade ARD auf und ich versuche RTL zu starten. So wie es in TV Headend aussieht versucht er RTL über den importierten Tuner abzuspielen. In Kodi passiert gar nichts. Es kommt keine Fehlermeldung - nichts. In TV Headend sieht das ganze so aus:


    Das Kodi log habe ich beigefügt.

    Ich habe jetzt bald alle Einstellungen in TV Headend ausprobiert, leider habe ich auch über Google noch keine Anleitung gefunden, wie man einen Tuner aus dem Netzwerk in TV Headend importiert.
    Dateien
    • kodi.log

      (21,59 kB, 2 mal heruntergeladen, zuletzt: )
  • mich wundert, dass da so GAR keine Meldung kommt. Wenn auf der Box 2 der Tuner freigegeben ist (led mal diesen Fred GANZ), und in der anderen Box der Tuner keine roten Punkte davor hat, sollte er auch angesprochen werden. teste mal weiter...
    1x KII Pro DVB-S2/T2 (S905) Box als TVH LiveTV Server/Client
    1x KII Pro DVB-S2/T2 (S905) Box als TVH-Server für die KIII Box
    1x KIII Box (S905) als LiveTV Client
  • Hallo @Ponyriemen,
    tests haben etwas gedauert... leider bin ich aber immer noch nicht weiter. Es ist immer noch genau so, dass keine Fehlermeldung kommt und das Kodi-Log noch gleich aussieht. Ich habe jetzt folgendes gemacht:

    Beim "abgebenden Tv Headend"


    diese Einstellugnen im SAT-IP Server gemacht und genau den gleichen Benutzer angelegt, der auch beim "Empfänger TV Headend" angelegt ist - mit erlaubtem Netzwerk "192.168.178.0/24"

    Der Tuner ist beim "Empfänger TV Headend" grün und ich habe folgende Einstellungen gemacht:





    Habe ich vielleicht noch irgendeine Einstellung übersehen, oder vergessen?

    Viele Grüße
    J.J.
  • "verknüpfter Input" kann/muss leer bleiben, wenn ich mich richtig erinnere. Halt mal die Maus drüber, dann wird der Punkt erklärt.
    Teste doch auch mal, ob verschiedene Benutzer da nen Vorteil bringen. Ich hab z.b. gar keinen Benutzer definiert und, naja, bei mir klappts ja auch nicht... ;)

    Du könntest ma an der Box, die den IP-Tuner nutzen soll und auch nen internen hat, den internen deaktivieren, sodass die Box gezwungen wird den entfernten IP-Tuner zu nehmen. Dann mal im TVH Log gucken was da an Meldungen kommt und auch an der Box, dessen Tuner da genutzt werden soll, mal im "Status" gucken, ob/wie der Tuner da angesprochen wird...
    1x KII Pro DVB-S2/T2 (S905) Box als TVH LiveTV Server/Client
    1x KII Pro DVB-S2/T2 (S905) Box als TVH-Server für die KIII Box
    1x KIII Box (S905) als LiveTV Client
  • ok. den verknüpften Input habe ich rausgenommen und den internen Tuner mal deaktiviert. Es hat zumindest mal gebracht dass jetzt ne Fehlermeldung in Kodi kommt (immerhin ein kleiner Schritt weiter). Die Fehlermeldung lautet "Tvheadend HTSP Client: Tuning fehlgeschlagen"
    Das Logfile sieht leider noch gleich aus. Ich habe es mal drangehängt.
    Dateien
    • kodi.log

      (17,67 kB, 0 mal heruntergeladen)
  • wenn Du im Browser TVH offen hast, ist unten rechts so ein kleines "Pfeilchen-Symbol" - wenn man da drauf klickt, wird unten auf der gesamten Breite des Fensters der Live-Log angezeigt und aktualisiert sich fortlaufend. Den dann einfach per C&P hier rein, nach dem Test...
    1x KII Pro DVB-S2/T2 (S905) Box als TVH LiveTV Server/Client
    1x KII Pro DVB-S2/T2 (S905) Box als TVH-Server für die KIII Box
    1x KIII Box (S905) als LiveTV Client
  • ok, hab beim editieren wohl geantwortet. ;) Hab mir den Log angesehen.

    aufgefallen ist mir:

    - RTSP SETUP error -5 (Input/output error)
    check die RTSP-Settings nochmal

    - No input source available for subscription "192.168.178.36 [ jj | Kodi Media Center ]" to channel "RTL Television"
    die entfernte IP-Karte schint lokal auf der TVH nicht mit den Channels gemappt zu sein...
    1x KII Pro DVB-S2/T2 (S905) Box als TVH LiveTV Server/Client
    1x KII Pro DVB-S2/T2 (S905) Box als TVH-Server für die KIII Box
    1x KIII Box (S905) als LiveTV Client
  • - RTSP SETUP

    Mehr als diese Einstellungen hier kann man doch meines Wissens gar nicht machen, oder ist irgendwo anders was versteckt?


    - No input source available
    Bei den zugeordneten Channels kann ich keinen Tuner hinzufügen, nur Netzwerke. Der entfernte Tuner wiederum ist dem Netzwerk "DVB-S Netzwerk" zugeordnet. Viel mehr Einstellungen gibt es meines Erachtens aber nicht mehr, oder?



    Danke übrigens mal, dass Du so viel Zeit opferst für das Thema! Wenn ich das hinbekomme schreibe ich glaube ich mal ein Schritt für Schritt Tutorial, damit jeder was davon hat.
  • nimm mal den RTSP Port raus und trag ne 0 ein bei beiden. Teste dann nochmal.
    Wenn die interne Karte deaktiviert ist, lässt sich dann mit der IP-Karte auch ein Senderscan starten? Wenn der - warum auch immer - der Meinung ist, es kann auf der Kiste keinen Sender finden, den er auch wiedergeben könnte, dann soll er eben auf der Kiste selber nach Sendern suchen... (wenns auch nicht lokal ist, aber die Kiste glaubt das ja.)

    probier mal...

    P.S.: kanns selber nicht testen, bin auf Arbeit und schreib zwischendurch. Interessiert mich ja auch. ;)
    1x KII Pro DVB-S2/T2 (S905) Box als TVH LiveTV Server/Client
    1x KII Pro DVB-S2/T2 (S905) Box als TVH-Server für die KIII Box
    1x KIII Box (S905) als LiveTV Client
  • also wenn ich den RTSP Port auf "0" setze erscheint im TVH.log folgende Fehlermeldung: 2018-03-22 14:04:24.214 [ ERROR]:satip: SAT>IP DVB-S Tuner #1 (192.168.178.44) - RTSP error -111 (Connection refused) [6-0]
    also setze ich ihn wieder zurück auf 554.

    Den Sendersuchlauf habe ich gemacht. Alle Muxes sitzen jetzt auf "Fehler" und das Log sagt dazu:

    ---nur ein kurzer Ausschnitt---

    2018-03-22 14:10:55.440 [ INFO]:mpegts: 10743.75H in DVB-S Netzwerk - tuning on SAT>IP DVB-S Tuner #1 (192.168.178.44)
    2018-03-22 14:10:55.440 [ INFO]:subscription: 021F: "scan" subscribing to mux "10743.75H", weight: 6, adapter: "SAT>IP DVB-S Tuner #1 (192.168.178.44)", network: "DVB-S Netzwerk", service: "Raw PID Subscription"
    2018-03-22 14:10:55.441 [ NOTICE]:subscription: 01D4: No input source available for subscription "192.168.178.36 [ jj | Kodi Media Center ]" to channel "RTL Television"
    2018-03-22 14:10:56.430 [ NOTICE]:subscription: 01D4: No input source available for subscription "192.168.178.36 [ jj | Kodi Media Center ]" to channel "RTL Television"
    2018-03-22 14:10:58.430 [ NOTICE]:subscription: 01D4: No input source available for subscription "192.168.178.36 [ jj | Kodi Media Center ]" to channel "RTL Television"
    2018-03-22 14:11:00.430 [ NOTICE]:subscription: 01D4: No input source available for subscription "192.168.178.36 [ jj | Kodi Media Center ]" to channel "RTL Television"
    2018-03-22 14:11:02.430 [ NOTICE]:subscription: 01D4: No input source available for subscription "192.168.178.36 [ jj | Kodi Media Center ]" to channel "RTL Television"
    2018-03-22 14:11:04.430 [ NOTICE]:subscription: 01D4: No input source available for subscription "192.168.178.36 [ jj | Kodi Media Center ]" to channel "RTL Television"
    2018-03-22 14:11:05.430 [ INFO]:mpegts: 10743.75H in DVB-S Netzwerk - scan no data, failed
    2018-03-22 14:11:05.430 [ INFO]:subscription: 021F: "scan" unsubscribing
    ---nur ein kurzer Ausschnitt---
  • ok, also nachdem ich es jetzt mit 2x TVH nicht hinbekomme versuche ich mich gerade an der zweiten hier aufgezeigten Möglichkeit, minisatip.

    Habe den Tuner angeschlossen und wie empfohlen über das Linuxserver.io repo das minisatip addon installiert. Nun kommt ja aber der zweite Schritt und an diesem scheitere ich gerade:

    CvH schrieb:

    auf der Freien Box läuft Tvheadend, auf diese IP Verbindest du dich mit den pvr.hts client
    Wie mache ich das konkret? Wo finde ich die Datei pvr.hts? Das WebUI das ich für MInisatIP gefunden habe und aufgerufen habe ist ja leider nicht mehr als eine Statusanzeige, Einstellungen kann man darüber nicht vornehmen. In TVH erscheint der Tuner nicht. In den Settings des minisatIP-Addons kann man ja nicht wirklich viel einstellen. Bei mir steht das auf:

    <settings>
    <setting id="P_port" value="8875" />
    <setting id="P_port2" value="554" />
    <setting id="P_port3" value="1900" />
    <setting id="E_opt" value="" />
    <setting id="D_device" value="/dev/dvb" />
    </settings>

    Viele Grüße
    J.J.
  • ...ich weiss nicht ob das jetzt der richtige Schritt ist weiter zu kommen, minisatip zu verstehen. Letztlich macht es ja nix anderes, als die Freigabe des Tuners per IP im LAN freizugeben. Die manuelle Einstellung SAT>IP bewirkt das Gleiche.
    Wir sollten das "Problem" lieber weiter in TVH identifizieren und lösen. Ein weiteres Addon verkompliziert es nur noch und könnte dazwischen funken.
    1x KII Pro DVB-S2/T2 (S905) Box als TVH LiveTV Server/Client
    1x KII Pro DVB-S2/T2 (S905) Box als TVH-Server für die KIII Box
    1x KIII Box (S905) als LiveTV Client
  • das mit minisatip und Tvh geht, die Frage ist wie, du könntest in den Tvh settings mal versuchen Tvh mit 10sec Verspätung starten zu lassen -> es kann immer nur ein Programm auf den Tuner zugreifen, wenn beide gleichzeitig starten ist es das Programm was als erstes darauf zugreift


    Ponyriemen schrieb:

    Wir sollten das "Problem" lieber weiter in TVH identifizieren und lösen.
    auf jeden Fall !