NFO von Filmsets wird nicht gelesen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • NFO von Filmsets wird nicht gelesen

    Hallo Community,

    ich hab meine Filmsets in EMBER erstellt (NFO, Poster, Fanart) und in KODI den MovieSet Artwork Automator aktiviert. Als Skin nutze ich den Xonfluence für KODI 17.6.
    Die Bilder sind nun auch wunderschön zu sehen, allerdings steht beim Text "Nicht verfügbar", obwohl alles wichtige in der NFO enthalten ist.

    Kann mir jemand sagen, was ich hier falsch mache?


    Gruß diddi
    Das Leben ist zu kurz für RTL II (WG)
  • verstehe ich es richtig oder falsch. Hast du eine separate NFO Datei für Filmsets erstellt oder hast du einen <set>-Tag in deinen Movie-NFOs?

    Soweit ich das für Kodi beurteilen kann, gibt es keine speziellen NFO-Dateien für Movie-sets. Die Infos, wann welcher Film in welches Set kommt, liegt in der Movie-NFO. Solltest du den Film schon gescrapet haben und nachträglich eine Änderung an der NFO vorgenommen haben, musst du die Filminformationen neu einlesen/aktualisieren. Das ist nicht mit einem Library-Update erledigt. Du navigierst in der Bibliothek zum Film, betrittst dann die Filminformationen (z. B. Taste "i" auf einer Tastatur), navigierst dann zu "aktualisieren" und bestätigst das. Dann wird Kodi eine Nachricht präsentieren, die dir sagt, dass lokale Filminformationen gefunden wurde und ob du die ignorieren und neu aus dem Netz laden möchtest, was du bei lokalen NFO-Dateien natürlich verneinst. Dann wird die NFO-Datei neu eingelesen und die Änderungen in der NFO werden aktiv.

    Solltest du das schon gemacht haben, müssen wir mal den Inhalt der NFO sehen.
    Ich gebe keinen Support per PN bzgl illegaler Addons...also nervt mich nicht damit, danke ;)
  • Hallo DaVu,

    EMBER selber erstellt eigene NFO-Dateien für Filmsets, diese werden mit den Postern und Bannern in einem eigenen Ordner abgelegt. Mit dem MovieSetArtworkAutomator-Addon können dann die Bilder eingelesen werden, die NFO aber eben nicht.

    Aussehen tut eine NFO wie folgt:
    Spoiler anzeigen

    <?xml version="1.0" encoding="utf-8"?>
    <movieset xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <title>Bourne Filmreihe</title>
    <id>31562</id>
    <plot>Jason Bourne ist ein Top-Agent der CIA, der bei einem gefährlichen Spezialeinsatz sein Gedächtnis verliert. Als er in Die Bourne Identität nach seiner Vergangenheit sucht, werden er und seine Freundin Marie zur Zielscheibe des amerikanischen Geheimdienstes. Zwei Jahre später macht Jason in Die Bourne Verschwörung Jagd auf die durchtriebenen Geheimdienstler, die ihm ein Attentat in die Schuhe schieben wollen. Schließlich klärt der Agent in Das Bourne Ultimatum die letzten Geheimnisse seiner Vergangenheit und zwingt seine Gegner zum ultimativen Showdown.</plot>
    </movieset>



    Und jetzt wäre es eben hübsch, wenn dieser Text auch mit angezeigt werden würde ...



    Gruß diddi
    Das Leben ist zu kurz für RTL II (WG)
  • Dieser Text wird nur in ausgewählten Ansichten angezeigt. Liegt also an skin und Ansicht im gleichen. Bei dem von Dir gewählten weiß ich das nicht da ich ich nicht kenne.

    Aber generell wird diese Infos zum Teil gezogen und dargestellt.
    Client1: ML03B|GA-A75M-UD2H|MSI R5450|A4-3400 2x2.70GHz|8GB DDR3-1600|LE 7.0.2
    Client2:RPI2|LE 7.0.2
    NAS 1: DS211J
    NAS 2: Define Nano S|ASRock H110M|G4560 2x 3.50GHz|8GB|OMV 3.x|Emby Server 3.x
    SKIN: Estuary.Refresh
    Display: Samsung 55 Zoll
    PVR: VU Duo 2|3TB
    FB: Harmony 600
    Amp: OnkyoTX626
    Center VOKAL
    Front: ZENZOR5
    Surround: ZENZOR1
  • diddi8 schrieb:

    EMBER selber erstellt eigene NFO-Dateien für Filmsets
    Diese NFOs sind nur für Ember nützlich, Kodi kann damit nichts anfangen. Ember kann neu aber auch den Filmset-Plot in die Film-NFO schreiben. Dazu muss die Option Einstellungen => Filme => Scraper-Daten => Filmsets => Speichere erweiterte Filmsetinformationen in NFO aktiviert werden.

    DaVu schrieb:

    Soweit ich das für Kodi beurteilen kann, gibt es keine speziellen NFO-Dateien für Movie-sets.
    Das ist korrekt.

    DaVu schrieb:

    Die Infos, wann welcher Film in welches Set kommt, liegt in der Movie-NFO. Solltest du den Film schon gescrapet haben und nachträglich eine Änderung an der NFO vorgenommen haben, musst du die Filminformationen neu einlesen/aktualisieren.
    Leider reicht das für den Filmset-Plot in Film-NFOs nicht aus. So wie es aussieht wird der Plot nur zu dem Zeitpunkt ausgelesen, wenn ein Film ein neues Set "erstellt". Ist das Set erstmal in der Kodi-DB wird nur noch der Set-Titel ausgelesen. Wenn man nachträglich den plot hinzufügt muss man:
    1. Erstmal dafür sorgen, dass alle Filme eines Set eine NFO mit Plot-Info haben
    2. Das Set in Kodi über das GUI löschen (am besten gleich mit den Filmen)
    3. Danach die DB bereinigen, da nur so die Set's wirklich gelöscht werden (nach Punkt 2 fehlen erst die Links, nicht aber die Sets selbst)
    4. Dann die DB Updaten


    Ziemlich mühsam, vor allem weil sicher der Set-Plot immer noch nicht über das JSON Interface syncen lässt. Hab alle Probleme diesbezüglich schon diverse Male angekreidet, jedoch scheint sich niemand darum zu kümmern.
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • @DaVu
    Danke, das wäre toll. Evtl. könntest du auch noch dafür sorgen, dass man die Bilder/Infos der "All Seasons" Einträge ebenfalls setzen kann. Leider werden diese nicht gelistet, sprich man kriegt die "idSeason" nicht, da wohl die Season-Nummer "-1" rausgefiltert wird. Hier die Links zu meinenm Thread: forum.kodi.tv/showthread.php?tid=319542
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • Hallo Dan,

    vielen Dank für den Hinweis. Nachdem ich nun mein EMBER auf die aktuelle Version upgedatet hab, die Einstellungen für die erweiterten Filmsetinfos hinterlegt habe, meine Daten nochmals gescrappt, meine alte Video.db gelöscht und alles wieder neu eingelesen habe, ist es genau so, wie ich es wollte.

    Dafür und für EMBER allgemein ein großes Dankeschön.


    Gruß diddi
    Das Leben ist zu kurz für RTL II (WG)
  • JackON schrieb:

    Entschuldigt bitte wenn ich hie so reinplatze.
    Aber wo bekommt man aktuelle noch das Addon 'MovieSet Artwork Automator'?
    Die Links im KODI Forum gehen ja wohl nicht mehr.

    forum.kodi.tv/showthread.php?tid=153502

    Wer kann mir hier bitte helfen?

    Danke schon mal.
    Habs leider auch nicht mehr rumliegen, hab aber diesen Link gefunden. Natürlich ohne Gewähr!

    Alternativ kannst du aber die Bilder auch mit dem KI in Ember übertragen.
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • KI bedeutet das Modul Kodi Interface in Ember. Damit kannst du eigentlich alles mit Kodi Syncen, was das Kodi JSON Interface hergibt, inkl. der zusätzlichen Bilder, die Kodi nicht einliest. D.h. im Groben Banner, CharacterArt, ClearArt, ClearLogo, DiscArt und Landscape, sowohl bei Filmen, Serien und Filmsets. Damit sind eigentlich alle Kodi Addons wie AD (ArtworkDownloader) und MSAA (Movieset Artwork Automator) hinfällig.
    Ausserdem kannst du in Ember etwas an den Daten ändern und Kodi übernimmt die Änderungen sofort, ohne dass du manuell in Kodi die NFO neu auslesen lassen musst.
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • Das Kodi Interface ist sehr zu empfehlen.
    Ich nutze es auch erst seit einem Tag, bin aber restlos begeistert davon.

    Was für mich noch interessant wäre:

    Ich arbeite in KODI mit 2 Profilen, da meine Kids nicht alles sehen brauchen. Funktioniert dann die Übertragung per KI auch noch?
    In EMBER kann ich ja mit mehreren Profilen arbeiten.

    Aber wie sieht es dann mit der Übertragung aus?
    Oder wird immer an das Profil übertragen, welches aktiv läuft?
    Das Leben ist zu kurz für RTL II (WG)
  • DanCooper schrieb:

    Alternativ kannst du aber die Bilder auch mit dem KI in Ember übertragen.
    Hallo Dan,

    ich habe bei mir gerade nochmals die video.db gelöscht und über KI neu befüllen lassen, nachdem ich das MSAA-AddOn gelöscht habe.
    Aber obwohl ich in den Einstellungen bei Filmsets das KI aktiviert und den Pfad der Bilder mitgegeben habe, werden die Bilder für die Filmsets leider nicht übertragen.

    Fehlt mir hier noch eine Einstellung?
    Das Leben ist zu kurz für RTL II (WG)
  • Ja, die Bilder liegen auf dem NAS und die Zugriffsrechte müssten auch gewährleistet sein, da der Import mit MSAA funktioniert.

    Unter Einstellungen - Module - KODI Interface - KODI HOST hab ich die Quelle mit smb://NAS/_Filmset_Bilder angegeben.
    Unter Einstellungen - Filmsets - Dateien und Quellen - Datei Benennung - KODI hab ich den Pfad zu den Bildern mit \\NAS\_Filmset_Bilder angegeben, da ich hier über das Auswahlfenster gegangen bin.


    Könnte dies das Problem sein, bzw. muss auch bei den Filmset-Einstellungen der Pfad mit smb:// angegeben werden?
    Das Leben ist zu kurz für RTL II (WG)
  • diddi8 schrieb:

    Könnte dies das Problem sein, bzw. muss auch bei den Filmset-Einstellungen der Pfad mit smb:// angegeben werden?
    Nein, denn Ember-intern läuft ja alles über Windows. Das KI ersetzt einfach \\NAS\_Filmset_Bilder mit smb://NAS/_Filmset_Bilder und korrigiert die \ im restlichen Pfad, also z.B. \\NAS\_Filmset_Bilder\Stirb Langsam Collection-poster.jpg => smb://NAS/_Filmset_Bilder/Stirb Langsam Collection-poster.jpg.


    Die Gross-Kleinschreibung des Ordnernamens stimmt? Linux ist da ja ziemlich heikel...
    Hast du in Kodi die Filmliste nach dem Sync verlassen und wieder aufgerufen? Nur dann werden die neuen Pfade aus der DB gelesen.
    Wird kein Bild oder einfach das falsche angezeigt? Kein Bild würde ein Problem mit dem Zugriff bzw. falschem Pfad bedeuten, einfalsches Bild, dass der Sync nicht funktioniert hat (das wäre dann aber im Ember Log ersichtlich).
    Ember latest Version - Ember | SPENDEN für Ember | Patreon