Angepinnt Milhouse Testbuilds (Kodi 18/LibreELEC 9) - Erfahrungen, Probleme, Fragen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Milhouse Testbuilds (Kodi 18/LibreELEC 9) - Erfahrungen, Probleme, Fragen

    Hallo zusammen,

    nachdem ich mich schon häufiger per PM mit anderen Milhouse-Usern ausgetauscht habe und dank inputstream und den sich daraus ergebenden Möglichkeiten die "Milhouse-Gemeinde" auch immer größer wird, dachte ich es wäre vielleicht sinnvoll einen "deutschen" Milhouse Thread zu eröffnen.

    Hier können Erfahrungen ausgetauscht, Fragen gestellt und Probleme diskutiert werden.


    Grüße
    debutanker


    Kleines Milhousepedia


    Was sind Milhouse Builds?
    • Milhouse Builds sind "bleeding edge" Builds was bedeutet, dass sich diese Versionen noch vor einem Beta Status befinden und jeden Abend (deswegen auch nightly builds genannt) neue Ideen/Fixes/Updates einfließen, welche eben aber auch ständig zu instabilem Verhalten führen können.


    Was brauche ich um Milhouse Builds testen zu können?
    • sinnvoll und erforderlich ist hier eine saubere Basis mit einer aktuellen LibreELEC Version zu verwenden. Wie ihr LibreELEC auf euer System bekommt, wird euch hier erklärt.


    Wie installiere ich Milhouse Builds?
    (vergesst vorher nicht ein Backup zu starten!)
    • hier empfehle ich euch die "direkte" Methode indem ihr in den LibreELEC Einstellungen (unter "Aktualisierungen ") die, für euer System passende URL eintragt:
    Für x86-Systeme wäre das: http://milhouse.libreelec.tv/builds/master/Generic
    Für Pi2/3-Systeme wäre das: http://milhouse.libreelec.tv/builds/master/RPi2

    Danach den "Update-Kanal" auf "Milhouse-9.0" stellen und "Automatische Aktualisierungen" auf "manual".
    Die genauen Einstellungen hier nochmals per Screenshot:


    Damit habt ihr unter dem Punkt "Verfügbare Versionen" ganz einfach die Möglichkeit auf die gewünschte Milhouse Version upzugraden bzw. hin- und her zu switchen.


    Wie installiere ich wieder eine aktuelle, stable Version von LibreELEC?
    • hier könnt ihr in den LibreELEC Einstellungen unter dem Punkt "Update Kanal" einfach den Eintrag "LibreELEC-8.0" einstellen und somit wieder die gewünschte LibreELEC Version installieren.
    • Da die Milhouse Builds eine neue Settings-Version benutzen, wird LE8 zurück auf "default-settings" gesetzt sein - hierzu spielt ihr einfach euer vorher getätigtes Backup ein


    Was muss ich noch tun, um Amazon Video und Netflix zum Laufen zu bringen?
    • um inputstream zu "komplettieren", müsst ihr aktuell noch manuell die libwidevinecdm installieren
    • um dies zu bewerkstelligen, loggt ihr euch per ssh auf euer System und führt folgenden Befehl aus:
    curl -Ls http://nmacleod.com/public/libreelec/getwidevine.sh | bash
    (aktuell gibt es hier mit dem Rasperry leider Probleme) -->ab Version #0207 sind die Probleme behoben

    Die libwidevinecdm wird inzwischen durch den, im Amazon-, Netflix- oder SkyAddon implementierten "inputstreamhelper"(many thx @emilsvennesson ) gezogen - einfach beim ersten Starten eines Films/Serie die benötigten Schritte vom inputstreamhelper ausführen lassen. Somit habt ihr die aktuell gültige libwidevine und seid gewappnet für VOD.



    noch vergewissern ob inputstream auch aktiviert ist (Benutzer-Addons)


    Die dementsprechenden Threads findet ihr



    Die "original" Quelle findet ihr im Kodi.tv Forum:
    Für den Pi ---> forum.kodi.tv/showthread.php?tid=298461
    Für x86-Systeme ---> forum.kodi.tv/showthread.php?tid=298462
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine

    Dieser Beitrag wurde bereits 26 mal editiert, zuletzt von debutanker () aus folgendem Grund: Milhousepedia aktualisiert

  • @don
    Kleines "Milhousepedia" angehängt!
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine
  • Super!!!

    Mein Flehen wurde erhört. Nutze seit ca. 1,5 Jahren die Milhouse-Builds, lese fleißig seine Posts und ziehe den Hut vor seinem Engagement (wie auch dem Engagement der Mitentwickler, Builder und Add-On-Programmierer).

    Nachdem ich mit meinem Kabylake-NUC ziemlich auf die Nase gefallen bin, bin ich allerdings auf eine VEro4k umgestiegen, weil mein neuer 4K-TV nach entsprechendem Input giert. Ich weine allerdings LibreElec und hier vor allem den Milhouse-Builds hinterher, da sie aus meiner Sicht bereits in Vor-Beta-Phasen eine durchaus verlässliche Betriebsstabilität haben und immer einen Schritt voraus sind.

    Wenn ich selbst dazu beitragen kann, wieder diesen Build zu nutzen (der NUC liegt ungenutzt herum) und das in meinem Lieblingsforum, finde ich das Ideal.

    Dann werde ich mal das Ding wieder aus dem Schrank holen....

    Gruß - willicooper
  • willicooper schrieb:

    Dann werde ich mal das Ding wieder aus dem Schrank holen....
    Hoffe, das Ding ist schon wieder abgestaubt und angeschlossen! :thumbsup:

    willicooper schrieb:

    da sie aus meiner Sicht bereits in Vor-Beta-Phasen eine durchaus verlässliche Betriebsstabilität haben und immer einen Schritt voraus sind.
    Kann ich dir nur zustimmen!
    Ich persönlich fahre auf all meinen Systemen auch schon lange Milhouse und meine Regierung hat mir bisher noch nicht den Hals rumgedreht (und das soll was heißen...) ;)

    Ein aktuelles, größeres Problem gibts ab Build #1124 (weswegen ich aktuell weiterhin auf dem #1123 bin) bei einigen Usern allerdings mit diversen TV Kanälen oder aufgenommen Sendungen (TS-Streams).
    Habe hierzu auch schon einmal im Kodi.tv Forum berichtet und ein trac-Ticket erstellt.
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine
  • Was genau meinst du mit "das aktualisieren "?
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine
  • Wenn du nach der Anleitung oben alles eingestellt hast, musst du nur den Punkt "verfügbare Versionen" anklicken und da dann eben die Version, die du installieren möchtest!

    Danach wird automatisch die ausgewählte Version installiert!
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine
  • Zum einen habe ich die Auflösungen 3840 x 2160 nicht über 30 Hz hinbekommen (Hinweise in einem entsprechenden Thread im LE-Forum habe ich aufgegriffen und umgesetzt, leider ohne dauerhaften Erfolg), zum anderen die noch nicht „reife“ Wiedergabe von HDR-Material. Beides kann die Vero im Zusammenspiel mit meinem Sony KD75XD9405.

    Tonprobleme hatte ich dagegen keine. Nach den NUC-Updates funktionierten auch die HD-Tonformate am Yammi ohne Probleme.
  • willicooper schrieb:


    Tonprobleme hatte ich dagegen keine. Nach den NUC-Updates funktionierten auch die HD-Tonformate am Yammi ohne Probleme.
    Läuft inzwischen tatsächlich ohne Probleme


    Mit UHD und Konsorten hab ich mich noch nicht wirklich beschäftigt.
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine
  • debutanker schrieb:

    Ein aktuelles, größeres Problem gibts ab Build #1124 (weswegen ich aktuell weiterhin auf dem #1123 bin) bei einigen Usern allerdings mit diversen TV Kanälen oder aufgenommen Sendungen (TS-Streams).
    Habe hierzu auch schon einmal im Kodi.tv Forum berichtet und ein trac-Ticket erstellt.
    In der neuen Nightly (#1201) ist dieser Bug dank FernetMenta gefixt - klasse Support!
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine
  • debutanker schrieb:

    debutanker schrieb:

    Ein aktuelles, größeres Problem gibts ab Build #1124 (weswegen ich aktuell weiterhin auf dem #1123 bin) bei einigen Usern allerdings mit diversen TV Kanälen oder aufgenommen Sendungen (TS-Streams).
    Habe hierzu auch schon einmal im Kodi.tv Forum berichtet und ein trac-Ticket erstellt.
    In der neuen Nightly (#1201) ist dieser Bug dank FernetMenta gefixt - klasse Support!
    Hallo Debutanker,
    Danke für deine Anleitung , habe gerade auf 1201 upgedatet.
    Was mir aufgefallen ist, das im Menü auf der linken Seite der Reiter Filme fehlt.
    Ab Serien hinunter ist alles da - irgendwie komisch oder?.
    Hast du ne Lösung :wacko:
    Danke
  • Hätte ich jetzt auch als erste Idee im Kopf gehabt!
    Einstellungen --> Benutzeroberfläche --> Skins --> Skins konfigurieren --> Hauptmenüeinträge
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine