[Beta] OSMOSIS *Streams zur DB hinzufügen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Klappt wie zu erwarten natürlich nicht:
    17:27:32.396 T:139464586320 NOTICE: Creating InputStream
    17:27:32.400 T:139464586320 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.osmosis/?url=plugin&mode=10&mediaType=show&episode=s1e1&showid=80|The Alienist – Die Einkreisung
    17:27:32.401 T:139464586320 ERROR: Open - failed to open source <plugin://plugin.video.osmosis/?url=plugin&mode=10&mediaType=show&episode=s1e1&showid=80|The Alienist – Die Einkreisung>

    Habe die strm datei gelöscht und von Osmosis neu anlegen lassen.
    Er kann die strm Datei ja auch wunderbar auslesen, nur Kodi weiss eben mit dem Inhalt nix mehr anzufangen.
  • [Beta] OSMOSIS *Streams zur DB hinzufügen

    Ja ich hab das gestern nacht auch noch festgestellt. Das Problem ist der doppelte plugin:// Aufruf. Strm ruft osmosis auf osmosis dann das eigentliche Video addon. Dann geht es nicht. Bei mir gehen beide Varianten nicht weil meine Strm files emby verwaltet und emby selbst auch einen plugin: Aufruf macht beim starten. Also sogar dreifach: emby, osmosis, Video addon.
    Aber spielt ja letztlich auch keine Rolle, es ist definitiv ein kodi Bug, mit älteren nightlies geht ja alles.

    Gesendet von meinem SM-G950F mit Tapatalk
  • So ich habe über das Emby Forum per private Message jetzt nochmal Kontakt mit @Angelblue05 aufgenommen da Sie ja in die Umbauten bei Kodi was strm Dateien und Playlists angeht eingebunden war/ist. Sie ist bis jetzt auch die einzigste die reagiert hat (vielen Dank dafür).
    Wir haben ein paarmal hin und her geschrieben und ich habe versucht das Problem so genau wie möglich zu erklären.
    Sie hat es dann recht passend und kurz auf den Punkt gebracht :thumbsup: Zitat: "the issue is related to a plugin passing another plugin path does not work"

    Was ich alles probiert und Ihr geschrieben habe unter anderem steht hiernach. Ich hoffe mal das ich jetzt alles richtig getestet und aufgeschrieben habe und das dieser Fehler dann auch bald wieder bereinigt wird. Sonst weiss ich auch nicht mehr was ich noch machen soll.

    ----------------------------------------------------------------------------------------------------

    Plugin Load 1: VideoPlayer::OpenFile: plugin://plugin.video.emby.tvshows/adc25f7fa4cda2c6ea15e9b2a9e5a589/?dbid=1&mode=play&id=368a382086491205300b15bcb9374ab5&filename=s1e1.strm

    s1e1.strm includes: plugin://plugin.video.osmosis/?url=plugin&mode=10&mediaType=show&episode=s1e1&showid=59|Absentia

    Plugin Load 2: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.osmosis/?url=plugin&mode=10&mediaType=show&episode=s1e1&showid=59|Absentia <---- FAILED

    When i play the Video directly from the Amazon Addon it works:

    Quellcode

    1. 21:48:58.454 T:139157812304 NOTICE: [Amazon VOD] Using inputstream.adaptive Version:2.2.16
    2. 21:48:58.455 T:139157812304 NOTICE: [Amazon VOD] Checking AudioTrack
    3. 21:48:58.487 T:139017045072 NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0
    4. 21:48:58.490 T:139203601488 NOTICE: Creating InputStream
    5. 21:48:58.569 T:139203601488 ERROR: AddOnLog: InputStream Adaptive: Key system request: com.widevine.alpha
    6. 21:48:58.636 T:139199423568 NOTICE: EMBY.kodimonitor -> Method: Info.OnChanged Data: null
    7. 21:48:58.658 T:139199423568 NOTICE: EMBY.kodimonitor -> Method: Player.OnPlay Data: {"item":{"episode":1,"season":1,"showtitle":"Absentia","title":"Emily","type":"episode"},"player":{"playerid":1,"speed":1}}
    8. 21:48:58.677 T:139199423568 NOTICE: EMBY.kodimonitor -> Item is invalid for playstate update
    9. 21:48:59.637 T:139203601488 NOTICE: Previous line repeats 1 times.
    10. 21:48:59.637 T:139203601488 NOTICE: Creating Demuxer
    11. 21:48:59.639 T:139203601488 NOTICE: Opening stream: 1 source: 256
    12. 21:48:59.661 T:139203601488 NOTICE: Creating video codec with codec id: 27
    13. 21:48:59.719 T:139203601488 NOTICE: CDVDVideoCodecAndroidMediaCodec::Open Testing codec:OMX.Nvidia.mp4.decode
    14. 21:48:59.719 T:139203601488 NOTICE: CDVDVideoCodecAndroidMediaCodec::Open Testing codec:OMX.Nvidia.h263.decode
    15. 21:48:59.720 T:139203601488 NOTICE: CDVDVideoCodecAndroidMediaCodec::Open Testing codec:OMX.Nvidia.h264.decode
    16. 21:48:59.737 T:139203601488 NOTICE: Creating video thread
    17. 21:48:59.737 T:139509851216 NOTICE: running thread: video_thread
    Alles anzeigen

    Detail:
    When starting with Emby:
    First call: plugin://plugin.video.emby.tvshows/adc25f7fa4cda2c6ea15e9b2a9e5a589/?dbid=1&mode=play&id=368a382086491205300b15bcb9374ab5&filename=s1e1.strm
    This calls: plugin://plugin.video.osmosis/?url=plugin&mode=10&mediaType=show&episode=s1e1&showid=59|Absentia <-- Failed

    When it would work it calls: plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0

    Same thing happens when i play the strm file without Emby:
    First call: plugin://plugin.video.osmosis/?url=plugin&mode=10&mediaType=show&episode=s1e1&showid=59|Absentia
    This calls: plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0 <--- FAILED

    When i instert in the strm file: plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0
    and play it directly it works, only one plugin:// call.

    When i play it over Emby:

    Quellcode

    1. 21:59:00.659 T:139157840976 NOTICE: EMBY.default_tvshows -> Parameter string: ?dbid=1&mode=play&id=368a382086491205300b15bcb9374ab5&filename=s1e1.strm
    2. 21:59:00.750 T:139157840976 NOTICE: EMBY.playbackutils -> Play called: Emily
    3. 21:59:00.794 T:139157840976 NOTICE: EMBY.playutils -> Strm detected.
    4. 21:59:00.808 T:139157840976 NOTICE: EMBY.playutils -> playback info: {u'SupportsDirectStream': True, u'Container': u'strm', u'RequiresClosing': False, u'IgnoreDts': False, u'IgnoreIndex': False, u'SupportsDirectPlay': True, u'MediaStreams': [], u'Type': u'Default', u'ReadAtNativeFramerate': False, u'RequiresLooping': False, u'Path': u'plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0', u'RequiresOpening': False, u'IsRemote': True, u'Name': u's1e1.strm', u'RequiredHttpHeaders': {}, u'SupportsTranscoding': True, u'Formats': [], u'Protocol': u'File', u'IsInfiniteStream': False, u'GenPtsInput': False, u'VideoType': u'VideoFile', u'ETag': u'602820ff412b4ef669f3cf979927d852', u'SupportsProbing': True, u'Id': u'368a382086491205300b15bcb9374ab5'}
    5. 21:59:00.821 T:139157840976 NOTICE: EMBY.playutils -> play method: DirectPlay play url: plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0
    6. 21:59:00.914 T:139010958416 NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.emby.tvshows/adc25f7fa4cda2c6ea15e9b2a9e5a589/?dbid=1&mode=play&id=368a382086491205300b15bcb9374ab5&filename=s1e1.strm
    7. 21:59:00.916 T:139158897744 NOTICE: Creating InputStream
    8. 21:59:00.918 T:139158897744 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0
    9. 21:59:00.919 T:139158897744 ERROR: Open - failed to open source <plugin://plugin.video.amazon-test/?asin=B0797VD551&mode=PlayVideo&adult=0&name=1+-+Emily&trailer=0&selbitrate=0>
    10. 21:59:00.919 T:139158897744 ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.emby.tvshows/adc25f7fa4cda2c6ea15e9b2a9e5a589/?dbid=1&mode=play&id=368a382086491205300b15bcb9374ab5&filename=s1e1.strm]
    11. 21:59:00.920 T:139158897744 NOTICE: CVideoPlayer::OnExit()
    Alles anzeigen

    With the old Kodi Nightly (kodi-20180413-294d6a27-master-arm64-v8a.apk) all this ways works.
  • Ich habe gestern ein wenig rumprobiert und habe jetzt eine lauffähige Version.
    Ob das mit Emby klappt, kann ich leider nicht sagen.

    Wer die mal testen möchte, kann das gerne machen.
    Dateien

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Maven ()

  • Hallo @Maven,

    vielen Dank für die lauffahige Version. Auf meinem Pi mit OSMC starten meine Amazon Serien nun wieder.
    Im log ist aber trotzdem eine Fehlermeldung. Debug log habe ich angehängt.

    Auf meinem Windows Kodi erscheint ein Fenster das die Datei nicht abgespielt werden kann. Sobald ich ok klicke startet der Stream dann trotzdem.

    Aber es läuft erstmal wieder. Dafür nochmal vielen Dank.
    Gruß hedeon
    Dateien
    • kodi.log

      (585,91 kB, 1 mal heruntergeladen, zuletzt: )
  • @hedeon

    Der Error im Log ist normal, da Osmosis an Kodi eine Url übergibt, die nicht existiert.
    Dies soll verhindern, dass die Meldung "Mindestens eine Datei konnte nicht abgespielt werden" erscheint.

    Ist nur ein Workaround, mir fiel aber nicht besseres ein.

    hedeon schrieb:

    Auf meinem Windows Kodi erscheint ein Fenster das die Datei nicht abgespielt werden kann. Sobald ich ok klicke startet der Stream dann trotzdem.
    Komisch. Habe es auf meinem Windows-PC getestet. Bei mir erscheint das Fenster nicht.

    Edit: Getestet mit Netflix und 7tv
  • @Maven
    achso, alles klar.

    Unter Windows habe ich die ALPHA 1 laufen. Vielleicht liegt es daran.
    Habe es nochmal mit 7TV und Amazon getetset.
    Die Meldung "Mindestens eine Datei konnte nicht abgespielt werden" erscheint bei beiden Addons. Aber wie gesagt startet der Stream dann trotzdem.

    Das ist für mich aber nicht weiter schlimm, da ich die Windows Version nur zum Testen nutze.