Kodi 16.1 auf Ubuntu 16.04 LTS

  • Kodi 16.1 auf Ubuntu 16.04 LTS

    Hallo Ihr Lieben,
    habe auf einem Acer Aspire XC-705 mit ssd-Platte Ubuntu 16.04 LTS installiert. für DVB-C-Stick benutze ich den DVBSky T330. Dieser wird zwar von Ubuntu erkannt, braucht aber noch Firmware. Diese habe ich mir besorgt und installiert. Dann schnell VDR auf die Kiste und mit w_scan die Senderliste erstellt. Alles Easy! Nun noch schnell Kodi 16.1 drauf mit VDR-Plugin. Kodi gestartet und alles war gut. Habe noch ein MySQL-Server. Auf dem sind die Multimedia-Inhalte für alle Kodi-Clients (4). Also die advancedsettings angepasst. Fertig! Videos, Musik und TV liefen. War schon spät, also runterfahren und ab ins Bett.
    Nächster Tag. Rechner gestartet und ... Probleme!
    1. TV fehlt!
    2. Filme, Musik: fehlt!

    Nach etwas Suche kam ich drauf, dass Ubuntu mit systemd und SSD-Platten ein Problem zu haben scheint. Habe den Start von VDR über systemd gekillt und in benutze wieder initd. Alle Versuche systemd zu überreden auf die Firmeware zu warten scheiterte. Bin wohl zu blöde! Aber so geht es auch. Dennoch habe ich das Problem, das Kodi sehr lande für den Start braucht, um alle Sender zu aktualisieren. Das war unter Windows 10 nicht so.
    Das Filme und Musik fehlen hat wohl damit zu tun, dass auch hier ein Problem mit ssd auftritt. Wenn ich Kodi neu starte ist das Problem behoben (Kodi wird normaler Weise automatisch gestartet).

    Bleibt mein Problem mit der Fernbedienung.
    Hier bekomme ich es nicht hin, dass das Kontextmenü eines Films über die Kontext-Taste angezeigt wird. Es wird immer das von einem Film weiter oben in der Liste angezeigt. Keine Ahnung warum.
    Was aber viel schlimmer ist, dass wenn man den Rechner mit der der Powertaste auf der Fernbedienung schlafen legt und mit der gleichen Taste aufweckt, dann kackt Ubuntu vollständig ab. Dann hilft nur noch die Power-Taste am Rechner selbst!

    Hat jemand Ideen zu diesen Problemen?
    Gruß
    Jürgen
  • Das klingt aber nach ner Menge an Linuxproblemen, die alle irgendwie mit der Verfügbarkeit von Quellen zusammenhängen.
    Nimm die as.xml erst mal raus. Und LIVE-TV deaktivieren (da beide Kodi dazu veranlassen, auf einen Dienst zu warten).

    Die Sache mit der Contexttaste ist wirklich seltsam. Kannst du uns einen Screenshot davon machen?

    Energiemanagement kann auch mit den zu ladenden Modulen/Treibern zusammenhängen und auch ggf mit dem USB-Port.

    Koditechnisch können wir dir hier gerne weiterhelfen.
    Aber ich befürchte fast, dass die anderen Fragen eher was für das ubuntuforum sind.
    Auch wenn wir hier einige sehr fähige User zu dem Thema haben.
    [ (C8H10N4O2) ]


  • Mal eine andere Frage auch noch. Willst du auch Ubuntu benutzen oder nur den VDR mit KODI. Wenn du nur VDR und KODI haben möchtest dann schaue dir die MLD mal an. Da hast du alles was du haben möchtest ist schnell und einfach installiert. Kannst es auch zum Testen einfach mal auf einen USB Stick geben und von dem starten. Bei gefallen dann gleich auch installieren.
    HTPC: MLD 5.0 64Bit | ASRock Q1900M | 4GB Ram | DigitalDevices DVB-S2 | SSD 64GB | HDD 2,5 500GB | 250GB Backup HDD



    ZU VERKAUFEN
  • mafe68 schrieb:

    Mal eine andere Frage auch noch. Willst du auch Ubuntu benutzen oder nur den VDR mit KODI. Wenn du nur VDR und KODI haben möchtest dann schaue dir die MLD mal an. Da hast du alles was du haben möchtest ist schnell und einfach installiert. Kannst es auch zum Testen einfach mal auf einen USB Stick geben und von dem starten. Bei gefallen dann gleich auch installieren.
    Alternativ kann man sich auch mal easyVDR ansehen .... ;) Ist Ubuntu mit VDR und Kodi ... EasyVDR
  • mafe68 schrieb:

    Bei VDR führen viele Wege nach Rom!
    Stimmt, wichtig ist was man selbst haben will und ob das Eingesetzte den eigenen Wünschen entspricht ...
  • Hallo,

    welche VDR und Kodi Pakete benutzt du denn ?

    Die aus dem Ubuntu Xenial Repo oder andere ?

    Benutzt du vnsi, dieses sollte immer genau zu deinen Paketen passen, damit gab es schon oft Probleme

    Hauptsache man hat Spaß
    Hauptsache man hat Spaß

    No Debug .log, no issue - Kein Support ohne Debug-log .

    "Tears are running down the cheeks of Lady Liberty, the Lady is crying - I'm in Grief"

    "Bei genauerem Zusehen zeigt sich, dass jede starke äußere Machtentfaltung, sei sie politischer oder religiöser Art, bestimmte Menschen mit Dummheit schlägt." - Dietrich Bonhoeffer

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von vdr.tuxnet ()

  • Hallo alle zusammen,
    sorry, dass ich erst jetzt antworte.

    Habe fasst alle Probleme gelöst indem ich den Rechner komplett neu aufgesetzt habe. Und zwar zunächst komplett aus dem Ubuntu-Repository. Nachdem ich alles in Kodi eingerichtet hatte, habe ich Kodi auf die aktuelle Version gebracht. Jetzt habe ich TV und die Anbindung an den Samba- und MySQL-Server läuft auch. Natürlich musste ich VDR auch hier aus Systemd entfernen und über initd starten.

    Ein Problem ist aber geblieben. und da glaube ich an ein Kodi-Problem. Es handelt sich um Remote Control. Ich habe noch ein wenig rumgespielt und folgendes heraus gefunden.

    1. Ich habe eine Hama-Fernbedienung, die MCE kompatibel sein soll.
    2. Dies wird automatisch erkannt und funktioniert.
    3. Ich steuere Filme an und lasse mir die Liste der Filme anzeigen.
    4. Ich gehe durch die Liste mit der Down-Taste.
    5. Drücke ich die i-Taste, dann geschieht folgendes
    a - Wenn ich zuvor die Maus benutzt hatte und der Mauszeiger (nicht sichtbar) nicht über der Liste steht, wird die Liste geschlossen.
    b - Wenn der Mauszeiger (nicht sichtbar) über der Liste steht, wird das Kontext-Menü für den Film unter dem Mauszeiger angezeigt. Nicht der, der von der Ub- oder Down-Taste markiert wurde.

    Das klingt konfus, ist es aber nicht. Die Fernbedienung hat auch eine Maus-Emulation. Da scheinen sich zwei Input-Devices zu stören. Leider habe ich keine Idee, wie ich das bereinigen kann.
  • Lirc habe ich schon installiert. Bringt keine Änderung. Aber, ich muss zugeben, dass ich da auch Verständnisprobleme habe. Lang, lang ist es her, da habe ich mich mit Tastaturen unter Linux herumgeschlagen. Schon damals hatte ich Probleme, wenn es darum ging, Spezial-Tasten, die keinen einfachen Keycode senden, abzufangen. Die i-Taste schein so ein Kandidat zu sein. Da langt wohl mein Gehirn nicht. Soweit ich mich erinnere, muss man mit Ereignissen und Bit-Folgen arbeiten.
    Kennt sich jemand damit aus?

    Nachtrag:
    Habe noch ein wenig rumgespielt.
    Ergebnis:
    Es liegt an Kodi UND Fernbedienung!

    Die Fernbedienung sendet für die i-Taste einfach "Buttom 3"! Dumm nur, dass Kodi dies als Maus-Event interpretiert. Da nun Kodi den Fokus der Maus und der Tastatur nicht synchron hält, ergibt sich ein unterschied in der Interpretation von "Buttom 3". Dies zu lösen ginge nur, wenn man Kodi überreden könnte den Focus vom Tastatur-Curser und Maus-Zeiger zu synchronisieren. Leider langt mein Englisch nicht, um das dem Kodi-Team mitzuteilen. Vielleicht kann das jemand von Euch übernehmen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von juergen ()

  • korrekt wie @pacoma meint....per remote/keyboard.xml die tasten trennen

    Nicht klicken
    Wohnzimmer:
    Gehäuse Cooltek G3
    Netzteil Be quiet 300W
    Asrock Q1900 ITX
    RAM 2x4 GB Corsair Venegance
    System SSD: 1x Samsung 850 EVO
    LG BD/DVD Brenner
    Fernbedienung: Logitech Harmony Ultimate
    IR Empfänger: CoHaus RC6
    Hier auch nicht
    Server:
    Gehäuse Fractal Node 304
    Netzteil Be quiet 300W
    Asrock Q1900 ITX
    Digital Devices Cine S2
    RAM 2x4 GB Corsair Venegance
    System SSD: 1x Samsung 850 EVO
    Speicher: 2x2TB + 1x6TB WD RED

    Schlafzimmer:
    Raspberry Pi 2
    Octagon 1008G+ (HDMU/Enigma2)