[beta] [kodi 17] SkyGo Plugin

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Komm erst morgen zum Testen und Senf abgeben, aber

    tausend dank schon mal an @jojo und @libdev


    Leute wie ihr machen Kodi wieder sexy! ;-)
    Client 1: Raspi3, LibreElec, Kodi Krypton I Client 2: Intel i5 750, GeForce GTX 750, 8GB Ram, Win7, Kodi Krypton
    Display: Samsung UE40J6250
    Ego: Student aus Kiel, Kompetenzen in Lesen & Schreiben + Wirtschaft + Pädagogik I Alter Ego : Call me Mike
  • @dirtylion Heierei das ist jetzt aber unglücklich, wahrscheinlich musst du erstmal da anrufen und bitten dass die dir deine Geräte wieder freigeben.
    Am besten sagst du, dass du dein System heute mehrfach neu installiert hast (also dein Betriebssystem), kodi wird nicht als Grund zählen.

    Wenn du wieder Geräte zur Verfügung hast, gehe ich davon aus, das es mit der 0-byte grossen Datei wie vorhin beschrieben geht - es wird eine Geräteregistrierung kosten.
    Bitte schau nach dem ersten Video / Stream sofort im Anschluss nach, ob die 0-byte grosse datei dann 46 Byte gross ist. Wenn nicht, bitte sofort aufhören zu testen.
    Andernfalls bist du wieder alle Registrierungen los.
  • Ordner: /storage/.kodi/cdm/widevine/68747470733A2F2F777667756172642E736B792E6465/
    Dateiname: cdm

    Aber wie gesagt, das ist ein Versuch (der auch nur funktioniert, wenn du wieder Geräteregistrierungen hast)
    Sollte diese Datei nach dem ersten Video welches du angeklickt hast immer noch 0 byte gross sein, bitte aufhören.

    Wir können aufgrund fehlender registrierungen erst ab 21.05 weitertesten, sorry.
  • Eigentlich sollte ich ja schon längst im Bett sein - Danke ihr 2..... :sleeping: :D
    Habe es nach einiger Bastelei mit dem LE testbuild 420 zum laufen bekommen!

    1. Problem war der zwar vorhandene Chromium Browser aus der unofficial OE Repo der unter LE allerdings nicht lief(LE 8.0 repo funktioniert noch nicht)
    Folgende Anpassung war hier in der "default.py" nötig : sys.path.append('/storage/.kodi/addons/service.openelec.settings') ändern in sys.path.append('/storage/.kodi/addons/service.libreelec.settings')
    2. Einmaliges Einloggen per Chromium in SkyGo
    3. Unter storage/.kodi/userdata/addon_data/browser.chromium/profile/default/file system/plugins/000/application_x-ppapi-widevine-cdm/00 die darin vorhandene "46kb" Datei in storage/.kodi/cdm/widevine/68747470733A2F2777667756172642E736B792E6465 kopieren und diese danach in "cdm" umbenennen
    4. SkyGo Addon installieren und Anmeldedaten eingeben

    Vielen Dank an Euch 2 !!! (auch für meine, morgen vorhandenen, Augenringe.... :D )
    Spoiler anzeigen
    WOHNZIMMER-HTPC:Asus H270M-Plus,i3-7100,Kingston 4GB,aktueller LE tb,Samsung 128GB SSD,Silverstone LC-16,iMon+IR6,TVMosaic,Harmony Hub/Touch/KeyboardSERVER-HTPC:Asus Prime H270-Plus,i5-7500,Kingston 8GB,WIN10 Pro64,Samsung SSD,2xCineS2V6 unicable,Alphacrypt Classic mit MTD,TVMosaic-Server,Lights Out2SCHLAFZIMMER:NUC7i3BNH,aktueller LE tb,TVMosaicBAD:Pi2,aktueller LE tb,TVMosaicMobil-HTPC:Acer Iconia W700P,LE tb,TVMosaicWeTekHub:rb-agile build, Testmaschine

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von debutanker ()

  • Hallo,

    ich hatte noch einen slot frei und habe etwas getestet mit der neuesten milhouse build. ich habe das ganze mit der 46 kb Datei nicht gemacht,
    es wurde nichts abgespielt, obwohl er denke ich knapp dran war. hatte mich schon gefreut.

    das gerät bei sky wurde angelegt. hatte noch einen slot frei ;)
    die Datei im cdm ordner wurde nicht angelegt.

    muss im smoothstream plugin wirklich keine URL eingetragen sein oder eine Bandbreite so wie im amazon plugin?

    wie kann ich noch weiterhelfen? ich kann meine liste löschen, einen slot muss ich aber für mein nb behalten;)
    das kodi log hänge ich mal hier an. muss mir das mit pastebin erst mal ansehen

    edit: die entscheidenen Sachen stehen glaube ich bei 8:05:58
    edit2: der ordner 68747470733A2F2F777667756172642E736B792E6465 wird übrigens angelegt, die Datei nicht, auf sky ist aber ein gerät eingetragen
    Dateien
    • kodi.log

      (55,46 kB, 23 mal heruntergeladen, zuletzt: )
  • ich habe die variante "kopieren" benutzt. Meine liste war voll und habe diese zurückgesetzt. android app / und chromium verwendet und dann die datei kopiert. Läuft nun auch.
    Dafür könnt ihr rein gar nichts, aber die Sortierung ist genauso geknackt wie auf der SkyGo Seite selbst. :whistling:

    was mir auf anhieb aufgefallen ist, ich komme nicht über 540SD hinaus. Ich war der meinung, dass ich mit chromium, zwar nicht immer, zumindest 720p hatte. Ich konnte es nicht als Videoinfo sehen, aber gefühlt war es 720p.

    An die Sky receiver benutzer: habt ihr eine DD spur, wenn ihr sky go darüber laufen lässt? Sind die Videos dort HD?
  • este schrieb:

    wie kann ich noch weiterhelfen? ich kann meine liste löschen, einen slot muss ich aber für mein nb behalten;)
    Das Problem, welches du hier nennst, ist das, was wir in der Einleitung angesprochen haben: Wir haben keine Erfahrung im Anlegen eines neuen Gerätes.

    - Gestern Abend habe ich eine Änderung in ssd_wv eingebaut, mit der die Gräteregistrierung funktionieren könnte.
    Der freie Slot, den du noch hattest, ist leider erst einmal weg, bis zum nächsten Reset.

    - Was wir nun brauchen ist jemand, der noch einen freies gerät hat und für uns einmal testet, ob mit der aktuellsten Version ssd_wv die Geräteregsitrierung klappt.
    Gerne kann sich auch die-/derjenige per PM bei mir melden, um das detailliert anzugehen, am Liebsten unter Windows, da ich dafür die ssd_wv kompiliert vorliegen habe

    Danke für euer Verständnis!
  • urls oder eine bandbreite müssen nicht eingetragen werden.

    Wir sind uns mitlerweile relativ sicher dass kodi zur zeit keine eigene registrierung anlegen kann vermuten aber auch woran es liegt.

    Was mal probieren kannst:
    Lege in dem erstellten Ordner (687...) eine Datei namens cdm an. Einfach nur die Datei und nichts weiter (also kein inhalt keine dateiendung!).
    Danach probiere es nochmal.
    Die liste musst du dazu natürlich zurücksetzen. Registriere aber besser deknen Laptop zuerst damit du diese definitiv behällst.
  • dreamer schrieb:

    was mir auf anhieb aufgefallen ist, ich komme nicht über 540SD hinaus. Ich war der meinung, dass ich mit chromium, zwar nicht immer, zumindest 720p hatte. Ich konnte es nicht als Videoinfo sehen, aber gefühlt war es 720p.
    im kodi log wird der name der manifest Datei ausgegeben (such mal nach Manifest). Beispiel:

    Quellcode

    1. http://skywebvod-s.akamaihd.net/ondemand/Production/de_at/movies/UNI146967332001/UNI146967332001.ism/Manifest

    Diese URL kannst du so in deinen Browser eingeben und bekommst XML zurück mit den Auflösungen, die unterstützt werden.
    Zumindest ist das das "Futter", welches wir dort derzeit bekommen.
    Wenn ihr Manifest Dateien mit höheren Auflösungen seht, dann lasst uns das bitte wissen.
    Vlt. machen wir auch etwas noch nicht ganz richtig.
  • Welcher Film ist es? ich habe die ersten vier Filme mal probiert und alle sind max 540SD

    edit:
    meine URL sieht aber auch leicht anders aus:

    Quellcode

    1. http://skywebvod-s.akamaihd.net/ondemand/Production/de_at/movies/F30050458____100332001/F30050458____100332001.ism/Manifest
    hab nun die ersten 10 Filme ausprobiert.

    edit2:
    hab nun eine serie(Silicon Valley) gefunden, die 720p hat. scheint wohl sehr rar zu sein, was HD angeht. hätte ich so nicht gedacht...

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von dreamer ()

  • libdev schrieb:

    este schrieb:

    wie kann ich noch weiterhelfen? ich kann meine liste löschen, einen slot muss ich aber für mein nb behalten;)
    Das Problem, welches du hier nennst, ist das, was wir in der Einleitung angesprochen haben: Wir haben keine Erfahrung im Anlegen eines neuen Gerätes.
    - Gestern Abend habe ich eine Änderung in ssd_wv eingebaut, mit der die Gräteregistrierung funktionieren könnte.
    Der freie Slot, den du noch hattest, ist leider erst einmal weg, bis zum nächsten Reset.

    - Was wir nun brauchen ist jemand, der noch einen freies gerät hat und für uns einmal testet, ob mit der aktuellsten Version ssd_wv die Geräteregsitrierung klappt.
    Gerne kann sich auch die-/derjenige per PM bei mir melden, um das detailliert anzugehen, am Liebsten unter Windows, da ich dafür die ssd_wv kompiliert vorliegen habe

    Danke für euer Verständnis!
    Hi,

    ich hab aktuell 2 Geräte registriert, also hätte ich noch zwei Slots zum Testen frei.
    Wir können heute Abend gerne mal testen, habe ein Windows 10 Testnotebook.
  • jojo schrieb:

    68747470733A2F2F777667756172642E736B792E6465

    jojo schrieb:

    libssd_wv.dll/

    jojo schrieb:

    Hallo Liebe Kodinerds,

    Wir (@libdev, @jojo) haben in den letzten Wochen ein wenig für euch gewerkelt und möchten euch nun den ersten Zwischenstand unserer Arbeit zur Verfügung stellen: Das ersehnte SkyGo Plugin.

    Durch das inputstream.smoothstream Addon von mapfau wird es möglich VOD’s und auch LiveTV von skygo abzuspielen.
    Dieses Addon hat seinen Weg in den Kodi-Master bereits gefunden und ist nun auf dem Weg in die verschiedenen Builds (In den Windows/Mac nightlies ist es schon enthalten).

    Ihr seid es von dem Amazon-Prime Addon bereits gewohnt: Zu dem inputstream Addon benötigt ihr noch zwei weitere DLLs um die geschützten Videos abspielen zu können. (Zur Referenz: [kodi 17] plugin.amazon.prime reloaded)


    Wir können leider nicht mehr genau testen ob das Kodi Plugin automatisch eine Geräteregistrierung anlegt oder nicht (Wir haben unsere Registrierungen zur Zeit aufgebraucht).
    Aber mit den folgenden Schritten solltet ihr zumindest auf dem gleichen Gerät die selbe Registrierung für Chrome und Kodi benutzen können.


    Habt ihr die Folgenden Schritte genau befolgt und es spielt kein Video ab hört bitte erst mal auf zu testen und meldet euch hier mit einem Log und welche Schritte ihr durchgeführt habt. Wir wollen nicht, dass Ihr alle Geräte Registrierungen verschwendet und am Ende gar nicht mehr gucken könnt!



    In dem selben Pfad in dem auch Eure widevine.dll/so und die libssd_wv.dll/so liegen erstellt Ihr bitte den Ordner “widevine” und in diesem Ordner wiederum den Ordner “68747470733A2F2F777667756172642E736B792E6465”.

    Jetzt müssen wir zwischen den verschiedenen Betriebssystem unterscheiden:

    Unter Linux Geht in den Ordne

    Quellcode

    1. ~/.config/google-chrome/Default/File System/Plugins

    Unter Windows in den Ordner:

    Quellcode

    1. C:\Users\[user]\AppData\Local\Google\Chrome\User Data\Default\File System\Plugins\
    Unter OSX (vermutlich!):

    Quellcode

    1. /Users/Benutzername/Library/Application Support/Google/Chrome/Default/File System/Plugins

    Hier gibt es nun mehrere Möglichkeiten:
    Ihr habt mehrere Unterordner nach dem Schema 000, 001, 002 usw. in diesen Unterordnern wiederum den Unterordner application_x-ppapi-widevine-cdm und dort drin wieder ein Unterordner (ja ich mag das Wort) 00 oder 01 oder 02 usw. in diesem letzten Ordner müsst ihr eine Datei finden die wiederum einen Numerischen Namen hat. Bei mir heißt sie z.B. 00000062 sie kann aber auch z.B. 00000005 heißen. Wichtig ist nun: Diese Datei muss genau 46 Byte groß sein. Es gibt bei vielen von euch vermutlich auch eine mit 77 Byte - das ist nicht die richtige Datei!
    Habt Ihr die korrekte 46 Byte große Datei gefunden kopiert ihr diese bitte in den oben angelegten Ordner “68747470733A2F2F777667756172642E736B792E6465”. Anschließend benennt ihr diese Datei in "cdm" um.
    Das war’s dann auch schon mit der Einrichtung des inputstream.smoothstream addons.


    Bitte aktiviert das inputstream.smoothstream nun in euren Kodi Einstellungen!

    Im folgenden GitHub Repository findet Ihr die Erste (sehr unfertige) Version eines skygo Plugins: https://github.com/trummerjo/plugin.video.skygo
    (nein vorerst kein Repo!) - (Mitarbeit in Form von PR gerne gesehen!)

    Dieses Einfach installieren, Eure Login Daten eingeben und mal schauen was sich so abspielen lässt und uns Eure Erfahrungen berichten.

    Viel Spaß Damit!

    Gruß
    libdev, jojo

    Bei Fehlern Fragen usw. bitte immer ein log mit aktiviertem Debug hinzufügen!


    Dank geht schonmal jetzt an:
    @don
    @marriol123343
    phil65
    Wäre es auch möglich über TeamViewer? Hätte noch platz in der Geräte Liste !!! Es müssten nur sämtliche Einstellungen selber gemacht werden, da ich (noch) nicht ganz mit komme;-))
  • libdev schrieb:

    - Gestern Abend habe ich eine Änderung in ssd_wv eingebaut, mit der die Gräteregistrierung funktionieren könnte.
    Der freie Slot, den du noch hattest, ist leider erst einmal weg, bis zum nächsten Reset.

    - Was wir nun brauchen ist jemand, der noch einen freies gerät hat und für uns einmal testet, ob mit der aktuellsten Version ssd_wv die Geräteregsitrierung klappt.
    Gerne kann sich auch die-/derjenige per PM bei mir melden, um das detailliert anzugehen, am Liebsten unter Windows, da ich dafür die ssd_wv kompiliert vorliegen habe
    ich kann meine liste momentan resetten.
    dann registriere ich am abend das Notebook und die restlichen Registrierungen kann ich zum testen nehmen.
    ich melde mich dann wenn es soweit ist, vielleicht braucht ihr ja dann was anderes. kann auch erst morgen sein.
    Windows geht in Ordnung wenn du mir die Dateien zur verfügung stellen könntest. die widvine finde ich, da gibt es ja hier irgendwo eine Anleitung.
    habs nur unter Windows noch nie getestet. das gute ist dass ich das auch tagsüber machen könnte ;)