RasPi 2, Openelec 6: Videos in Fotosammlungen ruckeln

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • RasPi 2, Openelec 6: Videos in Fotosammlungen ruckeln

    Hallo Leute,

    nach langem erfolglosem Suchen in den Forumthemen schreibie ich nun mein Problem in diesen Thread. Falls das Thema schon irgendwo beschrieben und vielleicht sogar gelöst wurde, würde ich mich über einen Hinweis freuen.

    Wenn ich eine Fotosammlung mit der Diaschau-Funktion durchlaufen lasse und es kommt ein Video, dann ruckelt das Video (auch ohne Diaschau-Funktion). Aufgenommen sind das Video mit 1280 x 720. Bis das Video überhaupt anfängt, vergehen immer ein paar Sekunden. Dann werden ca. 5..6 Sek. sauber abgespielt und danach fängt es an zu ruckeln. Ich habe den Eindruck, dass der Puffer leer läuft und erst wieder Daten nachgeladen werden müssen, bevor es weiter geht. Das Ganze verstehe ich nicht, da alle Filme oder Serien, die ich im Bereich Videos oder Serien abspiele, überhaupt keine Probleme bereiten. Sogar Full-HD wird dort problemlos abgespielt. Hat hierzu jemand eine Idee, woran das liegen könnte?

    Diese Problem hatte ich übrigens schon immer, auch als ich noch meinen ersten Raspberry Pi (1) B hatte. Dort war das Problem sogar noch schlimmer. Mit dem PasPi 2 ist es nicht mehr ganz so schlimm, aber immer noch sehr nervig. Ich war nur bisher zu faul, mich um diese Problem zu kümmern... Vielleicht könnt ihr mir ja helfen.

    Meine Konfiguration:
    - Openelec 6.0.3 auf Raspberry Pi 2
    - Daten liegen auf meinem NAS QNAP TS-251
    - Verbunden über WLAN n (2,4 GHz), WLAN Stick mit 300MBit/s, Router Fritzbox 7490
    - Daten in Openelec eingepflegt über SMB Netzwerkfreigaben

    Danke und LG
    aeppsi
  • Bei den Videos bei deinen Bildern wird MJPEG und PCM als Codecs angegeben.

    Das sind Codecs, die sehr hohe Bitraten erzeugen und sich eigentlich nicht eignen, um sie über das "limitierte" Netzwerk zu übertragen.
    Sprich der Raspberry läd 5-6 sek vor bis sein Puffer voll ist und spielt diese ab. Und wartet dann wieder auf Daten, die übers Netz nachkommen.

    Man könnte zwar die Netzwerkperformance verbessern (Cache Werte von Kodi ändern oder mal NFS anstatt dem langsameren SMB probieren), aber am sinnvollsten wäre, wenn du die Videos runter komprimieren würdest, wenn du sie über das Netzwerk streamen willst. z.B. mit H264 und AAC
  • Alles klar. Ich verstehe. Dabke für die Erklärungen.

    Ich werde nun erstmal probieren, die Tipps bezüglich des Netzwerkes anzuwenden und wenn das nichts bringt, die Videos zu konvertieren. Könnt ihr mir zum Konvertieren ein Programm empfehlen? Es sollte bitte ein einfach zu bedienendes Programm sein. Sowas wie MakeMKV. Ich hatte mal Handbrake probiert und weil ich die Einstellmöglichkeiten nicht kappiert habe, kam nur Quatsch dabei raus. Oder gibt es da mittlerweile einen "one-click-Modus" für Leute wie mich?
  • Ich habe mittlerweile mal probehalber ein Video konvertiert (H.264, AAC) und es läuft ruckelfrei. Danach habe ich mir gedacht, dass das Konvertieren ja auch gleich mein QNAP-NAS per Transcoding machen kann und ich dann die Daten via DLNA-Quelle bei Kodi einpflegen kann. Nur kann ich dann mit dieser Lösung die Fotos und die Videos nur noch getrennt aufrufen und es spielt mir alles zusammen - egal ob Video oder Foto - nicht mehr in der Reihenfolge der Aufnahme/Dateinamen. Also werde ich wohl alle Videos im Stammordner mit den konvertierten Videos austauschen müssen und dann alles wieder als SMB-Quelle einpflegen. Puh... Das Sortieren wird ganz schön Arbeit werden...

    Mal sehen, vielleich kann ich ja mit Handbrake eine Batch-Konvertierung meines gesamten Foto-Ordners inkl. Unterordnern hinbekommen, wo ich die konvertierte Videodatei ins Quellverzeichnis schreiben lassen kann. Falls jemand dazu einen Tipp hat, ware ich dankbar.