Sat>IP Signal in Kodi ansehen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Sat>IP Signal in Kodi ansehen

    Guten Abend,

    ich bin neu hier im Forum und probiere mich gerade an Kodi bzw. daran mein Sat>Ip Signal dort anzusehen.

    Also mein Ziel ist es, dass das Sat Signal zu meinem TV kommt.
    Dazu habe ich mir nun überlegt Sat>Ip zu benutzen, da ich hierfür kein neues KAbel ziehen muss, dank Powerline Adaptern.
    Als Sat>IP Router kommt ein "Digibit Twin" von Telestar zum Einsatz. Dieser funktioniert auch schon, da ich mit dem Windows Programm DVBViewer auf meinem Laptop das Sat>Ip Signal empfangen kann. Ich kann also TV über Lan sehen!

    Jetzt möchte ich natürlich komfortabel (wie mit einem normalen Receiver) TV sehen und nicht den Laptop an den Fernseher anschließen. Deshalb möchte ich mit meinem HTPC auf dem seit heute nun das neuste Openelec + Kodi drauf ist dfür nutzen.

    Am einafchsten wäre es, wenn es ein Addon oder Programm geben würde mit dem ich das Sat>Ip Signal direkt emfangen könnte. Gibt es da etwas, ich abe nämlich nichts dergleichen gefunden?
    Nun habe ich mich etwas belesen und herausgefunden, dass man wohl mit einem VDR Server(backend) und einem VDR Client(frontend) sämlichte DVB Signale in Kodi implementieren kann und das dies ebenfalls mit Sat>Ip möglich sein soll.

    Meine Frage ist nun:
    Kann ich backend und frontend auf meinem HTPC mit Openelec + Kodi realisieren und falls es geht, wie verdammt nochmal geht das???????

    Ich habe es heute schon den ganzen Tag probiert und habe jetzt aufgeben und frage hier deshalb um Rat.

    Gerne würde ich mich genauer in etwas einlesen was mir hilft, das VDR Wiki tut es z.B. nicht, nur um das Vorweg zu nehmen. Oder ich bin zu doof es zu lesen.

    Was ich bisher erreicht habe:
    VDR Backend ist intaslliert und aktiviert und der Vnsi Client so heißt er glaube ich. Und was ich jetzt ganz neu entdeckt habe ist, dass ich System -> TV -> Cient spezifische Einstellungen das VDR OSD sehen konnte und beim rumspielen bin ich auch auf den wirbelscan gestoßen, von dem ich gelsen hatte. Ich dachte mir super, jetzt geht es richtig los, da er auch meinen Sat>Ip Router mit der richtigen IP angezeigt hat, jedoch brachte der Scan kein einziges Programm. Unten im Log stand dann immer:
    "frontend status () could not open /dev/dvb/adapter-5 ....."
    Was wohl so viel heißt wie, iwas ann nicht auf den Tuner zugreifen...



    Ich bin mal gespannt wie hier so die Resonanz bei dieser Problemstellung ist.



    Beste Grüße und noch einen schönen Sonntag
    zogga
  • Technisch gesehen hast du aus dem Gerät heraus einen IP-Stream.
    Dafür wäre dann der Simple-IPTV Client der richtige. Dein Backend würde bereits mit dem Digibit erledigt sein.
    In dem Simple-IPTV Client muss ein Pfad zu einer Playlist eingetragen werden.
    In etwa so: DIGIBIT-012345:8080/m3u

    Den VDR benötigst du nicht.

    Hab noch was gefunden:
    debacher.de/wiki/Telestar_Digibit_R1
    [ (C8H10N4O2) ]


  • don schrieb:

    Technisch gesehen hast du aus dem Gerät heraus einen IP-Stream.
    Dafür wäre dann der Simple-IPTV Client der richtige.
    Ja und Nein, du hast die "Primitive" Variante - einfach die m3u von der Box zu nehmen und die beim IPTV Plugin einzutragen -> damit hat man kein EPG, keine Möglichkeit des Sender suchen und schlechtere Umschaltzeiten.

    Dann gibt es noch die Möglichkeit das ganze mit einem PVR Server zu benutzen - da verhält sich Sat>IP genauso wie eine normale TV Karte die man einbauen könnte (Timeshift, Aufnahme etc).

    Ich geh jetzt mal von OpenELEC 6.0.1 aus, da gibt es die Möglichkeit mittels VDR oder Tvh das ganze zu betreiben.

    Dazu braucht man einen TV Server (backend) im Falle von OE vdr-addon oder das Tvheadend Addon welche sich in der Repo befinden unter Dienste (Tvh ist in der unofficial Repo). Das stellt erstmal den blanken TV Server zur Verfügung. Um das Signal dann in Kodi zu bekommen muss auch noch das Client-Addon aktiviert werden welches unter PVR sich befindet. ACHTUNG immer nur ein Addon aktiviert haben, sonst gibt das die blödesten Probleme.

    Generell empfiehlt es sich bei OE -> Programme -> OpenELEC Configuration -> Netzwerk "vor dem Start von Kodi auf das Netzwerk warten" anzuhaken, weil ohne Netzwerk kein Sat>IP.

    VDR: um VDR Sat>IP beizubringen in die Einstellungen des vdr-addons gehen und dort unter plugins eigentlich nur satip anmachen, Rest aus außer du brauchst irgend ein Plugin dringend.
    Unter DVB alles abgehakt lassen. Dann sollte VDR so klappen wie es sollte inkl Kanalsuche etc. Du kannst auch auf channelpedia dir deine Kanalliste zusammenkopieren und in die \\deine-ip\Userdata\addon_data\service.multimedia.vdr-addon\config\channels.conf eintragen. Dazu muss aber das vdr-addon deaktiviert sein sonst überschreibt VDR beim Neustart wieder alle Kanäle.

    Weitere Einstellungen kannst du entweder direkt in der Config machen oder Kodi->Einstellungen->TV->Clientspezifisch->Clientspezifische Einstellungen und dort im VDR Fenster kannst du unter Plugins noch das Sat>IP Plugin einstellen.

    Tvh: Andere Möglichkeit wäre Tvheadend, aber gerade bei Sat>IP wäre es dringend zu empfehlen die 4.1.x Version zu nehmen - siehe meine Signatur, einfach unter Addons aus Datei installieren - zwar noch in Entwicklung aber deutlich besser bei Sat>IP als die 4.0.x aus der Repo. Das einzige was zu bedenken ist das am Anfang der der Installationswizard noch bisschen buggy ist - den kann man aber wegklicken zur Not. Dort erfolgt die Einrichtung komplett über das Webinterface. Unter PVR-Clients das Tvh HTSP Addon aktivieren und unter Dienste mal gucken was beim Tvheadend Addon so eingestellt ist -> dort unter DVB -> Wait for Network musst du probieren ob man das anlässt oder aus macht - eigentlich lässt man das an (5sec oder so) das gab bei mir aber schonmal ein Problem auf einem HTPC - die anderen funktionieren damit einwandfrei.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von CvH ()

  • Also das mit dem Simple-IPTV Client habe ich jetzt nochmal ausprobiert und dabei leider noch keinen Erfolg gehbat...
    Ich habe verschiedene m3u's ausprobiert und auch immer brav die IP des Sat>IP routers eingetragen, doch leider nie ein Bild erhalten auch nach mehrmaligen Reboots nicht. Sehr schade...
    Also die Channel werden jetzt bei TV angezeigt, bei manchen m3u's passiert nichts beim auswählen eines Channels bei anderen steht immerhin schonmal "Working" rechts unten, aber das läuft dann fröhlich vor sich hin und nichts passiert.

    Also bräuchte ich dahningehend noch etwas Unterstützung.

    @CvH

    Das mit der PVR Variante hatte ich ja vorher schonmal ausprobiert, aber "vdr-addon", das mittlerweile übrigens "VDR PVR Backend" heißt, hat da irgendwie keinen Sendersuchlauf durchführen können. Den Sat>Ip Router hat er aber erkannt im VDR OSD.
    Verbindung zwischen "VDR VNSI Client" und "VDR PVR Backend stand auch, es gab jedenfalls keine Fehlermeldung.

    Das werde ich auch nochmal mit einer Channelliste probieren so wie du es beschriben hast. Aber ich weiß nicht ob das sinnvoll ist, da er beim Suchlauf ja nichts gefunden hat??? Der Suchlauf geht übrigens NUR 1 Minute und nicht viel länger...




    Grüße
    zogga
  • zogga schrieb:

    frontend status () could not open /dev/dvb/adapter-5 .....
    Solange das kommt denkt VDR das ein TV Karte im System drin ist. Logischerweiße nimmt er dann die. Hast du bei Kodi->Einstellungen->TV->Clientspezifisch->Clientspezifische Einstellungen mal geguckt ?

    so geht das bei mir problemlos in VDR

    Im Zweifelsfall dann halt Tvh ;)
  • hi,

    ich probiere mich auch gerade an dem DIGIBIT.
    Habe das Problem das er mir keine Sender mehr finden will. Anfangs ging es, dann habe ich nochmals über das wirbelscan controll plugin die senderliste gelöscht und nun findet er nur manchmal ein paar.
    Im wirbelscan unter der OSD Stuerung wirft er mir immer den Fehler "GetFrontendStatus(): could not open /dev/dvb/@adapter0/: blabla(Frequenz)" aus.
    Woran könnte das liegen?

    Grüße
    Kev0
  • Heyoooo,

    kam erst heute dazu es auszuprobieren und es hat nun geklappt!
    Nachdem ich mir ein paar channel in die \channels.conf gepackt habe hat es tatsächlich funktioniert. Total happy :D:D:D

    Werde mich da die Tage jetzt nochmal weiter damit beschäftigen, was man da so machen kann und wie das alles so funktioniert. Hauptsache ist erstmal für mich, dass es geht.

    Besten Dank an CvH und auch danke auch an don, auch wenn ich das leider nicht hinbekommen habe.

    grüße
    zogga
  • Heyo,

    also mit VDR bekomme ich immer wieder diese "no channel data" Meldung und das nervt tierisch. Jetzt möchte ich versuchen den Sat>IP Empfang mit TvHeadend zu realisieren.
    Nun habe ich es mit der Version 4.0.x und mit der 4.1.x von TvHeadend Backend ausprobiert.

    Bei 4.1.x gab es das Problem, dass immer die Meldung aufploppte "Verbindung unterbrochen" und ich konnte auch nicht auf das Webinterace zugreifen
    Bei der 4.0.x hatte ich das Problem nicht und ich kann auch über das Webinterface auf das Backend zugreifen. Jedoch findet er den Sat>IP Server nicht. Gibt es dazu eine detaillierte Anleitung? In Kodi habe ich bisher nichts gemacht und auch keine Channelliste oder etwas anderes eingebunden.

    Vllt kann mir ja noch einmal jemand helfen.

    Grüße
    zogga
  • Jap habe OE(OpenELEC) 6.0.3 drauf. Da muss ich erstmal kurz die 4.1 wieder drauf machen und dann die service.log posten oder wird das log versionsübergreifend geführt?

    Also ich weiß nicht genau welche service.log du meinst.
    Ich habe folgendes gefunden
    /storage/.kodi/addons/service.multimedia.tvheadend/system.d

    aber der Inhalt ist doch sehr unspektakulär:

    Quellcode

    1. [Unit]
    2. Description=TVHeadend Service
    3. After=graphical.target
    4. [Service]
    5. ExecStart=/bin/sh -c "exec sh /storage/.kodi/addons/service.multimedia.tvheadend/bin/tvheadend.start"
    6. TimeoutStopSec=2
    7. Restart=always
    8. RestartSec=2
    9. StartLimitInterval=0
    10. [Install]
    11. WantedBy=kodi.target
    Alles anzeigen
    Habe jetzt das kodi.log gefunden und hier ein Asuzug der letzten Zeilen, die den Fehler anzeigen:

    Quellcode

    1. 00:22:14 T:140517404911360 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 1
    2. 00:22:14 T:140517910664960 NOTICE: Thread AddonStatus pvr.hts start, auto delete: true
    3. 00:22:15 T:140517027342080 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 127.0.0.1:9982
    4. 00:22:25 T:140517404911360 ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (1) from Create and is not usable
    5. 00:22:25 T:140517404911360 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 1
    6. 00:22:25 T:140517910664960 NOTICE: Thread AddonStatus pvr.hts start, auto delete: true
    7. 00:22:26 T:140517027342080 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 127.0.0.1:9982
    8. 00:22:36 T:140517404911360 ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (1) from Create and is not usable
    9. 00:22:36 T:140517404911360 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 1
    10. 00:22:36 T:140517910664960 NOTICE: Thread AddonStatus pvr.hts start, auto delete: true
    11. 00:22:37 T:140517027342080 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 127.0.0.1:9982
    12. 00:22:47 T:140517404911360 ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (1) from Create and is not usable
    13. 00:22:47 T:140517404911360 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 1
    14. 00:22:47 T:140517910664960 NOTICE: Thread AddonStatus pvr.hts start, auto delete: true
    15. 00:22:48 T:140517027342080 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 127.0.0.1:9982
    Alles anzeigen

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von zogga ()

  • /storage/.kodi/userdata/addon_data/service.multimedia.tvheadend/service.log
    bzw
    \\deine-ip-vom-htpc\Userdata\addon_data\service.multimedia.tvheadend\service.log

    Die meinte ich
    Du musst auf das Web Admin zugreifen können, wenn nicht ist was falsch. Bzw vorher mal den addon_data/service.multimedia.tvheadend/ löschen ? Evtl haben sich da Inkompatibilitäten eingestellt.
  • Also ich greife über filezilla auf den HTPC zu, weil wenn ich nur die IP des HTPC im Browser eingebe, dann habe ich da ich nur rechts oben die Reiter: Profiles Remote Movies, ... stehen und nicht mehr.

    Jedenfalls ist in dem Ordner /storage/.kodi/userdata/addon_data/service.multimedia.tvheadend/ keine service.log gewesen, außer diese ist noch irgendwie versteckt.

    Jetzt habe ich das addon deinstalliert und den Ordner "service.multimedia.tvheadend" gelöscht und die Version 4.1 nochmal aus der zip intalliert und 2 mal neu gestartet und der Ordner wird nicht mehr erstellt.


    Edit://

    Müsste ich das pvr hts aus deiner Database auch installieren und wofür ist das eigentlich genau genau?

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von zogga ()

  • Du hast das hier heruntergeladen und Kodi -> Einstellungen -> Addons -> Addon installieren -> zip ausgewählt -> neugestartet?

    Weil wie es aus sieht hat du die Falsche version heruntergeladen - du hast einen PC mit Intel und so als HTPC ja ?


    zogga schrieb:

    weil wenn ich nur die IP des HTPC im Browser eingebe
    die IP Adresse musst du im Winmdows Explorer eingeben :)
  • Ja genau die habe ich runtergeladen.
    Ja ich habe einen eingenständigen HTPC auf dem Win7 und Openelec + Kodi drauf ist. Mit Bootloader um zwischen Win7 und Openelec zu wählen.

    Oh ja im Explorer gehts , ups :rolleyes:

    Aber da ist natürlich jetzt der Ordner immer noch nicht, da es ja evtl. die falsche Version war, die ich ausprobiert habe...


    Edit://

    Brauche ich das "WeTek _PLay......" ?

    Edit://

    Das hat das gleiche Verhalten wie das Generic, schade...

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von zogga ()

  • Ich hab die dumpfe Vermutung das ich beim erstellen irgendwas vergeigt habe, ich habe mal das ganze geupdatet.

    Einfach nochmal probieren mit der Tvh-OE7/tvheadend-4.1-1592-06.03.2016/

    Nur komisch das es bei mir funktioniert hatte - beim erneuten probieren dann aber nicht O_o (da hab ich irgendwas komplett versaut wie es scheint)