Angepinnt Ember Media Manager 1.4.8.0 Alpha - Diskussionsthread

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Morgen, mal ne frage kann es sein das Die Set art falsch in die Mysql datenbank geschrieben werden?
    In Ember hab ich den Pfad smb://192.168.112.17/HelMedia1/Set Artwork
    in der Datenbank steht aber mein normaler Thumbnail Ordner \\192.168.112.17\Kodi\userdata\Thumbnails\Titanen Collection-poster.jpg
    [img]http://img5.fotos-hochladen.net/thumbnail/screenshot9p4fbq2zikj_thumb.jpg[/img]
    Bilder
    • Screenshot (9).png

      802,14 kB, 3.600×1.080, 12 mal angesehen
    Intel I3 | 4 GB Ram | Cooltek G3 | Win 8 x64 |URC 7962 | Gotham Beta 3 | HorizonzV
    AMD Phenom II X4 Black Edition | 16 GB Ram | Nividia GTX460 | Win 8 x64 | Gotham Beta 3 | HorizonzV
    Samsung UE46F6500
  • Nepomuk schrieb:

    waffi schrieb:

    Ok alles klar, Backup hat man ja eigentlich durch Ember oder? Dort sind ja alle NFO's Bilder, Trailers etc gespeichert

    Also bei den Filmen hab ich keine Bedenken aber bei den Serien hab ich einbisschen Schiss aber ich probiere das morgen mal aus:)
    Wat nix verstehen - ich Schwabe.Vor was hast du Schiss?
    textures13.db und vom Ordner Thumbnails kannst du ja einfach umbenennen, dann hast du da eine Art Backup.
    Die Kodi-db kannst du doch auch einfach umbenennen, wenn du die Standart-db nutzt. Bei mySQL oder Maria-db nimmst du einfach das Heidi-SQL Programm und erstellst einen SQL-Export. phpmyadmin müsste doch auch gehen, hab aber damit keine Erfahrung.

    :D

    Also das mit der SQL Export müsste ich mir mal anschauen, der Rest klingt nicht schwer:) aber wenn du das ja eh schon so gemacht hast kannst du es testen? Ich lad dir sonst mal die neueste komblimierte Version hoch :)
  • Hallo zusammen, nachdem die ersten kleineren Probleme behoben sind, kommen jetzt die für mich größeren Fragen :)

    Folgende Situation:

    Openelec mit Kodi, bisher habe ich immer mit Media Elch die nfo und das Artwork gescrapt. Danach wurden die CDArts usw mit Artwork Download Manager in die Kodi DB gebracht. Da Media Elch immer mal wieder Probleme macht, würd eich jetzt Ember nutzen wollen.

    Da Ember mir beim einlesen nicht meine bereits vorhanden CDArts und Logos einliest aufgrund der falschen Namen (disc statt discart usw.) habe ich mir folgendes überlegt. Vielleicht könnt ihr einmal drüber gucken ob das so ok ist.

    Ich lösche auf meinem NAS alle alten CDArtworks. Dann exportiere ich nfo und Artwork aus Kodi per video Export. In Ember habe ich das kodi Interface aktiviert, der Zugriff funktioniert auch. Jetzt würde ich alle Filme von meinem Nas einlesen und dann per Tools - Kodi Interface - Datenbank aktualisieren, die neuen Artworks direkt in die Kodi DB schreiben lassen. Kann man das so machen ?

    Wie bekomme ich in Ember alle Filme als grün angezeigt , sodass ich beim nächsten aktualiseren nur die neuen Filme mit rot sehe ?

    Danke und Gruß
  • Eispirat schrieb:

    Hallo zusammen, nachdem die ersten kleineren Probleme behoben sind, kommen jetzt die für mich größeren Fragen :)

    Folgende Situation:

    Openelec mit Kodi, bisher habe ich immer mit Media Elch die nfo und das Artwork gescrapt. Danach wurden die CDArts usw mit Artwork Download Manager in die Kodi DB gebracht. Da Media Elch immer mal wieder Probleme macht, würd eich jetzt Ember nutzen wollen.

    Da Ember mir beim einlesen nicht meine bereits vorhanden CDArts und Logos einliest aufgrund der falschen Namen (disc statt discart usw.) habe ich mir folgendes überlegt. Vielleicht könnt ihr einmal drüber gucken ob das so ok ist.

    Ich lösche auf meinem NAS alle alten CDArtworks. Dann exportiere ich nfo und Artwork aus Kodi per video Export. In Ember habe ich das kodi Interface aktiviert, der Zugriff funktioniert auch. Jetzt würde ich alle Filme von meinem Nas einlesen und dann per Tools - Kodi Interface - Datenbank aktualisieren, die neuen Artworks direkt in die Kodi DB schreiben lassen. Kann man das so machen ?

    Wie bekomme ich in Ember alle Filme als grün angezeigt , sodass ich beim nächsten aktualiseren nur die neuen Filme mit rot sehe ?

    Danke und Gruß
    Tools => Kodi Interface => Datenbank aktualisieren führt nur das normale Kodi Datenbank Update aus, hiermit werden die zusätzlichen Bilder nicht in die Kodi DB geschrieben.
    Für einen Sync der Bilder kannst du einen oder mehrere Filme markieren und dann per Kontextmenü => Kodi Interface => Sync den "richtigen" Sync starten. Es wird dann in Kürze auch die Möglichkeit über Tools geben, alles in einem Rutsch zu syncen.
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • @DanCooper

    nochmal Danke :)

    eine letzte Frage sei noch erlaubt, zumindest für heute :)

    Wenn ich einen neuen Film scrape möchte ich nur Trailer haben wenn er diese auch runterladen kann. Wenn das nicht funktioniert, möchte ich nicht das ein youtube link unter Trailer in der nfo steht. Ich habe meiner Meinung nach schon alle Haken deaktiviert. Es steht trotzdem immer wieder eine url drin.

    Danke und Gruß
  • Eispirat schrieb:

    @DanCooper

    nochmal Danke :)

    eine letzte Frage sei noch erlaubt, zumindest für heute :)

    Wenn ich einen neuen Film scrape möchte ich nur Trailer haben wenn er diese auch runterladen kann. Wenn das nicht funktioniert, möchte ich nicht das ein youtube link unter Trailer in der nfo steht. Ich habe meiner Meinung nach schon alle Haken deaktiviert. Es steht trotzdem immer wieder eine url drin.

    Danke und Gruß
    Unter Einstellungen => Filme => Scraper-Daten => Trailer (global) deaktivieren und Leere deaktivierte Felder aktivieren, damit beim (Re-)Scrapen vorhandene Links auch entfernt werden.
    Der Trailerdownload (lokal) kann unter Einstellungen => Scraper-Trailer eingestellt werden (ebenfalls muss unter Dateien & Quellen der Hacken bei Trailer gesetzt werden).
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • andy-man schrieb:

    Hallo,

    mir ist da auch gerade eine Kleinigkeit aufgefallen wo ich nicht sicher bin ob es so gewollt ist. Wenn im KI "Playcount lesen von" angehakt ist lassen sich die gesehen Markierungen in Ember nicht ändern, der Status springt dann immer gleich zum vorhanden zurück.
    Ich würde jetzt nicht sagen "gewollt", aber ist zur Zeit definitiv so. Ich muss noch ein Force-Overwrite für diese Fälle einbauen, muss mir aber erst noch ein paar Gedanken dazu machen.
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • waffi schrieb:

    Also das mit der SQL Export müsste ich mir mal anschauen, der Rest klingt nicht schwer:) aber wenn du das ja eh schon so gemacht hast kannst du es testen? Ich lad dir sonst mal die neueste komblimierte Version hoch
    @waffi JA bitte schick mir mal die neuste Version.

    Eispirat schrieb:

    Hallo zusammen, nachdem die ersten kleineren Probleme behoben sind, kommen jetzt die für mich größeren Fragen :)

    Folgende Situation:

    Openelec mit Kodi, bisher habe ich immer mit Media Elch die nfo und das Artwork gescrapt. Danach wurden die CDArts usw mit Artwork Download Manager in die Kodi DB gebracht. Da Media Elch immer mal wieder Probleme macht, würd eich jetzt Ember nutzen wollen.

    Da Ember mir beim einlesen nicht meine bereits vorhanden CDArts und Logos einliest aufgrund der falschen Namen (disc statt discart usw.) habe ich mir folgendes überlegt. Vielleicht könnt ihr einmal drüber gucken ob das so ok ist.

    Ich lösche auf meinem NAS alle alten CDArtworks. Dann exportiere ich nfo und Artwork aus Kodi per video Export. In Ember habe ich das kodi Interface aktiviert, der Zugriff funktioniert auch. Jetzt würde ich alle Filme von meinem Nas einlesen und dann per Tools - Kodi Interface - Datenbank aktualisieren, die neuen Artworks direkt in die Kodi DB schreiben lassen. Kann man das so machen ?

    Wie bekomme ich in Ember alle Filme als grün angezeigt , sodass ich beim nächsten aktualiseren nur die neuen Filme mit rot sehe ?

    Danke und Gruß
    Lies mal das Tutorial durch da wird dir im 2. Post erklärt, wie du die Arts mit den falschen Namen berichtigst.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • Nepomuk schrieb:

    @grieche47 hast du das Poster von Herr der Ringe auch mit einem Rechtsklick und Select Image ausgewählt?

    DanCooper schrieb:

    die Bilder müssen neu mit rechter Maustaste ausgewählt werden. Grund dafür ist, dass nicht bei jedem Doppelklick auf ein Bild (für die Vorschau in voller Auflösung) gleich das Bild ausgewählt wird. Ist am Anfang etwas gewöhnungsbedürftig, geht dann aber irgendwann auch automatisch
    Hey, danke Euch beiden für das rasche feedback.
    Ja, das habe ich natürlich nicht so gemacht.
    Klappt jetzt einwandfrei

    DanCooper schrieb:

    Trailervorschau = scheisse... Wir arbeiten an einer besseren Lösung mit VLC, wird dann irgendwann auch endlich mal zuverlässig gehen.
    Okay, danke für das feedback.





    Was mir gestern noch aufgefallen ist.

    Habe bei einigen Filmen die Cover manuell geändert.
    Nach ca. 10 Filmen ist das Programm abgestürzt "Speicher voll" (oder so in der Art).
    Client1: ML03B|GA-A75M-UD2H|MSI R5450|A4-3400 2x2.70GHz|8GB DDR3-1600|LE 7.0.2
    Client2:RPI2|LE 7.0.2
    NAS 1: DS211J
    NAS 2: Define Nano S|ASRock H110M|G4560 2x 3.50GHz|8GB|OMV 3.x|Emby Server 3.x
    SKIN: Estuary.Refresh
    Display: Samsung 55 Zoll
    PVR: VU Duo 2|3TB
    FB: Harmony 600
    Amp: OnkyoTX626
    Center VOKAL
    Front: ZENZOR5
    Surround: ZENZOR1
  • grieche47 schrieb:

    Hey, danke Euch beiden für das rasche feedback.
    Kein Problem.

    grieche47 schrieb:

    Was mir gestern noch aufgefallen ist.

    Habe bei einigen Filmen die Cover manuell geändert.
    Nach ca. 10 Filmen ist das Programm abgestürzt "Speicher voll" (oder so in der Art).
    Bitte beschreib mal genau was du gemacht hast und wie.
    Dann häng noch die Log-Datei hier mit an.

    Nur so kann @DanCooper mehr sehen.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424
  • ich werde mal schauen ob es sich reproduzieren lässt
    Client1: ML03B|GA-A75M-UD2H|MSI R5450|A4-3400 2x2.70GHz|8GB DDR3-1600|LE 7.0.2
    Client2:RPI2|LE 7.0.2
    NAS 1: DS211J
    NAS 2: Define Nano S|ASRock H110M|G4560 2x 3.50GHz|8GB|OMV 3.x|Emby Server 3.x
    SKIN: Estuary.Refresh
    Display: Samsung 55 Zoll
    PVR: VU Duo 2|3TB
    FB: Harmony 600
    Amp: OnkyoTX626
    Center VOKAL
    Front: ZENZOR5
    Surround: ZENZOR1
  • Nepomuk schrieb:

    waffi schrieb:

    Ok alles klar, Backup hat man ja eigentlich durch Ember oder? Dort sind ja alle NFO's Bilder, Trailers etc gespeichert

    Also bei den Filmen hab ich keine Bedenken aber bei den Serien hab ich einbisschen Schiss aber ich probiere das morgen mal aus:)
    Wat nix verstehen - ich Schwabe.Vor was hast du Schiss?
    textures13.db und vom Ordner Thumbnails kannst du ja einfach umbenennen, dann hast du da eine Art Backup.
    Die Kodi-db kannst du doch auch einfach umbenennen, wenn du die Standart-db nutzt. Bei mySQL oder Maria-db nimmst du einfach das Heidi-SQL Programm und erstellst einen SQL-Export. phpmyadmin müsste doch auch gehen, hab aber damit keine Erfahrung.


    EDIT 18.02.2016:
    @waffi entschuldige das war mein Fehler gestern. [img]http://www.kodinerds.net/wcf/images/smilies/love.png[/img] Ich hatte es dir nicht ausführlich erklärt.
    Wenn du die MySQL Datenbank löscht, musst du einmal Kodi neu starten, damit Kodi die DB wieder anlegt. Kodi trägt dann in Tabelle path deine Sources ein. Denen musst du dann in Kodi den entsprechenden Scraper - NFO local zuweisen. Kodi frägt nach jeder Zuweisung, ob es die Bibleothek aktualisieren soll - hier sagst du jedesmal nein.
    Dann gehst du am besten her und beendest Kodi wieder und exportierst dir erstmal nur die Tabelle path.
    So kannst du zukünftig die db löschen, einmal Kodi für Neuanlage der db starten, beenden und die path.sql importieren und fertisch.

    Aah jetzt ist alles klar, ich hab jetzt einfach alles kurz neu gesynct mit Ember und es klappt ja wunderbar. Aber nächstes mal probiere ich das mit der path.sql aus. Danke :)

    Aktueller Stand 17.02. 18.30

    Viel Spass :D

    www22.zippyshare.com/v/jlbx7CUI/file.html
  • Ich möchte meinen ersten Post hier im Forum gerne mit einem großen Dankeschön starten.

    Schon länger lese ich hier mit und habe mit Hilfe dieses Forums einen lockeren Einstieg in die Kodi-Welt geschafft.
    Immer wenn Fragen auf kommen, muss ich nur kurz hier suchen und schon hab ich die Lösung gefunden - Darum habe ich wohl bis her auch keine eigenen Beiträge erstellen müssen :whistling:

    In besondere möchte ich mich bei Nepomuk und DanCooper bedanken:
    Schon das erstes Tutorial zu Ember hat mich begeistert und ich habe innerhalb weniger Stunden Ordnung in meine chaotische Sammlung bringen können.
    Das Tutorial zur neuen Alpha von Ember hat mich etwas länger beschäftigt, aber jetzt läuft alles (außer der Trailer-Download) rund.

    Danke auch an waffi für das bereitstellen der aktuellen Alpha-Version.

    Schön, dass es trotz der aktuellen Diskussion zum aufkommenden schlechten Ruf von Kodi durch vermeintlich habgierige und zwielichtige Händler weiterhin so engagierte User gibt :thumbup:
    Wohnzimmer: LibreELEC (Krypton) v8.0.2 @ Rspberry Pi3 FireTV 2.Gen. | Schlafzimmer: FireTV Stick 1.Gen | Medienquelle: Synology Diskstation DS212j 2x 2TB |
    Ordnung durch Ember 1.4.8.0 alpha thx to Nepomuk | Kodi v17.3 Krypton |
    [img]http://files.towade.me/images/instagram_button.png[/img]
  • Nepomuk schrieb:

    grieche47 schrieb:

    Hey, danke Euch beiden für das rasche feedback.
    Kein Problem.

    grieche47 schrieb:

    Was mir gestern noch aufgefallen ist.

    Habe bei einigen Filmen die Cover manuell geändert.
    Nach ca. 10 Filmen ist das Programm abgestürzt "Speicher voll" (oder so in der Art).
    Bitte beschreib mal genau was du gemacht hast und wie.Dann häng noch die Log-Datei hier mit an.

    Nur so kann @DanCooper mehr sehen.
    Ich weiss eigentlich woher der Fehler kommt, nur nicht warum er auftaucht.
    Das Problem ist halt, dass wir für die Anzeige der Bilder diese vom komprimierten JPEG Format in Bitmaps (unkomprimiert) umwandeln müssen. Wenn jetzt jemand sehr viele Extrathumbs und/oder Extrafanarts hat steigt der verwendete Speicher schnell mal in ungeahnte Höhen. Ein 4k Bild hat zum Beispiel als JPEG 8 MB, für die Anzeige als Bitmap wird aber bereits ca. 40 MB Speicher benötigt. Ok, das Beispiel ist jetzt extrem übertrieben, stellt aber genau das Problem dar. Neben dem Speicher, der Ember sowieso schon benötigt und all den anderen Bildern, die im Betrieb so angezeigt werden erreicht man sehr schnell das Speicherlimit von 4 GB bei 32bit, das sich alle 32bit Programme mehr oder weniger auch noch teilen müssen.

    Frage ist halt, warum teilweise der Speicher nicht mehr freigegeben wird. @mam hat das auf "schleifen" und dergleichen geschoben, doch das stimmt einfach nicht. Auch der Garbage Collector funktioniert ohne Probleme und gibt den Speicher wieder frei, das sieht man im Debug Modus sehr schön. Wir hatten mal ein Memory Leak in einem Modul, indem das ganze Objekt als Kopie für immer verloren gegangen ist, der Bug ist aber behoben und mir ist kein weiterer "Lost-in-Space" Bug bekannt. Das Problem ist bei mir übrigens auch nur beim manuellen Rescrapen aufgetaucht, denn beim automatischen Scrapen werden ja keine Bitmaps angezeigt und somit hällt sich der Speicherverbrauch auch sehr in Grenzen.

    Ich muss mir das Problem nochmals ansehen.
    Ember latest Version - Ember | SPENDEN für Ember | Patreon
  • @DanCooper und @Cocotus

    Nepomuk schrieb:

    Cocotus schrieb:

    Grandios, tolle Arbeit @Nepomuk
    Vielleicht lerne ich sogar daraus noch das ein oder andere
    ;)
    @Cocotus, danke für die Blumen. :love: Was willste denn noch lernen, du hast doch Ember mit entwickelt - super Arbeit von Euch.

    Übrigens, beim Playcount Synch klemmts noch. Hatte es zwar gemeldet, scheint aber in der Flut unter gegangen zu sein. Schau mal da deinen Code an.

    Cocotus schrieb:

    Meinst du das Syncen der Playcounts im trakt.tv Manager? Werd mal in der Konversation schauen, habe ich wohl tatsächlich verdrängt/übersehen :D

    Ich hatte letzte oder vorletzte Woche @Cocotus den Hinweis gegeben, dass im trakt.tv Manager noch was nicht stimmt. Ist dir was bekannt? Sind da Änderungen in den Code schon mit eingeflossen, denn ich finde auf Github nichts. In der waffi-Version vom 17.02. ist es noch nicht gefixt.

    Bei dem Test, hab ich noch einen Bug gefunden.
    Ich hatte einen ISO Film in ein MKV "gewandelt", diese MKV in Ember gescrapt, dann aber auf Dateiebene die MKV gelöscht und die ISO wieder in den Filmordner kopiert. Also Ember hatte noch die MKV drinne, vorhanden war aber eine ISO. Dann hatte ich den trakt.tv Manager gestartet, Ember teilte mir dann per MSG-Box mit, dass die MKV-Datei fehlen würde. Nach dem Wegklicken der MSG-Box lief die Sanduhr los und in der Statuszeile (Anwendung nicht mehr erreichbar) oder so ähnlich. Musste Ember dann schliesslich killen.

    DanCooper schrieb:

    Nepomuk schrieb:

    DanCooper schrieb:

    @Nepomuk phu, du legst langsam auch ein Tempo vor mit Antworten :thumbsup:

    Ich hab übrigens gerade noch die KI Task Count Anzeige soweit geändert, dass der Count beim Hinzufügen eines neuen Tasks erhöht wird und nicht erst nachdem der nächste gestartet worden ist.
    Sorry, aber das liegt an meinem MUA, wenn da eine neue email kommt, steht die bei mir im Laufband. Also abarbeiten und gut ist es.Bin ich dir zu schnell? Du südlich des schwäbischen Meers - ich etwas nördlich davon. :thumbup:
    Super - wieder ein Punkt gefixt. :thumbsup:
    Haste jetzt mal über einen zentralen Ki Button und über die Ki-Ampel nachgedacht Dies noch einzubauen?
    MUA? Manipulation unter Anästhesie? ;)
    Die Ampel-Geschichte ist mir, zumindest momentan, zu viel Arbeit und zu komplex. Vielleicht kommt da später mal noch was.
    Mit zentralem KI Button meinste Funktionen wie "Sync alles" oder "hole Playcount von allem"? Das wird sicher noch kommen in nächster Zeit, sobald das ganze KI stabil läuft (was es ja eigentlich tut, zumindest beim mir). Ich werde da aber warscheinlich mal noch mit @waffi etwas üben, denn bei ihm klappt es ja noch nicht so rund.
    Das versteh ich, die Ampel-Geschichte wäre auch noch für die Gui was Optisches.
    Mach mir aber trotzdem Gedanken, wie es sich denn am Leichtesten mit der Funktion "Synch alles" am Sinnvollsten lösen lässt. Denn wenn der Button wirklich einen Synch über ALLES auslöst, dann wird das bei größeren Beständen Stunden dauern.
    Gut als Alternative gibts dann auch noch Live-Synch, hier muss aber dann immer das eingetragene Client-Kodi gleichzeitig laufen. Übrigens, ich hab diese Funktion noch nicht getestet - hat ein anderer Tester diesen Punkt durch??

    Was soll der User machen, wenn es keinen solchen Button gibt und er auch nicht Live-Synch aktiv hat?
    Entweder er macht bei jedem Film etc. gleich einen Synch per Rechtsklick oder er markiert alle Filme und macht einen manuellen Synch alles regelmässig.
    Echt problematisch wirds bei den command-line User, da geht mit Ki gar nichts.

    Ich kann den Code zwar lesen - verstehe aber nichts oder nicht viel.
    Jetzt geh ich mal davon aus, dass egal ob Film, Set oder Serie ein Scrapvorgang - auch hier egal ob manuell, automatisch oder sonst wie, es immer in einer immer gleichen Prozedur endet, nämlich da wo der Speichervorgang programmiert ist. Lieg ich da richtig? Da könnte man doch ansetzen?
    Beim Speichern Variable == LEER --> bleibt leer, Variable == 0 --> ändere Wert auf 1.

    Die Dateipfade sind in der Ember.db in den Tabellen - für Filme in 'movie', Sets in 'sets', die Serien in 'tvshow' und die Edisoden in 'files' gespeichert, und in genau diesen Tabellen landet Jeder gleich beim "Datenbank aktualisieren".
    Wenn diese Tabellen jetzt jede eine neue Variable namens z.B. 'synch' bekommen, dann steigt die Version von MyVideo33.emm auf MyVideo34.emm ist klar, aber egal da wir eh im alpha noch sind und nicht beta.
    So jetzt gibt es bei dieser Variablen den Zustand LEER und dann übers Programm den Wert 0 und 1
    LEER --> in Ember drinne, aber noch kein Ki synch gemacht, keine Kodi-ID bekannt.
    0 --> Synch gemacht, Kodi == Ember, Kodi-ID ist bekannt.
    1 --> Synch muss erneut gemacht werden, da Kodi <> Ember, Kodi-ID ist bekannt.

    So jetzt kann es einen zentralen Button geben, so wie 'Datenbank aktualisieren' oder bei Tools/KodiInterface, der dann beim Auslösen, alle 4 Tabellen durchgeht und wenn synch == LEER oder synch == 1 ist, Diese synchronisiert und die Variable synch dann auf 0 setzt. Alternativ wenn du es feiner haben willst, so aufteilen wie Tools/...neu laden.

    Was meinst du @DanCooper? So wie ich dich hier kenne, bekommst du das locker hin. :thumbsup: :thumbsup:

    P.S.
    Ich lösch jetzt mal Thumbnails, texture13 und meine Kodi.db und fahr einen kompletten Synch durch.
    @waffi hat ja schon berichtet, dass es bei ihm, ohne Probleme, durch gelaufen ist. @waffi du hast die Serien nur mit "Synch full" durchlaufen lassen oder wie??
    @waffi ist ja mehr der Serienjunkie - ich der Filmjunkie, dann sehen wir gleich, ob es noch Probleme beim Synch gibt.
    Kodi-Hardware anzeigen
    HTPC: Kodi 17 auf Windows 10 Pro x64, Intel DQ77KB, Intel Core i3-3225, Intel Graphic integrated, 8Gb Ram, 128GB Samsung 830, Streacom FC8evo
    TV: Samsung UE65F9090 mit SEK-3500, AVR: Pioneer SC-LX57, Boxen: Nubert NuLine 284 Set 7.1
    Server: OmniOSce r151024 mit Napp-it pro, SM-Board X8SI6-F, Intel Xeon L3426, 16GB ECC RAM, LSI 9211-8i & 9201-16i, nur Hitachi/HGST 7k4000, XCase-Gehäuse RM424