[Release] Amazon Prime Instant Video

  • Manul schrieb:

    @Jah-B: Das erste, was mir auffällt, sind diverse Fehler bzgl. Namensauflösung am Ende des crashlogs. Laufen denn andere Plugins, die eine Internetverbindung benötigen (Youtube z.B.)?
    Jetzt geht's! GEIL!

    habe vergessen nach der Neuinstallation auf Input-Stream zu wechseln und die Settings anzupassen. Nach ein paar Neustarts und erneuter Eingabe der Login-Daten geht's endlich wieder.

    Tausend Dank an die Entwickler und ihre Helfer, spitze!

    Beitrag von Gismo112 ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • DonaldDuck schrieb:

    huhuKurze Frage: meinst du dieses update?, oder nur den reinen Grafiktreiber?
    Falls ja spiele ich das mal lieber nicht ein :D (habe einen NUC6CAY)
    Weiß jemand wie man die aktuelle HDMI Firmwareversion ermitteln kann? (am liebsten unter linux)
    Dieses HDMI-Firmware-Update hatte ich ebenfalls eingespielt. Allerdings schon im November oder Dezember. Da gab es nach dem Update noch keine Probleme mit Kodi.
    Meines Erachtens gabs die Probleme erst mit Update des Intel-Grafik-Treibers vom 05.01.18

    Wenn ich micht recht entsinne wurde die aktuelle Firmwareversion eingeblendet wenn das oben verlinkte Firmwareupdate gestartet wurde. Man konnte an der Stelle aber noch abbrechen...
  • psychofaktory schrieb:

    DonaldDuck schrieb:

    huhuKurze Frage: meinst du dieses update?, oder nur den reinen Grafiktreiber?
    Falls ja spiele ich das mal lieber nicht ein :D (habe einen NUC6CAY)
    Weiß jemand wie man die aktuelle HDMI Firmwareversion ermitteln kann? (am liebsten unter linux)
    Dieses HDMI-Firmware-Update hatte ich ebenfalls eingespielt. Allerdings schon im November oder Dezember. Da gab es nach dem Update noch keine Probleme mit Kodi.Meines Erachtens gabs die Probleme erst mit Update des Intel-Grafik-Treibers vom 05.01.18

    Wenn ich micht recht entsinne wurde die aktuelle Firmwareversion eingeblendet wenn das oben verlinkte Firmwareupdate gestartet wurde. Man konnte an der Stelle aber noch abbrechen...
    Alles klar :)
    Danke
  • Sagt mal, ich benutze eine Amlogic S905X Box mit der Leia alpha von adamg.

    Ich kann nie einen Film bei Amazon von Anfang bis Ende gucken, ohne dass folgendes passiert:

    Entweder: Bild friert ein, Ton friert ein, nach 5 Sekunden wird für ca. 5 Sekunden "vorgespult" zu dem Zeitpunkt, an dem der Film ohne das Einfrieren wäre und alles geht normal weiter. Ich habe eine stabile 100mbit Leitung und gucke in 720p, normales Puffern kann das doch nicht sein?

    Oder: Bild friert ein, Ton friert ein, es passiert dasselbe wie oben, aber der Ton bleibt weg. Man muss den Stream neustarten.

    Oder: Es wird "normal" gepuffert: Alles steht und geht normal weiter nach ein paar Sekunden.

    Frage: Liegt es am Amazon Plugin, liegt es am inputstream plugin oder liegt es daran, dass "leia" einfach noch zu instabil ist?

    PS: Gibt es inzwischen DIE Einstellung für inputstream adaptive? Ich habe nichts daran geändet. Was ist mit HDCP status oder stream selection?

    PPS: Ist das inputstream adaptive plugin aus dem Repo immer noch veraltet oder kann man das inzwischen aus dem repo updaten?

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von koboltzz ()

  • koboltzz schrieb:

    Frage: Liegt es am Amazon Plugin, liegt es am inputstream plugin oder liegt es daran, dass "leia" einfach noch zu instabil ist?
    Denke mal es liegt an der Leia Version die man nutzt.

    Hintergrund:

    Zum Beispiel Windows 10 Pro 64 Bit - Kodi 18 Alpha Nightly 64 Bit

    Problem nach dieser Version

    KodiSetup-20180125-7379a754-Master-x64.exe

    läuft es bei unser einer nicht mehr rund mit Amazon VOD wenn man einen Film startet...sei es aus der Watchlist oder unter einen anderen Menüpunkt...das man den Film stellenweise 2x beziehungsweise mehrfach starten muß...das ganze größtenteils wenn man ab einen gewissen Punkt von wo man diesen Film weiter schauen möchte...weil man schon ein Teil davon gesehen hatte...damit dieser dann richtig läuft...ansonsten Standbild welches langsam das nächste Standbild nach sich zieht...Ton läuft ansich normal weiter...oder völlig asynchron mit den Bild.

    Selbst nach der Behebung dieses Bug...muß da noch etwas sein...welches noch behoben werden sollte...das es wieder richtig rund läuft mit der Amazon VOD Version 0.5.2

    forum.kodi.tv/showthread.php?tid=327833

    Auch mit der Nvidia Shield TV Android 7 gibt es in der Richtung noch Probleme.
    Das Glück deines Lebens hängt ab von der Beschaffenheit deiner Gedanken.
  • Hoffe ihr könnt das nachprüfen bei Euch und vielleicht ein Bug Thread öffnen im forum.kodi.tv ...das es behoben werden könnte in den nächsten Nighlies... mein englisch ist einfach dafür zu übelst...das man es so wie von mir im Beitrag: 5187 geschildert rüber bringen könnte.
    Das Glück deines Lebens hängt ab von der Beschaffenheit deiner Gedanken.
  • Ich habe jetzt mal folgenden Test gemacht:

    Zwei identische Amlogic S905X Boxen: Beelink Mini MXIII II

    Erste Box:
    Libreelec seit 1/1/2 Jahren darauf installiert, begonnen mit Version 8.0 (Kodi 17) von "kszaq" und nach und nach immer nur geupdatet bis jetzt aktuell 8.90.4 (Kodi 18) von "adamg".
    Alle addons auf dem neuesten Stand
    Ergebnis: Amazon VOD funktioniert akzeptabel (bis auf s.o.)

    Zweite Box:
    Gerade eben ganz frische Libreelec Installation direkt mit der neuesten Version 8.90.4
    Alle addons auf dem neuesten Stand, gerade Widevine libs mittels inputstream adaptive helper installiert.
    Ergebnis: Amazon VOD liefert bei dem selben Film nur Standbilder und puffert alle 5 Sekunden das nächste Standbild

    Was ist da los? Eine jungfräuliche Kodi Version funktioniert soviel schlechter als eine, die schon so einiges auf dem Buckel hat?

    Edit: Man brauch danach anscheinend zwei reboots, mit jeweils einem Abspielversuch, bis es flüssig läuft.`

    Edit2: Wieder zurück zum Standbild Puffern...nachdem ich das Youtube Addon installiert habe. Vermutung ist, dass Youtube irgendwelche Abhängigkeiten von Amazon mit alten/inkompatiblen Versionen überschreibt. Wie wahrscheinlich ist das? Problem war ja vor den reboots schon mal vorhanden.

    Edit3: So langsam dreh ich am Rad. Jetzt sieht es so aus, dass je nach Film die Einstellung "DRM Check" aktiviert/deaktiviert ODER "Ungültige Tonspur automa. wechseln" aktiviert/deaktiviert werden muss, damit der Film überhaupt flüssig anläuft.

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von koboltzz ()

  • Ich muss mich jetzt auch mal zu Wort melden.
    Zwar lief vor zwei wochen noch Amazon (mit neuer libwidevine.so) doch der "helper" meckert jetzt wieder.
    Ich habe das script von @Gismo112 verwendet um an die neue lib zu kommen (Skript angepasst, da auf internem Speicher weniger wie 2GB verfügbar sind)
    Kann man irgendwie verhindern dass der get-libwidevine-helper anspringt?
    Odroid C2 (S905) mit 8GB eMMC und LibreELEC (Raybuntu´s Community-Builds) / Samsung 42"FullHD / Logitech Z-5500
  • andy5macht schrieb:

    Ich muss mich jetzt auch mal zu Wort melden.
    Zwar lief vor zwei wochen noch Amazon (mit neuer libwidevine.so) doch der "helper" meckert jetzt wieder.
    Ich habe das script von @Gismo112 verwendet um an die neue lib zu kommen (Skript angepasst, da auf internem Speicher weniger wie 2GB verfügbar sind)
    Kann man irgendwie verhindern dass der get-libwidevine-helper anspringt?
    Hier mal eine Info dazu. Habe es aber selber nicht ausprobiert kodinerds.net/index.php/Thread…?postID=444063#post444063:

    vdr.tuxnet schrieb:

    Rambo2000 schrieb:

    wie prüft denn der Helper, ob ein Update notwendig ist? Muss ja irgendwo ein check sein, der schaut ob die Dateien da sind. Hat man ein lauffähiges System, dann müsste es doch reichen die Dateien an die benötigte Stelle zu kopieren. Oder ist das zu einfach gedacht?.
    Der macht eine Abfrage bei https://dl.google.com/widevine-cdm/current.txt und und vergleicht mit /userdata/addon_data/script.module.inputstreamhelper/cdm/manifest.json
    Das ist nicht zu einfach gedacht, kannst du in einer Minute selbst erledigen.


    Kopiere einfach den Inhalt, ohne die libwidevine, aus $kodihome/userdata/addon_data/script.module.inputstreamhelper/cdm nach $kodihome/cdm, dann löscht du $kodihome/userdata/addon_data/script.module.inputstreamhelper/cdm und verlinkst $kodihome/cdm nach $kodihome/userdata/addon_data/script.module.inputstreamhelper/cdm, fertig. Die eventuell nötigen Updates landen dann immer automatisch in $kodihome/cdm.
  • bei mir ist der Pfad aber leer $kodihome/userdata/addon_data/script.module.inputstreamhelper/cdm
    ich hätte jetzt gern einfach die "manifest.json" angelegt und ihn quasi zur erfolgreichen abfrage gezwungen. was steht da denn drin?
    kann mir die jemand bitte zur verfügung stellen?!
    Odroid C2 (S905) mit 8GB eMMC und LibreELEC (Raybuntu´s Community-Builds) / Samsung 42"FullHD / Logitech Z-5500
  • andy5macht schrieb:

    was steht da denn drin?
    kann mir die jemand bitte zur verfügung stellen?!
    Das bei meinem Intel NUC mit Milhouse Kodi 18:

    Quellcode

    1. {
    2. "arch": "x64",
    3. "description": "Widevine Content Decryption Module",
    4. "manifest_version": 2,
    5. "name": "WidevineCdm",
    6. "offline_enabled": "false",
    7. "os": "linux",
    8. "version": "1.4.8.1008",
    9. "x-cdm-codecs": "vp8,vp9.0,avc1",
    10. "x-cdm-host-versions": "8",
    11. "x-cdm-interface-versions": "8",
    12. "x-cdm-module-versions": "4"
    13. }
    Alles anzeigen
  • Neu

    Ronny schrieb:

    Mit dieser Kodi 18 Nightly Version läuft auch die Nvidia Shield TV mit Amazon VOD Version 0.5.2 bei unser einer ohne Probleme.

    kodi-20180125-7379a754-Master-arm64-v8a.apk
    kann ich hier bestätigen. Build vom 18.02
    Win10-64bit + Kodi 17.4 + DVB Viewer Media Server Libreelec 8.2 Cvh DVB Edition mit TVHeadend 4.2 SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM,,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 perSMB als Aufnahmefreigabe. HDMI HTPC -> Denon AVR-4300H -> LG 65B6D
    Client Nvidia Shield mit Kodi 17.6 per SMB auf NAS DVBViewer Addon für LiveTV
    Client Rasp3 mit Libreelec per SMB auf NAS + DVBViewer Addon für LiveTV
  • Neu

    Hallo @Sandmann,

    ich bin begeisterter Nutzer deines Addons und soweit funktioniert auch alles. Leider klappt das automatische Umschalten der ungültigen Tonspur bei mir nicht.

    Ich habe zwei Rpi3 und einen Rpi2 im Einstatz. Der debug log stammt vom Rpi2. Das Verhalten ist aber auf allen Rpi's das Gleiche.
    Ich nutze OSMC mit der aktuellen Nightly von heute.
    Dein Addon, die widevine library und auch die Firmware sind auf dem neusten Stand.

    Ich kann grundsätzlich alle Filme oder Serien abspielen. Ich muss nur von Hand die richtige Tonspur einstellen. Was natürlich etwas lästig ist.

    Im debug log habe ich mit "Kevin can wait" Staffel 2 Episode 13 getestet. Wenn ich den Audiostream von Hand ändere läuft es (habe ich beim Erstellen des log nicht getan). Wenn ich die selbe Episode auf meinem Windows 10 PC starte klappt das Umschalten des ungültigen Streams ohne Probleme und die Episode startet ohne mein eingreifen.

    Wenn der 3. Audiostream gültig ist startet der Film oder die Episode problemlos. Falls nicht bleibt das Bild schwarz bis ich die Tonspur wechsel.

    Vielleicht kann mir jemand einen Tip geben woran es liegen könnte. Ich bin etwas ratlos.

    Gruß hedeon
    Dateien
    • kodi.log

      (378,05 kB, 2 mal heruntergeladen, zuletzt: )
  • Neu

    steelwarrior schrieb:

    Hallo zusammen,

    kann von euch jemand die letzten zwei Folgen der aktuellen 3. Staffel von Life in Pieces abspielen? Beim mir bleiben da auf meinen beiden RPi3 gleich nach dem Start das Bild hängen. Die ersten Folgen funktionieren. Hat jemand das gleiche Problem?
    Hallo steelwarrior,
    ich habe mal probiert die beiden Folgen zu schauen.
    Es ist das selbe Ptoblem wie ich einen Post vorher beschrieben habe. Die ungültige Tonspur wird nicht automatisch gewechselt.
    Wenn ich nach dem starten der Folge von Hand auf Tonspur 11 wechsel laufen die beiden Folgen.

    Gruß hedeon