Rom Collection Browser - XBMC Spiele Frontend

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Habt ihr ne Idee , habe mir eine kleine SNES Collection angelegt. Erstmal ne kleine (6-8) spiele zum testen. Er hat auch alle erkannt und die covers etc runtergeladen. nur zeigt er mir nicht alle Cover an , sondern nur von 3 spielen ca. Das lustige ist, beim nächsten mal zeigt er andere 3 Cover an. Also von den spielen wo es vorhin schwarz war. Hat da jemand ne Idee ?
  • aragon6377 schrieb:


    Habt ihr ne Idee , habe mir eine kleine SNES Collection angelegt. Erstmal ne kleine (6- spiele zum testen. Er hat auch alle erkannt und die covers etc runtergeladen. nur zeigt er mir nicht alle Cover an , sondern nur von 3 spielen ca. Das lustige ist, beim nächsten mal zeigt er andere 3 Cover an. Also von den spielen wo es vorhin schwarz war. Hat da jemand ne Idee ?

    Seltsam. Kannst Du mir mal einen Log zeigen nachdem Du RCB 2-3 mal gestartet hast und das Phänomen aufgetreten ist? Und ein paar Infos über Dein System geben (OS, XBMC Version, Skin, ...)?

    jinx schrieb:


    Ok ich habe meine Fehler nun erkannt
    Anstelle von
    smb://server/roms/*.nes
    muss ich einfach
    \\server\roms\*.nes
    eingeben.

    Ja, das ist auch der vorgeschlagene Workaround. Alternativ könntest Du noch Netz-Laufwerke oder Links zu Deinen SMB-Shares anlegen und diese dann in XBMC verwenden. Dann bräuchtest Du nicht die config.xml manuell anpassen.
  • Hi

    Ok den fehler mit den SNES spielen konnte ich beheben (war meine Dummheit). Ich bin jetzt aber gerade noch dran Wii Games einzubinden und scheitere kläglich daran.
    Per Konsole lässt sich das Spiel ohne probleme starten aber nicht aus XBMC.
    Ich bekomme immer das hier

    Quellcode

    1. 17:23:32 T:2719742784 NOTICE: RCB_INFO: Begin launchEmu
    2. 17:23:32 T:2719742784 NOTICE: RCB_INFO: launching game with id: 13
    3. 17:23:32 T:2719742784 NOTICE: RCB_INFO: Begin launcher.launchEmu
    4. 17:23:32 T:2719742784 NOTICE: RCB_INFO: files for current game: [(u'/media/freenas/Share/Games/WII/Monster_Trucks_(1344620640)/Monster_Trucks.iso',)]
    5. 17:23:32 T:2719742784 NOTICE: RCB_INFO: launcher.buildCmd
    6. 17:23:32 T:2719742784 NOTICE: RCB_INFO: emuCommandLine: /usr/games/dolphin-emu
    7. 17:23:32 T:2719742784 NOTICE: RCB_INFO: emuParams: "-e %ROM%"
    8. 17:23:32 T:2719742784 NOTICE: RCB_INFO: rom: /media/freenas/Share/Games/WII/Monster_Trucks_(1344620640)/Monster_Trucks.iso
    9. 17:23:32 T:2719742784 NOTICE: RCB_INFO: cmd: "/usr/games/dolphin-emu" "-b -e /media/freenas/Share/Games/WII/Monster_Trucks_(1344620640)/Monster_Trucks.iso"
    10. 17:23:32 T:2719742784 NOTICE: RCB_INFO: launchEmu on non-xbox
    11. 17:23:32 T:2719742784 NOTICE: RCB_INFO: screenMode: 1920x1080 @ 50.00 - Full Screen
    12. 17:23:32 T:2719742784 NOTICE: RCB_INFO: Toggle to Windowed mode
    13. 17:23:32 T:2987169600 ERROR: GLX: Same window as before, refreshing context
    14. 17:23:32 T:2719742784 NOTICE: RCB_INFO: launch emu
    15. 17:23:34 T:2987169600 NOTICE: DVDPlayer: Opening:
    16. 17:23:34 T:2987169600 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
    17. 17:23:34 T:2951486272 NOTICE: Creating InputStream
    18. 17:23:34 T:2951486272 ERROR: CDVDPlayer::OpenInputStream - error opening []
    19. 17:23:34 T:2951486272 NOTICE: CDVDPlayer::OnExit()
    20. 17:23:34 T:2951486272 NOTICE: CDVDPlayer::OnExit() deleting input stream
    21. 17:23:34 T:2987169600 ERROR: XBMC.PlayMedia could not play media:
    22. 17:23:34 T:2987169600 NOTICE: CDVDPlayer::CloseFile()
    23. 17:23:34 T:2987169600 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
    24. 17:23:34 T:2987169600 NOTICE: DVDPlayer: waiting for threads to exit
    25. 17:23:34 T:2987169600 NOTICE: DVDPlayer: finished waiting
    Alles anzeigen

    Ne Idee dazu

    Quellcode

    1. <RomCollection id="2" name="WII">
    2. <emulatorCmd>/usr/games/dolphin-emu</emulatorCmd>
    3. <emulatorParams>"-b -e %ROM%"</emulatorParams>
    4. <romPath>/media/freenas/Share/Games/WII/*.iso</romPath>
    5. <saveStatePath />
    6. <saveStateParams />
    7. <mediaPath type="boxfront">/media/freenas/Share/Games/WII/Artwork/boxfront/%GAME%.smc</mediaPath>
    8. <mediaPath type="boxback">/media/freenas/Share/Games/WII/Artwork/boxback/%GAME%.*</mediaPath>
    9. <mediaPath type="cartridge">/media/freenas/Share/Games/WII/Artwork/cartridge/%GAME%.*</mediaPath>
    10. <mediaPath type="screenshot">/media/freenas/Share/Games/WII/Artwork/screenshot/%GAME%.*</mediaPath>
    11. <mediaPath type="fanart">/media/freenas/Share/Games/WII/Artwork/fanart/%GAME%.*</mediaPath>
    12. <useEmuSolo>False</useEmuSolo>
    13. <ignoreOnScan>False</ignoreOnScan>
    14. <allowUpdate>True</allowUpdate>
    15. <autoplayVideoMain>True</autoplayVideoMain>
    16. <autoplayVideoInfo>True</autoplayVideoInfo>
    17. <useFoldernameAsGamename>True</useFoldernameAsGamename>
    18. <maxFolderDepth>99</maxFolderDepth>
    19. <doNotExtractZipFiles>True</doNotExtractZipFiles>
    20. <diskPrefix>_Disk</diskPrefix>
    21. <imagePlacingMain>gameinfobig</imagePlacingMain>
    22. <imagePlacingInfo>gameinfosmall</imagePlacingInfo>
    23. <scraper name="thegamesdb.net" replaceKeyString="" replaceValueString="" />
    24. <scraper name="archive.vg" replaceKeyString="" replaceValueString="" />
    25. <scraper name="mobygames.com" replaceKeyString="" replaceValueString="" />
    26. </RomCollection>
    Alles anzeigen


    Danke schon mal im voraus/useEmuSolo
    Gehäuse Silverstone LC17 in Silber, Foxconn "Brettl", Core2Duo 8300 ,2 GB Ram (800MHZ), Zotac GT240 passiv , 32GB SSD, TV @nywhere S2 + Technotrend C1501, freeVDR entwicklerversion (Ubuntu 14.04, vdr-2.1.1, softhddevice aus git, xbmc Kodi)

  • malte schrieb:

    Auf den ersten Blick würde ich vermuten, dass die emu Parameter falsch sind bzw. die Position des " in den Parametern. Richtig würde es für mich so aussehen:

    Quellcode

    1. <emulatorParams>-b -e "%ROM%"</emulatorParams>

    Danke das wars. :thumbsup:
    Manchmal sieht man den Wald vor lauter Bäumen nicht.

    Mfg
    Gehäuse Silverstone LC17 in Silber, Foxconn "Brettl", Core2Duo 8300 ,2 GB Ram (800MHZ), Zotac GT240 passiv , 32GB SSD, TV @nywhere S2 + Technotrend C1501, freeVDR entwicklerversion (Ubuntu 14.04, vdr-2.1.1, softhddevice aus git, xbmc Kodi)

  • Hallo, ich habe ein Problem mit der Anzeige von den Roms.
    Ich habe alle Einstellungen und Pfade für den Collector gesetzt, doch leider werden keine Daten angezeigt.
    Als primären Scraper habe ich mbygames ausgewählt. Auf meiner hdd werden auch die Artworks richtig abgelegt. Such die nfo Files werden erzeugt. Doch leider bleibt die Rom Collection in xbmc leer.

    Xbmc Version: xbmc 12 (Frodo) Alpha7
    RomCollectionBrowser Version: 1.0.1 und 1.0.5
    Platform: Windows 8
    Emulator:snes9x
    Roms: .zip ; .smc

    Der gleiche Fehler trat vor ca. einem Jahr sporadisch auch bei Windows 7 mit Xbmc 11 (eden) auf
  • Hey, wollte mich mal wieder melden.
    Hab mir noch ein paar Gedanken gemacht, um die Möglichkeit Scripte via RCB für die verschiedenen Emulatoren bereit zu stellen, das was wir halt besprochen hatten.
    Was hälst du von RetroArch?
    Ist ein interface, für viele bekannte Emulatorenkerne, angefangen von SNES über NES, GBA, GB/GBC, Genesis bis hin zu Cave Story und Doom. Es ist Multi Plattform und hat die Kompatibilität der verschiedenen Emulatoren, aber eine einheitliche Benutzerinterface und Steuerung. Was hältst du denn davon, wenn wir die Scripte darauf anpassen würden? Frodo nähert sich ja mit großen Schritten und deine neueste Version ist schließlich auch Frodo kompatibel?
    PS: Willst du mehr von, über oder mit mir lesen, besuche mich auf: Cause the Master Said so
  • Kannte ich bisher noch gar nicht. Werde ich mir mal ansehen.

    Grundsätzlich könnte ich mir so was schon vorstellen. Allerdings bin ich momentan sehr knapp bei Zeit und habe noch zwei dicke Brocken vor mir, die zwingend als nächstes erledigt werden müssen (Dokumentation auf den neuesten Stand bringen und Lokalisierung des Addons). Erst danach werde ich wieder Zeit haben, mich um neue Features zu kümmern. Aber ich habe seit neuestem auch endlich mal wieder einen weiteren Mitstreiter. Evtl. kann ich den auch darauf ansetzen. Danke schon mal für den Input!
  • Lokalisierung könntest du doch über Transifex laufen lassen, darüber läuft auch die XBMC Übersetzung und das meist so schnell, dass jedes Mal, wenn neue Strings dazu kommen und ich rein schaue, diese schon übersetzt sind. :D
    Das zweite, ist auch etwas, was sowohl User, als auch der Entwickler tun kann. Ich seh schon, du machst es dir, meiner Meinung anch teilweise unnötig schwerer. Denke, wenn du in die richtigen Rudnen fragst, findest bestimmt für solche Dinge sicherlich welche.
    Aber gut, du weißt glaub selbst besser, wie du es am besten löst. Aber wenn es um Input geht, kannst du dich zumindest auf immer mal neue Ideen von mir verlassen. ^^
    PS: Willst du mehr von, über oder mit mir lesen, besuche mich auf: Cause the Master Said so
  • Ja, die eigentliche Übersetzung werde ich später auch über Transiflex laufen lassen. Dafür muss das Addon aber auch vorbereitet sein. Aktuell sind sämtliche strings noch hart kodiert. Eigentlich ein Wunder, dass ich es damit überhaupt ins XBMC Repo geschafft habe :)

    Bei der Doku habe ich den Anspruch, dass zumindest die "stabilen" Versionen (also die im XBMC Repo) vollständig im Wiki dokumentiert sind. Da werde ich wohl auch nicht drum rumkommen, das größtenteils bis komplett selbst zu machen. Es gibt zwar immer mal wieder User, die mit kurzen Howtos o.ä. einspringen, aber den kompletten Überblick über alle Funktionen und deren Verwendung habe ich dann doch nur selbst. Dafür ist das ganze Projekt leider noch zu sehr "one man show".
  • Hy,

    hab das addon jetzt mal auf XBMC Frodo probiert, es funktioniert.
    Hab mein zsnes so eingestellt das auch auf Fullscreen spielen kann etc.

    Aber wie komme ich zurück zu XBMC?

    Konstellation:

    -Extra Mini PC
    -Angeschlossen an TV
    -Bedienung mit Harmony One

    Gibts ne Tastenkombination das des spiel beendet wird und dann XBMC wieder geöffnet?
    Kann zwar über die Harmony "ESC" senden, aber da tut sich nichts. Wenn ich über VNC "ESC" drübe geht das spiel zu.
    Gut, könnte ich notfalls über Ipad schnell drücken lassen, aber wieso öffnet sich dann nicht XBMC wieder?! Gibt es da ne möglichkeit oder muss ich was umstellen?

    grüße

    /edit Achja, BS: Windows7

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Rhuen ()

  • Der author hat eine neue Version veröffentlicht. forum.xbmc.org/showthread.php?…15&pid=1276229#pid1276229
    @Rhuen: Versuch mal diese Mod hier Advanced Launcher Mit Zurücktaste,spielstandsspeicherung,weniger Fenster(Programmstart),joypad / Keyfunktion damit kannste z.b beim Gamepad eine Taste anlegen womit er den emulator schliesst und du zum XBMC zurückkehrst der author des helferleins freutn sich im übrigen über Feedback zum Programm.
    Mein HTPC + Gaming PC:
    i5 3450| Asrock B75 Pro3 | 12GB DDR3 1600 | Gigabyte HD 7950 3GB | Asus Conar D1 @Edifier C2 |Samsung Basic 250GB & Seagate 500GB & 1500GB | LG BD+DVDRW | Xigmatek Midgard | Win 8 Pro 64 + XBMC Frodo
    HTPC2:
    Athlom II x4 630 | Asrock A770DE+ | 4GB DDR2 800 | Sapphiere HD 5570 | Seagate 500 GB | LG DVDRW| Xigmatek Asgard| Win 7 Home Premium 64 Bit + XBMC 12 Frodo RC 2
  • Hm das scheint laut Video so zu funktionieren wie ich das will...allerdings müsste man dafür auch nen anderen "emulator" nehmen, also es gibt eben net die schöne übersicht wie beim Rom Collection Browser.

    Hier müssten sich wohl mal beide Parteien zusammen tun :D

    Rom Collection Browser + das Gamepad Addon, da man bei nem SNES net alle tasten brauch, wäre das nice wenn man z.b. mit L2 + R2 oder eine von den testen den emulator schließt und wieder im xbmc landet.

    grüße.
  • Du kannst jetzt schon beides haben - vermute ich. Zum EInen sehe ich keinen Grund warum dieses Tool nicht auch mit RCB zusammenarbeiten sollte. Der Autor hat es halt nur für Advanced Launcher dokumentiert.

    Ohne es selbst ausprobiert zu haben, würde ich folgendes annehmen.

    -öffne den advanced Launcher
    -gebe bei Application (normalerweise Pfad zum Emulator oder Pc Programm) Joystartend.exe ein !
    -bei modify Arguments gibst Du den eigentlichen Emulator oder das PC Programm an inkl eventuellen Parametern !

    kann man ersetzen durch:

    - öffne Rom Collection Browser
    - öffne das Kontext Menu ("C" auf dem Keyboard oder "Menü" auf der Fernbedienung) und rufe "Rom Collection bearbeiten" auf
    - gebe bei Emulator (normalerweise Pfad zum Emulator oder Pc Programm) Joystartend.exe ein !
    - bei Emulator Parameter gibst Du den eigentlichen Emulator oder das PC Programm an inkl eventuellen Parametern !


    Andererseits kannst Du mit Advanced Launcher auch Bilder und Infos runterladen. Dann sieht es auch dort schöner aus.
  • Hy ich nochmal.

    Habe jetzt sowohl SNES als auch N64 eingebaut.
    SNES geht soweit, hab mal nen großes pack geladen, eingeführt aber nach 10 spielen war einfach schluß, war wohl zu viel? naja.

    Aber was is mit N64? Habe auch Project64 genommen, es startet auch das game, aber erst wenn ichs manuell nochmal lade.
    Führe ich das spiel aus über XBMC, startet Project64 dann kommt eine Fehlermeldung, dann lad ich das Rom nochmal über Project64 sleber, dann gehts.

    Eine Idee?

    grüße
  • Habe heute mal den Rom Collector getestet und finde ihm ansich viel besser als den Advanced Launcher, doch fand er bei manchen Games nicht die nötigen Informationen und kkonnte auch nicht Spiele einzeln suchen lassen, villeicht wäre auch eine anleitung praktisch auf deutsch.

    malte schrieb:

    Andererseits kannst Du mit Advanced Launcher auch Bilder und Infos runterladen. Dann sieht es auch dort schöner aus.
    Im Moment kann man es aber nicht da der Advanced Launcher einen miesen Bug hat, lege SNES an gebe die Roms, und Scrape bis py fehler kommt und die angelegte Datenbank ist hin. Sprich darf den Emulator neu einrichten in dem Launcher, und darf nicht scrapen sonst wieder datenverlust.
    Mein HTPC + Gaming PC:
    i5 3450| Asrock B75 Pro3 | 12GB DDR3 1600 | Gigabyte HD 7950 3GB | Asus Conar D1 @Edifier C2 |Samsung Basic 250GB & Seagate 500GB & 1500GB | LG BD+DVDRW | Xigmatek Midgard | Win 8 Pro 64 + XBMC Frodo
    HTPC2:
    Athlom II x4 630 | Asrock A770DE+ | 4GB DDR2 800 | Sapphiere HD 5570 | Seagate 500 GB | LG DVDRW| Xigmatek Asgard| Win 7 Home Premium 64 Bit + XBMC 12 Frodo RC 2