Rom Collection Browser - XBMC Spiele Frontend

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ne, eigentlich hast du dich verständlich ausgedrückt. Ich habs nur nicht richtig gelesen. Sorry.

    Aber die Antwort fällt trotzdem ähnlich aus. Ich rufe im addon nur einen Dialog auf, was dann darin passiert, ist Sache von kodi. Ich gucke aber noch mal nach, ob es da mit Leia neue Parameter oder ähnliches gibt. Oder ob das ein bekanntes Problem ist.
  • Hast du das artwork komplett von rcb holen lassen oder hattest du vorher schon welches? Ich hatte bei meiner Sammlung das Problem, dass artwork und Rom Namen nicht 100% identisch waren. In den aktuellen Versionen ist rcb dabei auch case sensitiv, auch unter Windows.
    Wenn du das artwork komplett von rcb hast holen lassen, nenn mir mal 1-2 Beispiele. Vielleicht kann ich das ja hier nachstellen.
  • malte schrieb:

    Ne, eigentlich hast du dich verständlich ausgedrückt. Ich habs nur nicht richtig gelesen. Sorry.

    Aber die Antwort fällt trotzdem ähnlich aus. Ich rufe im addon nur einen Dialog auf, was dann darin passiert, ist Sache von kodi. Ich gucke aber noch mal nach, ob es da mit Leia neue Parameter oder ähnliches gibt. Oder ob das ein bekanntes Problem ist.
    Scheint eher ein Bug im Leia Build zu sein, hab grad nen Retro Player Build installiert da funktionierts weiterhin tadellos.
    Mein Humor ist so schwarz, in Amerika würde er von der Polizei erschossen.
  • Ah,ok. Dann ist es wahrscheinlich genau andersherum. Standardmäßig zeigt rcb dort einen Screenshot an und nur als fallback das boxfront Bild. Es sei denn, du hast das in der config.xml überschrieben. Guck mal,ob grandia und die anderen spiele einen Screenshot haben. Vermutlich nicht und deshalb wird dort boxfront angezeigt.
    Anpassen könntest du das Verhalten in der config.xml. Wie hier beschrieben: github.com/maloep/romcollectio…/wiki/DynamicImagePlacing

    Edit: habe gerade deine Antwort gesehen.dann ist das hier wohl obsolet:)
  • als noch am wurschteln.... *-*
    Ähm hat von euch jemand der Ahnung hat.
    Eine shield , kodi aktuelle nightly
    Den rearmed psx emulator
    Und kann spiele spielen?

    Ich hab nen black screen und nur ton.
    Ich kenn mich in diesem github dingens nicht so aus.
    Hab da au diverses gelesen aber kann das nicht auf die shield reproduzieren :(.

    Wäre euch dankbar wenn ihr mir weiter helfen könnt.

    Klar könnte ich den android psx emu nehmen aber das nimmt mir den bastelspaß :)
    Will es nur schaffen, dass es läuft

    Cheers
  • Welchen Emu verwendest Du denn genau? Retroarch, RetroPlayer oder die Android App?

    Bei Android-Problemen kann ich Dir leider nicht helfen, aber bei Retroarch/RetroPlayer kann ich mich noch erinnern, dass Du für PSX zusätzlich noch Bios files brauchen könntest und dass es zumindest bei RetroPlayer nur ging, wenn man die cue-files geladen hat (statt direkt bin oder iso).
  • Hi,

    ich benutze RCB mit Retroarch und scheitere schon beim Scrapen. Erst mal zur Konfiguration: Ich hab zwei Konsolen (PSX und GBA) eingerichtet, bei der 3. Konsole hab ich versehentlich den falschen Core ausgewählt und konnte dann nicht mehr zurück. Hab auch nicht herausgefunden, wo ich das nachträglich noch ändern kann.
    Dann beim Scrapen selber war ich auch nicht viel erfolgreicher. Die PSX Roms hat er gar nicht gescrapped und bei den GBA Roms nur die Hälfte der Spiele und auch nicht mehr als den Titel in der nfo-Datei. Bilder hat er nur zwei heruntergeladen und die scheinen auch leer zu sein (O Byte).
    Irgendwas ist bei dem Scrapvorgang auch schief gelaufen, ich glaube es ging um die Bilder von der Box oder so. Er hat mir auch gesagt, dass er eine Log-Datei erstellt hat. Ist damit die normale Log Datei von Kodi gemeint oder hat RCB da eine eigene? Und falls ja, wo finde ich die dann?

    Ich benutze LibreElec, falls das irgendwie relevant ist.
    Meine Box: Amlogic S905X, 2GB Ram, LibreElec 8.2.3.1 / Kodi 17.6
  • Kupo91 schrieb:


    Ich hab zwei Konsolen (PSX und GBA) eingerichtet, bei der 3. Konsole hab ich versehentlich den falschen Core ausgewählt und konnte dann nicht mehr zurück. Hab auch nicht herausgefunden, wo ich das nachträglich noch ändern kann.
    Du kannst in RCB das Kontext-Menu aufrufen (mit "C" auf dem Keyboard oder "Menu" auf der Fernbedienung). Dort hast Du dann die Möglichkeit, Deine Konfiguration anzupassen oder erneut zu scrapen.

    Kupo91 schrieb:


    Dann beim Scrapen selber war ich auch nicht viel erfolgreicher. Die PSX Roms hat er gar nicht gescrapped und bei den GBA Roms nur die Hälfte der Spiele und auch nicht mehr als den Titel in der nfo-Datei. Bilder hat er nur zwei heruntergeladen und die scheinen auch leer zu sein (O Byte).
    Irgendwas ist bei dem Scrapvorgang auch schief gelaufen, ich glaube es ging um die Bilder von der Box oder so. Er hat mir auch gesagt, dass er eine Log-Datei erstellt hat. Ist damit die normale Log Datei von Kodi gemeint oder hat RCB da eine eigene? Und falls ja, wo finde ich die dann?
    Ja, es ist die Standard Kodi Log-Datei. Du musst aber erst in Kodi auf Debug-Log stellen, sonst werden Dir keine Infos von Addons angezeigt. Wenn Du die Log-Datei irgendwo hochladen kannst und hier verlinkst, kann ich Dir wahrscheinlich sagen, woran es hakt.
  • Hi, Danke für deine Antwort.

    Ich hatte leider noch eine veraltete Version installiert. Jetzt hat er schon etwas mehr gescrapped, aber lange noch nicht alles.

    Welche Log-Datei aus dem Archiv ist es, die Du brauchst? KODI.log?

    paste.ubuntu.com/p/2Twh39bhDH/

    Ich hoffe man kann dann überhaupt etwas aus der Datei entnehmen, bei mir kam diesmal nämlich keine Fehlermeldung o.ä. Es ist einfach nix passiert, als ich den Suchlauf gestartet hab, bzw. scheint er nix gefunden zu haben
    Meine Box: Amlogic S905X, 2GB Ram, LibreElec 8.2.3.1 / Kodi 17.6
  • Ich kann zumindest sehen, dass es einen Fehler gibt beim Versuch zu scrapen.

    Wenn ich den Log richtig lese, benutzt Du Aeon MQ7 als Skin? Das Problem ist vermutlich, dass Aeon MQ seine eigene RCB Oberfläche mitbringt. Die ist aber noch nicht kompatibel zu den aktuellsten Versionen von RCB.

    Du hättest jetzt drei Möglichkeiten:
    1. Gucke, ob es eventuell schon eine aktuellere Version von Aeon MQ7 gibt.
    2. Lösche oder benenne alle RCB Dateien im Skin-Verzeichnis um. Das sind alle Dateien, die mit "script-RCB" oder "script-Rom_Collection_Browser" beginnen im Verzeichnis "/storage/.kodi/addons/skin.aeonmq7/1080i" (da kommst Du glaube ich nur per ssh dran).
    3. Wechsle temporär den Skin auf z.B. Estuary und scrape die Spiele damit. Ich weiß aber nicht, ob es dann vielleicht an anderer Stelle Probleme geben könnte, wenn Du wieder zurück auf Aeon MQ wechselst.
  • Hi, Danke für deine Antwort :)

    der Skin könnte tatsächlich ein Faktor sein. Ich hab gestern Abend bereits mehrere Versuche gestartet und zwischendurch auch mit Estuary. Und ich glaube er hat da auch wirklich mehr importiert als vorher, aber die PSX Roms rührt er nicht an. Mein aktueller Stand ist: alle getesteten Spiele (GB, GBC, GBA, Easy RPG, PSX) mit Ausnahme der PSX Spiele wurden importiert.
    Von den importierten Spielen haben zwei ein Boxcover und eine Beschreibung, auch mit Jahr und Publisher etc. Die restlichen 6-10 Spiele haben nur einen Titel. Die Spiele gehören außerdem zu den Beliebtesten überhaupt, es ist also unwahrscheinlich dass sie nicht in der Datenbank stehen.
    Und wie gesagt PSX Spiele werdem überhaupt nicht erfasst. Ich hoffe es liegt nicht daran, dass ich sie alle in *.pbp konvertiert habe. Dass er die Spiele ID nicht auslesen kann oder sowas.

    Achja und die Spiele starten nicht aus RCB heraus. In Retroarch läuft alles, aber wenn ich ein Spiel in RCB starten möchte, zeigt er keine Reaktion. Hab ich allerdings nur unter Aeon MQ7 getestet. Ob das unter Estuary anders ist, müsste ich mal gucken
    Meine Box: Amlogic S905X, 2GB Ram, LibreElec 8.2.3.1 / Kodi 17.6
  • Dann müsstest Du mir von den anderen Problemen am besten auch mal einen Log zeigen. Ansonsten ist es schwierig, das zu bewerten.

    Typische Fehler beim Scrapen wären z.B.:
    • falsche Dateimaske (das könnte bei den PSX-Spielen der Fall sein)
    • Standardmäßig importiert RCB bereits vorhandene nfo-Dateien statt noch mal online zu gucken. Wenn Du also schon nfo-Dateien von früheren Importen hast, kann es sein, dass Du deswegen keine neuen Infos mehr bekommst. Das Verhalten kannst Du in den Addon Settings ändern.
    • Je nach Scraper können es auch noch andere, temporäre Probleme sein. Da hilft es manchmal, einen anderen Scraper auszuprobieren.
    Wie gesagt, lad am besten noch mal einen Log hoch, dann kann ich Dir genaueres sagen.

    Auf was für einem System hast Du denn libreelec laufen? Wenn es keine S905(X) box ist, dann nimm am besten das Gamestarter Addon. Mit dem Standard retroarch Addon hatte ich auch Probleme.
    Mit dem Gamestarter addon funktioniert es bei mir mit diesen Parametern:
    Emulator Cmd: /storage/.kodi/addons/game.retroarch/addon.sh
    Emulator Params: <Name des cores> "%rom%"
    Bei <Name des cores> musst Du den Namen ohne Dateiendung eintragen.

    Auf S905(X) Boxen ist es glaube ich generell noch schwierig, Retroarch ans Laufen zu kriegen. Da ich selbst keine habe, kann ich da aber nicht mehr zu sagen.
  • Ich hab jetzt nochmal alles an gescrapten Dateien, Config Files und Spieledatenbank rausgeworfen um ganz "clean" zu beginnen. Und alles unter Estuary. Hier ist die neue Log-Datei:

    paste.ubuntu.com/p/FKFx8rBrD9/

    Leider gleiches Ergebnis. PSX Roms werden nicht gescrapped, der Rest schon, allerdings nur zwei Spiele davon "richtig"

    In den Einstellungen hab ich alles default gelassen, auch beim Scraper ("Verwende konfigurierte Default Scraper").

    Bei den Dateimasken hab ich auch alles richtig eingegeben, da habe ich drauf geachtet.

    Ich verwende eine S905X Box, aber unter Retroarch funktioniert alles. Nur zwischen Retroarch und RCB läuft irgendwas schief. Nachfolgend noch die Log-Datei, wo ich ein Spiel anklicke und die Meldung erscheint "Spiel startet", jedoch nichts passiert:

    paste.ubuntu.com/p/nPwJGw2f3X/


    Danke schonmal für deine Mühe an der Stelle
    Meine Box: Amlogic S905X, 2GB Ram, LibreElec 8.2.3.1 / Kodi 17.6
  • Kupo91 schrieb:

    Ich hab jetzt nochmal alles an gescrapten Dateien, Config Files und Spieledatenbank rausgeworfen um ganz "clean" zu beginnen. Und alles unter Estuary. Hier ist die neue Log-Datei:

    paste.ubuntu.com/p/FKFx8rBrD9/

    Leider gleiches Ergebnis. PSX Roms werden nicht gescrapped, der Rest schon, allerdings nur zwei Spiele davon "richtig"

    In den Einstellungen hab ich alles default gelassen, auch beim Scraper ("Verwende konfigurierte Default Scraper").

    Bei den Dateimasken hab ich auch alles richtig eingegeben, da habe ich drauf geachtet.

    Ich verwende eine S905X Box, aber unter Retroarch funktioniert alles. Nur zwischen Retroarch und RCB läuft irgendwas schief. Nachfolgend noch die Log-Datei, wo ich ein Spiel anklicke und die Meldung erscheint "Spiel startet", jedoch nichts passiert:

    paste.ubuntu.com/p/nPwJGw2f3X/


    Danke schonmal für deine Mühe an der Stelle
    Bist du dir sicher dass deine PSX Roms wirklich die Endung "pbp" haben? Davon hab ich noch nie gehört bei Roms ^^
    Mein Humor ist so schwarz, in Amerika würde er von der Polizei erschossen.
  • Nevrion schrieb:

    Kupo91 schrieb:

    Ich hab jetzt nochmal alles an gescrapten Dateien, Config Files und Spieledatenbank rausgeworfen um ganz "clean" zu beginnen. Und alles unter Estuary. Hier ist die neue Log-Datei:

    paste.ubuntu.com/p/FKFx8rBrD9/

    Leider gleiches Ergebnis. PSX Roms werden nicht gescrapped, der Rest schon, allerdings nur zwei Spiele davon "richtig"

    In den Einstellungen hab ich alles default gelassen, auch beim Scraper ("Verwende konfigurierte Default Scraper").

    Bei den Dateimasken hab ich auch alles richtig eingegeben, da habe ich drauf geachtet.

    Ich verwende eine S905X Box, aber unter Retroarch funktioniert alles. Nur zwischen Retroarch und RCB läuft irgendwas schief. Nachfolgend noch die Log-Datei, wo ich ein Spiel anklicke und die Meldung erscheint "Spiel startet", jedoch nichts passiert:

    paste.ubuntu.com/p/nPwJGw2f3X/


    Danke schonmal für deine Mühe an der Stelle
    Bist du dir sicher dass deine PSX Roms wirklich die Endung "pbp" haben? Davon hab ich noch nie gehört bei Roms ^^

    Ja, ich hab sie so konvertiert. Ich hatte ursprünglich tausend verschiedene Formate. Bin mit Cue, Bin ohne Cue, Iso, Mehrere Bins in einem Spiel mit Cue, Mehrere Bins in einem Spiel ohne Cue. Dann hab ich irgendwo gelesen, dass viele ihre PSX Roms in pbp konvertieren. Das hat den Vorteil, dass man nur noch eine Datei pro Spiel hat, außerdem werden die Spiele dabei stark komprimiert. Ich hatte danach anstatt 30 gb nur noch 20 gb PSX Roms. Außerdem kann man Spiele mit mehreren CDs in eine einzelne Datei einschließen und brauch nicht mehr für jede CD eine eigene. Das Tool, mit dem man die Roms konvertiert heißt psx2psp und ist wohl sogar von Sony selbst. *.pbp ist das Format für die PSP und mit dem Tool sollen die Leute die Möglichkeit haben ihre Playstationspiele für die PSP konvertieren zu können. Das Format wird aber auch vom normalen PSX Emulator abgespielt. Sowohl auf dem PC, als auch in Retroarch ausprobiert
    Meine Box: Amlogic S905X, 2GB Ram, LibreElec 8.2.3.1 / Kodi 17.6

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Kupo91 ()

  • @malte
    Nochmal zu dem Problem das ich neulich erwähnt habe von wegen ich kann nicht auf den lokalen Speicher der SHIELD zugreifen mit den Leia Alphas...das Problem ist weiterhin drin...was ich aber jetzt noch festgestellt habe, er lässt mich nachdem ich das zu emulierende System ausgewählt habe auch gar nicht ein Verzeichnis auswählen sondern will den Pfad zum Emulator haben, die PreBuilds für Android werden nicht geladen, weder in Krypton noch in Leia...gabs da ne Änderung oder kann das an Android 8 liegen?
    Mein Humor ist so schwarz, in Amerika würde er von der Polizei erschossen.