Die neue ZDF Mediathek...

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ich habe gestern die membrane Repo auf meinem Raspberry mit OpenElec (Kodi 15.2) installiert. Erst kam die oben schon beschriebene Meldung, daß Abhängigkeiten nicht erfüllt werden. Ich habe daraufhin die ZDF-Mediathek deinstalliert und das libMediathek-Script von Hand hinterher installiert. Dann wollte ich die ZDF-Mediathek wieder installieren, aber sie ist nicht mehr zu finden, weder in der membrane Repo noch in der offiziellen Kodi Repo ?( . Auch nach einem Reset des gesamten Systems auf "Werkseinstellung" und Neuinstallation der Repo ist das Addon nicht zu finden.

    Kann mir jemand auf die Sprünge helfen?!

    Gruß
    hochsitzcola
  • Ein bisschen bin ich weitergekommen, ich hatte in den Einstellungen das Häkchen bei "nicht kompatible Addons ausblenden" gesetzt. Jetzt kann ich die ZDF Mediathek wieder sehen, sie lässt sich halt nicht installieren, da sie als "nicht kompatibel" gekennzeichnet ist....
    Vielleicht ist das ein Openelec-spezifisches Problem?!
    Im Openelec-Forum ist das Thema auch schon diskutiert worden, dort wird ein Workaround vorgeschlagen, ich sehe aber in der membrane repo kein plugin.video.mediathek :/

    Gruß
    hochsitzcola
  • So, ich habe es nun hinbekommen. 8o
    1. Das komplete Repo als zip heruntergeladen und auf einen USB Stick entpackt.

    2. im zip/addon.xml von script.module.libmediathek3-1.2.3 die XBMC-Version auf 2.1.0 geändert

    Quellcode

    1. <import addon="xbmc.python" version="2.24.0" />

    3. im zip/addon.xml von script.module.libZdf die libmediathek3-Version auf 1.2.3 geändert

    Quellcode

    1. <import addon="script.module.libmediathek3" version="1.1.16"/>


    4. im zip/addon.xml von plugin.video.zdf_de_lite die libMediathek2-Version auf 1.1.16 geändert

    Quellcode

    1. <import addon="script.module.libMediathek2" version="1.2.0"/>
    5. dann in dieser Reihenfolge die geänderten zips von Hand installiert
    --> 1. libmediathek2
    --> 2. libmediathek3
    --> 3. libZdf
    --> 4. zdf_de_lite

    Gruß
    hochsitzcola
  • Hmm, hast du wirklich die xml-Dateien innerhalb der zip-files geändert?
    Kannst du die ARD-Mediathek installieren?
    Welche Kodi-Version hast du?

    Gruß
    hochsitzcola

    edit: ich habe tatsächlich keine Ahnung, welche meiner Aktionen zum Erfolg geführt hat. Vielleicht kann hier jemand mit mehr Kenntnis der Materie Licht ins Dunkle bringen.
    Ob diese Versionsnummern-Editiererei wirklich in Summe hilfreich ist, weiß ich nicht. Es gibt noch weitere Inkonsistenzen in den den Versions-Bezügen, funktionieren tut es trotzdem...

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von hochsitzcola ()

  • @hochsitzcola: Ich kann deine Vorgehensweise als zielführend bestätigen.

    Installation aus dem membrane Repo: Aufgrund Abhängigkeiten nicht möglich
    Installation entpackt nach Änderung der o.g. addon.xml: Installation möglich, Funktion gegeben

    Kodi Version 15.2 auf Raspbian, aktuellste Version aus dem membrane Repo von 06.01.17.

    @membrane: möglicherweise gibt es Fehler bei den Abhängigkeiten in deinen Repos wodurch eine Installation fehlschlägt. Falls du Zeit findest, wäre es super, wenn diese behoben werden könnten, damit (auch bei Updates) keine händischen Änderungen vorgenommen werden müssen.
    Vielen Dank für deine tolle Arbeit!!

    Grüße
    Raemsna
  • Hallo zusammen,

    Ich habe heute die ZDF Mediathek aus Membranes Repo auf meinem FireTV 2 mit KODI 17 RC2 (frische Installation) installiert. Das browsen durch die Inhalte funktioniert soweit. Aber die Videos laufen nicht korrekt. Z.B. habe ich "Bares für Rares" ausprobiert. Nach sehr langer Wartezeit startet das Video, aber nicht am Anfang, sondern einige Sekunden nach Beginn. Der Ton läuft dann sauber weiter, aber Bild hakt, ruckelt und springt ihm hinterher. Unter KODI 16.1 hat es problemlos funktioniert und auch in der ZDF App des FireTV laufen die Videos fehlerfrei.

    /Edit: Bei Sendungen der ARD Mediathek tritt übrigens kein Problem auf. Da läuft alles rund.

    Danke für eure Hilfe,
    Key2k
    KODI: 17.0
    Skin: Estuary
    Hardware: Amazon FireTV 4k
    Video/Sound: via HDMI and harman/kardon AVR-270 on Samsung UE46ES7090
    LIVE-TV: TVheadend on Synology and FRITZ!Repeater DVB-C
    Remote: Logitech Harmony Ultimate

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von keyboarder2k ()

  • Hallo zusammen seit ein paar Tagen läuft das addon ZDF Mediathek Version 3.1.2 bei mir nicht mehr, am System wurde nichts geändert. Bei mir läuft LibreElec Alfa 7.9.010 Kodi v17.0-beta7 auf einem Raspberry Pi 3. Beim öffnen des addon bekomme ich sofort eine Fehlermeldung.
    Ich hänge mal die log Datei an vielleicht hilft es weiter .
    Dateien
    • 01_KODI.log

      (816,96 kB, 11 mal heruntergeladen, zuletzt: )
  • @membrane / @LORE Ich bin mim ZDF 3.1.2 leider auch nicht zum Ziel gekommen
    Mein Fehler deckt sich mit dem Eintrag meines Vorredners.

    Irgendwas löschen?

    Edit: hat sich erledigt, es wurde aus irgendwelchen Gründen die falsche libMediathek aus dem kodi repo installiert.
    Ich bin in kodi auf "letzte Aktualisierungen" gegangen, habe dann libmediathek3 auf membranes version geupdatet.
    Alles gut jetzt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von peak3d ()

  • Neu

    Hallo,
    zunächst mal einen herzlichen Dank an alle, die hier aktiv sind. Für mich ist das hin und wieder sehr hilfreich. Nun bin ich aber leider etwas hilflos - wohl wissend, dass ich keinen ausführlichen Support erwarten kann.

    Ich nutze seit Jahren Openelec/KODI auf einem Raspberry und mit der Zeit hatte ich mir das alles schön hingebastelt, wie es es brauchte - nutze vor allem die Mediatheken von ZDF, ARD etc. Alles super :) Bis zu dem Tage im letzten Jahr, wo das ZDF seine tolle neue Mediathek eröffnete. Seit dem funktionierte irgendwie nix mehr so richtig. Einen Teil von membranes Addons habe ich mit viel Frickelei ans Laufen bekommen, ein Teil verweigerte wegen irgendwelcher Abhängigkeiten komplett die Zusammenarbeit.

    Nun hatte sich auch noch das Dateisystem geschrottet - SD-Karte ist wohl hin - und ich machte mich schweren Herzens an einen kompletten Neuanfang (Openelec 7.01), da ich hoffte, nun alle vielleicht von mir eingebauten Verknotungen hinter mir zu lassen. Leider bekomme ich die Addons von membrane nach der Installation des Repository nicht ans Laufen. Ich verzweifel an den nicht gelösten Abhängigkeiten. Was müsste ich noch installieren, um die Abhängkeiten aufzulösen? Ich blicke es irgendwie nicht.

    Über einen Hinweis bin ich sehr, sehr dankbar :)

    Viele Grüße
    Der Ahnungslose
  • Neu

    Bei mir läuft sie seit dem Wochenende auch nicht mehr! Habe leider null Plan warum!

    Hier mal ein Auszug aus dem Log:

    Spoiler anzeigen

    15:24:14.052 T:140130098931456 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
    Error Type: <class 'urllib2.HTTPError'>
    Error Contents: HTTP Error 403: Forbidden
    Traceback (most recent call last):
    File "/home/kodi/.kodi/addons/plugin.video.zdf_de_lite/default.py", line 5, in <module>
    libzdf.list()
    File "/home/kodi/.kodi/addons/script.module.libzdf/lib/libzdf.py", line 100, in list
    libMediathek.play(libZdfPlay())
    File "/home/kodi/.kodi/addons/script.module.libzdf/lib/libzdf.py", line 47, in libZdfPlay
    return libZdfJsonParser.getVideoUrl(params['url'])
    File "/home/kodi/.kodi/addons/script.module.libzdf/lib/libzdfjsonparser.py", line 142, in getVideoUrl
    response = libMediathek.getUrl(url,getheader)
    File "/home/kodi/.kodi/addons/script.module.libmediathek3/lib/libmediathek3utils.py", line 25, in getUrl
    return _request(url,headers)
    File "/home/kodi/.kodi/addons/script.module.libmediathek3/lib/libmediathek3utils.py", line 35, in _request
    response = urllib2.urlopen(req)
    File "/usr/lib/python2.7/urllib2.py", line 154, in urlopen
    return opener.open(url, data, timeout)
    File "/usr/lib/python2.7/urllib2.py", line 435, in open
    response = meth(req, response)
    File "/usr/lib/python2.7/urllib2.py", line 548, in http_response
    'http', request, response, code, msg, hdrs)
    File "/usr/lib/python2.7/urllib2.py", line 473, in error
    return self._call_chain(*args)
    File "/usr/lib/python2.7/urllib2.py", line 407, in _call_chain
    result = func(*args)
    File "/usr/lib/python2.7/urllib2.py", line 556, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
    HTTPError: HTTP Error 403: Forbidden
    -->End of Python script error report<--
    15:24:14.077 T:140132122335616 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.zdf_de_lite/?url=https%3A%2F%2Fapi.zdf.de%2Ftmd%2F2%2Fngplayer_2_3%2Fvod%2Fptmd%2Fmediathek%2F170217_sendung_nano&mode=libZdfPlay]
    15:24:17.724 T:140130923407104 ERROR: Unable to find plugin
    15:24:17.724 T:140132122335616 ERROR: GetDirectory - Error getting plugin://
    15:24:17.724 T:140132122335616 ERROR: CGUIMediaWindow::GetDirectory(plugin://) failed

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von FoxBob79 ()